aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authortastytea <gentoo@tastytea.de>2023-11-03 15:08:19 +0100
committertastytea <gentoo@tastytea.de>2023-11-03 18:42:32 +0100
commitd0c24593742e5e96165c08c52889be3ba7f59abb (patch)
tree29ad52e10cd63c2603c4e2df3f553ad645f32644 /x11-apps
parentmedia-sound/yewtube: fix does not enable tests (diff)
downloadguru-d0c24593742e5e96165c08c52889be3ba7f59abb.tar.gz
guru-d0c24593742e5e96165c08c52889be3ba7f59abb.tar.bz2
guru-d0c24593742e5e96165c08c52889be3ba7f59abb.zip
x11-apps/xcur2png: update EAPI 7 -> 8, fix CFLAGS
Closes: https://bugs.gentoo.org/916457 Signed-off-by: tastytea <gentoo@tastytea.de>
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/xcur2png/xcur2png-0.7.1-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/x11-apps/xcur2png/xcur2png-0.7.1-r1.ebuild b/x11-apps/xcur2png/xcur2png-0.7.1-r1.ebuild
new file mode 100644
index 000000000..631989932
--- /dev/null
+++ b/x11-apps/xcur2png/xcur2png-0.7.1-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic
+
+DESCRIPTION="Convert X cursors to PNG images"
+HOMEPAGE="https://github.com/eworm-de/xcur2png"
+SRC_URI="https://github.com/eworm-de/xcur2png/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ media-libs/libpng
+ x11-libs/libXcursor
+"
+
+src_configure() {
+ append-cflags "-std=gnu89" # bug 916457
+ default
+}