aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2024-10-30 10:47:33 -0700
committerorbea <orbea@riseup.net>2024-10-30 10:58:37 -0700
commitcaa67c4d712018a760cacd91f0893adfe1cc0c1d (patch)
treebd8ac89297612620922e6602d17404b4a586b9c2 /dev-python
parentdev-python/m2crypto: stabilize 0.42.0 for ppc64 (diff)
downloadlibressl-caa67c4d712018a760cacd91f0893adfe1cc0c1d.tar.gz
libressl-caa67c4d712018a760cacd91f0893adfe1cc0c1d.tar.bz2
libressl-caa67c4d712018a760cacd91f0893adfe1cc0c1d.zip
dev-python/m2crypto: drop 0.41.0
Signed-off-by: orbea <orbea@riseup.net>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/m2crypto/Manifest1
-rw-r--r--dev-python/m2crypto/m2crypto-0.41.0.ebuild75
2 files changed, 0 insertions, 76 deletions
diff --git a/dev-python/m2crypto/Manifest b/dev-python/m2crypto/Manifest
index c190318..97f6e8c 100644
--- a/dev-python/m2crypto/Manifest
+++ b/dev-python/m2crypto/Manifest
@@ -1,2 +1 @@
-DIST M2Crypto-0.41.0.tar.gz 1151680 BLAKE2B 6c5294294fd62ca69eec8222324ce8a1012c999aab241eba2e5b0085c0d7b598fd62f26e106bea95bfad3199abb2db9876547f521b34f45930b00540a6ecc24a SHA512 50ca5e32ae999b9ecdc7f3bbd35221b4a7523ef29e54eb4bc266457723117718955f99b9e7ac42a4cb982f0e22a94e5c852d6886d7dfb157d040ad86c17660fb
DIST m2crypto-0.42.0.tar.gz 240072 BLAKE2B 86b9f340eb90a8fc94b09faa20a676a3a63c0c64a0902a6729face72b602a2f55941c156ecb3d522a823457d2514e96b147585264200674e11dfaba3d19790de SHA512 b36fb6d1ca401de9741118ab8d43113511bf27d32f45d2257ed70ea8d3b8a3beaf811731dbbece00a6b990366c43096c6b5f5b12d4649ae923bff98c5fc8e674
diff --git a/dev-python/m2crypto/m2crypto-0.41.0.ebuild b/dev-python/m2crypto/m2crypto-0.41.0.ebuild
deleted file mode 100644
index 6281185..0000000
--- a/dev-python/m2crypto/m2crypto-0.41.0.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 2018-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-PYPI_NO_NORMALIZE=1
-PYPI_PN="M2Crypto"
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1 toolchain-funcs pypi
-
-DESCRIPTION="A Python crypto and SSL toolkit"
-HOMEPAGE="
- https://gitlab.com/m2crypto/m2crypto/
- https://pypi.org/project/M2Crypto/
-"
-
-# openssl via src/SWIG/_lib11_compat.i
-LICENSE="MIT openssl"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
-IUSE="abi_mips_n32 abi_mips_n64 abi_mips_o32"
-
-DEPEND="
- dev-libs/openssl:=
-"
-RDEPEND="
- ${DEPEND}
-"
-BDEPEND="
- >=dev-lang/swig-2.0.9
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-libressl-0.38.0.patch
-)
-
-swig_define() {
- local x
- for x; do
- if tc-cpp-is-true "defined(${x})"; then
- SWIG_FEATURES+=" -D${x}"
- fi
- done
-}
-
-src_prepare() {
- # relies on very exact clock behavior which apparently fails
- # with inconvenient CONFIG_HZ*
- sed -e 's:test_server_simple_timeouts:_&:' \
- -i tests/test_ssl.py || die
- distutils-r1_src_prepare
-}
-
-python_compile() {
- # setup.py looks at platform.machine() to determine swig options.
- # For exotic ABIs, we need to give swig a hint.
- local -x SWIG_FEATURES=
-
- # https://bugs.gentoo.org/617946
- swig_define __ILP32__
-
- # https://bugs.gentoo.org/674112
- swig_define __ARM_PCS_VFP
-
- distutils-r1_python_compile
-}
-
-python_test() {
- "${EPYTHON}" -m unittest -b -v tests.alltests.suite ||
- die "Tests failed for ${EPYTHON}"
-}