summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2024-09-29 11:32:35 +0200
committerFabian Groffen <grobian@gentoo.org>2024-09-29 11:32:35 +0200
commit507d785ace4872b9a098a41b0f71545178b76942 (patch)
treea1376f6bf3cac40454b7deeb195fe973b9c5c0bd /sys-devel/gcc/gcc-14.2.0.ebuild
parentsys-devel/gcc-14.2.0: avoid using incompatible __FLT_EVAL_METHOD__ (diff)
downloadprefix-507d785ace4872b9a098a41b0f71545178b76942.tar.gz
prefix-507d785ace4872b9a098a41b0f71545178b76942.tar.bz2
prefix-507d785ace4872b9a098a41b0f71545178b76942.zip
sys-devel/gcc: replace USE=bootstrap with USE=system-bootstrap
Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'sys-devel/gcc/gcc-14.2.0.ebuild')
-rw-r--r--sys-devel/gcc/gcc-14.2.0.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/sys-devel/gcc/gcc-14.2.0.ebuild b/sys-devel/gcc/gcc-14.2.0.ebuild
index 7fe17192e3..aed471b324 100644
--- a/sys-devel/gcc/gcc-14.2.0.ebuild
+++ b/sys-devel/gcc/gcc-14.2.0.ebuild
@@ -32,7 +32,7 @@ fi
# use alternate source for Apple M1 (also works for x86_64)
SRC_URI+=" elibc_Darwin? ( https://raw.githubusercontent.com/Homebrew/formula-patches/d5dcb918a951b2dcf2d7702db75eb29ef144f614/gcc/gcc-14.2.0.diff -> gcc-14.2.0-arm64-darwin.patch )"
-IUSE+=" bootstrap"
+IUSE+=" system-bootstrap"
if [[ ${CATEGORY} != cross-* ]] ; then
# Technically only if USE=hardened *too* right now, but no point in complicating it further.
@@ -77,7 +77,7 @@ src_prepare() {
fi
if [[ ${CHOST} == *-darwin* ]] ; then
- use bootstrap && eapply "${FILESDIR}"/${PN}-13-darwin14-bootstrap.patch
+ use system-bootstrap && eapply "${FILESDIR}"/${PN}-13-darwin14-bootstrap.patch
# our ld64 is a slight bit different, so tweak expression to not
# get confused and break the build