summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Hernández Hernández <leohdz172@proton.me>2023-09-11 23:23:37 -0600
committerSam James <sam@gentoo.org>2023-09-13 04:48:04 +0100
commit05bac447ab803c37e8b221eab87418f6e144df1d (patch)
tree4c297e342a3bd646b1a136d24024cd4ee8c7f76f
parentapp-admin/logsentry: update EAPI 6 -> 8 (diff)
downloadgentoo-05bac447ab803c37e8b221eab87418f6e144df1d.tar.gz
gentoo-05bac447ab803c37e8b221eab87418f6e144df1d.tar.bz2
gentoo-05bac447ab803c37e8b221eab87418f6e144df1d.zip
app-admin/longrun: update EAPI 6 -> 8
Signed-off-by: Leonardo Hernández Hernández <leohdz172@proton.me> Closes: https://github.com/gentoo/gentoo/pull/32719 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-admin/longrun/Manifest1
-rw-r--r--app-admin/longrun/longrun-0.9-r5.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/app-admin/longrun/Manifest b/app-admin/longrun/Manifest
index 15924ea63ff0..060152338bf7 100644
--- a/app-admin/longrun/Manifest
+++ b/app-admin/longrun/Manifest
@@ -1,2 +1,3 @@
DIST longrun-0.9.tar.bz2 11539 BLAKE2B a308dc7f350399da0bf593e2eee8109a90103b298d943976f0da143c52105362aa100763dcdd3cacd4c3244cdd5a7eb9a1b355aa803a69a2225ea18c6e5a60dd SHA512 6b38160f54d0cb9124c46c0e3ba22faf4ba4376ef58f7db40aabbab20836b1551dd839d28e5bf49540a5ce0e13312bd1d7332cc59ce45fa49f81d0b9746ef055
DIST longrun_0.9-19.diff.gz 14697 BLAKE2B 98a7497679df5be0346a37b6119a9418c7fba80672eb2c345784628c3517c6f1fbc8d953abe2696a3b576310cd489e5c1d3595153bbfa9d82dfb44697c246116 SHA512 591519183017dd84d6f78554eea9f215be9346efc3f30889f5a25d01c6b68bd5a949507b9a0c871f9aca0b49e415c4fa261821d4158b24c93481394403b83e35
+DIST longrun_0.9-22.diff.gz 15714 BLAKE2B a132fcd5925b4868c767a43bc5e3428bc2731ffdc3678207442bd538db0bef79a1f50877679907dbd4a131aa807001d8bee602abc94ae086ec1ec458ec68a12d SHA512 6addb2a4070a4b105cbdd1ef96d3d99fbcbab5f6026fb2fcf8d6a702a60548e1ac9249c44e6359fcf46eab83da7529a6715a6ae77f8750f4be19d42ab83f51f8
diff --git a/app-admin/longrun/longrun-0.9-r5.ebuild b/app-admin/longrun/longrun-0.9-r5.ebuild
new file mode 100644
index 000000000000..1cbda722a3ef
--- /dev/null
+++ b/app-admin/longrun/longrun-0.9-r5.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info toolchain-funcs
+
+DESCRIPTION="A utility to control Transmeta's Crusoe and Efficeon processors"
+HOMEPAGE="http://freshmeat.net/projects/longrun/"
+
+DEBIAN_PATCH_VERSION="22"
+DEBIAN_PATCH="${PN}_${PV}-${DEBIAN_PATCH_VERSION}.diff"
+SRC_URI="
+ https://www.kernel.org/pub/linux/utils/cpu/crusoe/${P}.tar.bz2
+ mirror://debian/pool/main/l/${PN}/${DEBIAN_PATCH}.gz"
+S="${WORKDIR}/${PN}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-ppc ~x86"
+
+BDEPEND="sys-apps/groff"
+
+DOCS=( MAKEDEV-cpuid-msr )
+
+CONFIG_CHECK="~X86_MSR ~X86_CPUID"
+ERROR_X86_MSR="
+Longrun needs a MSR device to function. Please select
+MSR under Processor type and features. It can be build
+directly into the kernel or as a module."
+ERROR_X86_CPUID="
+Longrun needs a CPUID device to function. Please select
+CPUID under Processor type and features. It can be
+build directly into the kernel or as a module."
+
+PATCHES=(
+ "${WORKDIR}"/${DEBIAN_PATCH}
+ "${FILESDIR}"/${PV}-makefile_cflags.patch
+ "${FILESDIR}"/${PV}-replace-loff_t.patch
+)
+
+src_configure() {
+ tc-export CC
+ default
+}
+
+pkg_postinst() {
+ if linux_config_exists; then
+ if linux_chkconfig_module X86_MSR; then
+ elog "You have compiled MSR as a module."
+ elog "You need to load it before using Longrun."
+ elog "The module is called msr."
+ elog
+ fi
+
+ if linux_chkconfig_module X86_CPUID; then
+ elog "You have compiled CPUID as a module."
+ elog "You need to load it before using Longrun."
+ elog "The module is called cpuid."
+ fi
+ else
+ elog "You have no kernel configuration available."
+ elog "Longrun needs both CPUID and MSR capabilites,"
+ elog "in the kernel you intend to run it under."
+ fi
+}