summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2024-12-08 10:47:49 +0000
committerPatrick Lauer <patrick@gentoo.org>2024-12-08 11:00:31 +0000
commit064e2f6089e504c606d87000ded3fb0bbb4f9abd (patch)
tree68af7294ef5e1fdcf51e1ee186313068509dd8b2
parentsys-cluster/pmix: add 5.0.4 (diff)
downloadgentoo-064e2f6089e504c606d87000ded3fb0bbb4f9abd.tar.gz
gentoo-064e2f6089e504c606d87000ded3fb0bbb4f9abd.tar.bz2
gentoo-064e2f6089e504c606d87000ded3fb0bbb4f9abd.zip
sys-cluster/prrte: add 3.0.7
Signed-off-by: Patrick Lauer <patrick@gentoo.org>
-rw-r--r--sys-cluster/prrte/Manifest1
-rw-r--r--sys-cluster/prrte/prrte-3.0.7.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/sys-cluster/prrte/Manifest b/sys-cluster/prrte/Manifest
index 000d5865482f..831bd80dff96 100644
--- a/sys-cluster/prrte/Manifest
+++ b/sys-cluster/prrte/Manifest
@@ -1 +1,2 @@
DIST prrte-3.0.6.tar.gz 5976755 BLAKE2B 62cff51ebb7e72c32a237eb36db925f5bf5811cf5f409619128fa8ef490d3ba9e6ba4a1701edd21486878974088ff17645c98dab12904abd48c4a4b50453f807 SHA512 f7d3a1bedc0029fcb0e4e906a099d1de07b171805f0cc8d6e443826b8c321e3d5e7fa80867d8ab9ae1f628446a1a8f663231d8b67e243650582225805adc6e9d
+DIST prrte-3.0.7.tar.gz 5592294 BLAKE2B e12133f2d6515620bce639faa1b439947a5fd50bfdbf5d0c855e9ce138b82da452776bb92a326dcfe1b2b43be8b31dade528f0230b40ad5b38586ca6c0ee5c42 SHA512 34b032ba461d095d549af0580fa7366290cdb54c22056dad71a24c85a6dcbd3614f69bc01892a8b2505f406ae728f6d7520a0f03a597ee0ab0208091d5319e18
diff --git a/sys-cluster/prrte/prrte-3.0.7.ebuild b/sys-cluster/prrte/prrte-3.0.7.ebuild
new file mode 100644
index 000000000000..6790ea5231fa
--- /dev/null
+++ b/sys-cluster/prrte/prrte-3.0.7.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic libtool
+
+DESCRIPTION="PMIx Reference RunTime Environment"
+HOMEPAGE="https://openpmix.github.io/"
+SRC_URI="https://github.com/openpmix/prrte/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm64 ~ppc64"
+
+DEPEND="
+ dev-libs/libevent:=
+ sys-apps/hwloc:=
+ >=sys-cluster/pmix-4.2.4
+"
+RDEPEND="${DEPEND}"
+
+# There is no testsuite at least today.
+RESTRICT="test"
+
+src_prepare() {
+ default
+ elibtoolize
+}
+
+src_configure() {
+ # -Werror=lto-type-mismatch
+ #
+ # Same issue as its companion project sys-cluster/pmix, and logically
+ # solvable in tandem (or never).
+ # https://github.com/openpmix/openpmix/issues/3350
+ filter-lto
+
+ econf
+}
+
+src_install() {
+ default
+ find "${ED}" -type f -name '*.la' -delete || die
+}