summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2017-03-11 23:29:05 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2017-03-11 23:29:15 +0100
commit0fd2408ad935cea3de87948a84d0ea67e22ffc6c (patch)
tree11d591dd9375567da8cfcac14d65f555e5057ea3
parentnet-misc/smb4k: Drop old (diff)
downloadgentoo-0fd2408ad935cea3de87948a84d0ea67e22ffc6c.tar.gz
gentoo-0fd2408ad935cea3de87948a84d0ea67e22ffc6c.tar.bz2
gentoo-0fd2408ad935cea3de87948a84d0ea67e22ffc6c.zip
app-text/tuxcards: EAPI bump
Package-Manager: Portage-2.3.4, Repoman-2.3.2
-rw-r--r--app-text/tuxcards/tuxcards-2.2.1-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-text/tuxcards/tuxcards-2.2.1-r1.ebuild b/app-text/tuxcards/tuxcards-2.2.1-r1.ebuild
new file mode 100644
index 000000000000..0f0a61f134e7
--- /dev/null
+++ b/app-text/tuxcards/tuxcards-2.2.1-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils qmake-utils
+
+DESCRIPTION="A hierarchical notebook"
+HOMEPAGE="http://www.tuxcards.de/"
+SRC_URI="http://www.tuxcards.de/src/${P}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="dev-qt/qtgui:4"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PN}
+
+src_configure() {
+ eqmake4 tuxcards.pro
+}
+
+src_install() {
+ dobin ${PN}
+ newicon src/icons/lo32-app-tuxcards.png ${PN}.png
+ make_desktop_entry ${PN} TuxCards ${PN} "Qt;Utility"
+ dodoc AUTHORS README
+}