summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2024-10-19 18:48:16 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2024-10-19 18:48:16 +0000
commit13a45862f3bb51e03d7f77b68fca7c793898dcac (patch)
treeb58f4000c536afe19fd1c4c705cb830f5cc6adf1
parent2024-10-19 18:33:25 UTC (diff)
parentsci-chemistry/gromacs: Correct depend when openmp is enabled (diff)
downloadgentoo-13a45862f3bb51e03d7f77b68fca7c793898dcac.tar.gz
gentoo-13a45862f3bb51e03d7f77b68fca7c793898dcac.tar.bz2
gentoo-13a45862f3bb51e03d7f77b68fca7c793898dcac.zip
Merge updates from master
-rw-r--r--dev-python/xarray/xarray-2024.9.0.ebuild2
-rw-r--r--sci-chemistry/gromacs/files/gromacs-9999-Fix-build-with-torch.patch40
-rw-r--r--sci-chemistry/gromacs/gromacs-2020.7-r1.ebuild4
-rw-r--r--sci-chemistry/gromacs/gromacs-2021.7-r1.ebuild4
-rw-r--r--sci-chemistry/gromacs/gromacs-2022.6.ebuild4
-rw-r--r--sci-chemistry/gromacs/gromacs-2023.5.ebuild4
-rw-r--r--sci-chemistry/gromacs/gromacs-2023.9999.ebuild4
-rw-r--r--sci-chemistry/gromacs/gromacs-2024.3.ebuild4
-rw-r--r--sci-chemistry/gromacs/gromacs-2024.9999.ebuild4
-rw-r--r--sci-chemistry/gromacs/gromacs-9999.ebuild21
-rw-r--r--sci-chemistry/gromacs/metadata.xml1
11 files changed, 88 insertions, 4 deletions
diff --git a/dev-python/xarray/xarray-2024.9.0.ebuild b/dev-python/xarray/xarray-2024.9.0.ebuild
index 5d61b536a260..2e924b5a050b 100644
--- a/dev-python/xarray/xarray-2024.9.0.ebuild
+++ b/dev-python/xarray/xarray-2024.9.0.ebuild
@@ -17,7 +17,7 @@ HOMEPAGE="
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+KEYWORDS="amd64 ~arm64 ~riscv ~x86"
IUSE="big-endian"
RDEPEND="
diff --git a/sci-chemistry/gromacs/files/gromacs-9999-Fix-build-with-torch.patch b/sci-chemistry/gromacs/files/gromacs-9999-Fix-build-with-torch.patch
new file mode 100644
index 000000000000..f4f3698d96db
--- /dev/null
+++ b/sci-chemistry/gromacs/files/gromacs-9999-Fix-build-with-torch.patch
@@ -0,0 +1,40 @@
+From d997978fc0c644784ed929b0c48e153d5c1f1408 Mon Sep 17 00:00:00 2001
+From: Alexey Shvetsov <alexxyum@gmail.com>
+Date: Sat, 19 Oct 2024 21:22:07 +0300
+Subject: [PATCH] Fix build with torch if non default C{XX}_FLAGS set
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+This should fix build colvars with torch if torch was built with non
+default C{,XX}_FLAGS
+
+Erorr info:
+
+FAILED: src/gromacs/CMakeFiles/colvars_objlib.dir/__/external/colvars/colvar.cpp.o
+/usr/bin/x86_64-pc-linux-gnu-g++ -DCOLVARS_TORCH -DGMX_DOUBLE=0 -I/usr/include/torch/csrc/api/include -O2 -pipe -march=skylake -mtune=skylake -std=c++17 -fPIC "-O2 -pipe -march=skylake -mtune=skylake" -D_GLIBCXX_USE_CXX11_ABI=1 -fopenmp -MD -MT src/gromacs/CMakeFiles/colvars_objlib.dir/__/external/colvars/colvar.cpp.o -MF src/gromacs/CMakeFiles/colvars_objlib.dir/__/external/colvars/colvar.cpp.o.d -o src/gromacs/CMakeFiles/colvars_objlib.dir/__/external/colvars/colvar.cpp.o -c /var/tmp/portage/sci-chemistry/gromacs-9999/work/gromacs-9999/src/external/colvars/colvar.cpp
+cc1plus: error: argument to ‘-O’ should be a non-negative integer, ‘g’, ‘s’, ‘z’ or ‘fast’
+
+This caused by doubling quoted C{,XX}_FLAGS
+
+Signed-off-by: Alexey Shvetsov <alexxyum@gmail.com>
+---
+ cmake/gmxManageColvars.cmake | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/cmake/gmxManageColvars.cmake b/cmake/gmxManageColvars.cmake
+index 509d56e116..f49c820fa0 100644
+--- a/cmake/gmxManageColvars.cmake
++++ b/cmake/gmxManageColvars.cmake
+@@ -52,7 +52,7 @@ function(gmx_manage_colvars)
+ target_link_libraries(colvars_objlib PRIVATE OpenMP::OpenMP_CXX)
+ endif()
+ if(GMX_TORCH)
+- target_compile_options(colvars_objlib PRIVATE ${CMAKE_CXX_FLAGS} ${TORCH_CXX_FLAGS})
++ target_compile_options(colvars_objlib PRIVATE ${CMAKE_CXX_FLAGS})
+ target_include_directories(colvars_objlib PRIVATE ${TORCH_INCLUDE_DIRS})
+ target_compile_definitions(colvars_objlib PRIVATE -DCOLVARS_TORCH)
+ endif()
+--
+2.47.0
+
diff --git a/sci-chemistry/gromacs/gromacs-2020.7-r1.ebuild b/sci-chemistry/gromacs/gromacs-2020.7-r1.ebuild
index fa123d04defb..c93e5baf72ef 100644
--- a/sci-chemistry/gromacs/gromacs-2020.7-r1.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2020.7-r1.ebuild
@@ -49,6 +49,10 @@ CDEPEND="
blas? ( virtual/blas )
cuda? ( >=dev-util/nvidia-cuda-toolkit-6.5.14:= )
opencl? ( virtual/opencl )
+ openmp? (
+ sys-devel/gcc[openmp]
+ sys-devel/clang-runtime[openmp]
+ )
fftw? ( sci-libs/fftw:3.0= )
hwloc? ( sys-apps/hwloc:= )
lapack? ( virtual/lapack )
diff --git a/sci-chemistry/gromacs/gromacs-2021.7-r1.ebuild b/sci-chemistry/gromacs/gromacs-2021.7-r1.ebuild
index 1b82d86998ee..8b99117678ed 100644
--- a/sci-chemistry/gromacs/gromacs-2021.7-r1.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2021.7-r1.ebuild
@@ -49,6 +49,10 @@ CDEPEND="
blas? ( virtual/blas )
cuda? ( >=dev-util/nvidia-cuda-toolkit-6.5.14:=[profiler] )
opencl? ( virtual/opencl )
+ openmp? (
+ sys-devel/gcc[openmp]
+ sys-devel/clang-runtime[openmp]
+ )
fftw? ( sci-libs/fftw:3.0= )
hwloc? ( sys-apps/hwloc:= )
lapack? ( virtual/lapack )
diff --git a/sci-chemistry/gromacs/gromacs-2022.6.ebuild b/sci-chemistry/gromacs/gromacs-2022.6.ebuild
index 8ebb3ae9a8dd..92b1f497c860 100644
--- a/sci-chemistry/gromacs/gromacs-2022.6.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2022.6.ebuild
@@ -45,6 +45,10 @@ CDEPEND="
blas? ( virtual/blas )
cuda? ( >=dev-util/nvidia-cuda-toolkit-11:=[profiler] )
opencl? ( virtual/opencl )
+ openmp? (
+ sys-devel/gcc[openmp]
+ sys-devel/clang-runtime[openmp]
+ )
fftw? ( sci-libs/fftw:3.0= )
hwloc? ( sys-apps/hwloc:= )
lapack? ( virtual/lapack )
diff --git a/sci-chemistry/gromacs/gromacs-2023.5.ebuild b/sci-chemistry/gromacs/gromacs-2023.5.ebuild
index a3319899d419..4ee08b22a7f0 100644
--- a/sci-chemistry/gromacs/gromacs-2023.5.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2023.5.ebuild
@@ -45,6 +45,10 @@ CDEPEND="
blas? ( virtual/blas )
cuda? ( >=dev-util/nvidia-cuda-toolkit-11:=[profiler] )
opencl? ( virtual/opencl )
+ openmp? (
+ sys-devel/gcc[openmp]
+ sys-devel/clang-runtime[openmp]
+ )
fftw? ( sci-libs/fftw:3.0= )
hwloc? ( sys-apps/hwloc:= )
lapack? ( virtual/lapack )
diff --git a/sci-chemistry/gromacs/gromacs-2023.9999.ebuild b/sci-chemistry/gromacs/gromacs-2023.9999.ebuild
index a3319899d419..4ee08b22a7f0 100644
--- a/sci-chemistry/gromacs/gromacs-2023.9999.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2023.9999.ebuild
@@ -45,6 +45,10 @@ CDEPEND="
blas? ( virtual/blas )
cuda? ( >=dev-util/nvidia-cuda-toolkit-11:=[profiler] )
opencl? ( virtual/opencl )
+ openmp? (
+ sys-devel/gcc[openmp]
+ sys-devel/clang-runtime[openmp]
+ )
fftw? ( sci-libs/fftw:3.0= )
hwloc? ( sys-apps/hwloc:= )
lapack? ( virtual/lapack )
diff --git a/sci-chemistry/gromacs/gromacs-2024.3.ebuild b/sci-chemistry/gromacs/gromacs-2024.3.ebuild
index 33e343e23e7c..2101629ebc36 100644
--- a/sci-chemistry/gromacs/gromacs-2024.3.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2024.3.ebuild
@@ -45,6 +45,10 @@ CDEPEND="
blas? ( virtual/blas )
cuda? ( >=dev-util/nvidia-cuda-toolkit-11:=[profiler] )
opencl? ( virtual/opencl )
+ openmp? (
+ sys-devel/gcc[openmp]
+ sys-devel/clang-runtime[openmp]
+ )
fftw? ( sci-libs/fftw:3.0= )
hwloc? ( sys-apps/hwloc:= )
lapack? ( virtual/lapack )
diff --git a/sci-chemistry/gromacs/gromacs-2024.9999.ebuild b/sci-chemistry/gromacs/gromacs-2024.9999.ebuild
index 33e343e23e7c..2101629ebc36 100644
--- a/sci-chemistry/gromacs/gromacs-2024.9999.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2024.9999.ebuild
@@ -45,6 +45,10 @@ CDEPEND="
blas? ( virtual/blas )
cuda? ( >=dev-util/nvidia-cuda-toolkit-11:=[profiler] )
opencl? ( virtual/opencl )
+ openmp? (
+ sys-devel/gcc[openmp]
+ sys-devel/clang-runtime[openmp]
+ )
fftw? ( sci-libs/fftw:3.0= )
hwloc? ( sys-apps/hwloc:= )
lapack? ( virtual/lapack )
diff --git a/sci-chemistry/gromacs/gromacs-9999.ebuild b/sci-chemistry/gromacs/gromacs-9999.ebuild
index 33e343e23e7c..9f4ae599f86b 100644
--- a/sci-chemistry/gromacs/gromacs-9999.ebuild
+++ b/sci-chemistry/gromacs/gromacs-9999.ebuild
@@ -18,7 +18,7 @@ if [[ ${PV} = *9999* ]]; then
https://gitlab.com/gromacs/gromacs.git
https://github.com/gromacs/gromacs.git
"
- [[ ${PV} = 9999 ]] && EGIT_BRANCH="master" || EGIT_BRANCH="release-${PV:0:4}"
+ [[ ${PV} = 9999 ]] && EGIT_BRANCH="main" || EGIT_BRANCH="release-${PV:0:4}"
inherit git-r3
else
SRC_URI="
@@ -39,17 +39,23 @@ HOMEPAGE="https://www.gromacs.org/"
# base, vmd plugins, fftpack from numpy, blas/lapck from netlib, memtestG80 library, mpi_thread lib
LICENSE="LGPL-2.1 UoI-NCSA !mkl? ( !fftw? ( BSD ) !blas? ( BSD ) !lapack? ( BSD ) ) cuda? ( LGPL-3 ) threads? ( BSD )"
SLOT="0/${PV}"
-IUSE="blas clang clang-cuda cuda +custom-cflags +doc build-manual double-precision +fftw +gmxapi +gmxapi-legacy +hwloc lapack mkl mpi +offensive opencl openmp +python +single-precision test +threads +tng ${ACCE_IUSE}"
+IUSE="blas clang clang-cuda cuda +custom-cflags +doc build-manual double-precision +fftw +gmxapi +gmxapi-legacy +hdf5 +hwloc lapack mkl mpi nnpot +offensive opencl openmp +python +single-precision test +threads +tng ${ACCE_IUSE}"
CDEPEND="
blas? ( virtual/blas )
cuda? ( >=dev-util/nvidia-cuda-toolkit-11:=[profiler] )
opencl? ( virtual/opencl )
+ openmp? (
+ sys-devel/gcc[openmp]
+ sys-devel/clang-runtime[openmp]
+ )
fftw? ( sci-libs/fftw:3.0= )
+ hdf5? ( sci-libs/hdf5 )
hwloc? ( sys-apps/hwloc:= )
lapack? ( virtual/lapack )
mkl? ( sci-libs/mkl )
mpi? ( virtual/mpi[cxx] )
+ nnpot? ( sci-libs/caffe2[cuda=,opencl=] )
sci-libs/lmfit:=
>=dev-cpp/muParser-2.3:=
${PYTHON_DEPS}
@@ -88,6 +94,8 @@ DOCS=( AUTHORS README )
RESTRICT="!test? ( test )"
+PATCHES=( "${FILESDIR}/${P}-Fix-build-with-torch.patch" )
+
if [[ ${PV} != *9999 ]]; then
S="${WORKDIR}/${PN}-${PV/_/-}"
fi
@@ -178,6 +186,11 @@ src_prepare() {
src_configure() {
local mycmakeargs_pre=( ) extra fft_opts=( )
local acce="AUTO"
+ local nnpot="OFF"
+
+ if use nnpot; then
+ nnpot="TORCH"
+ fi
if use custom-cflags; then
#go from slowest to fastest acceleration
@@ -225,9 +238,11 @@ src_configure() {
-DGMX_COOL_QUOTES=$(usex offensive)
-DGMX_USE_TNG=$(usex tng)
-DGMX_BUILD_MANUAL=$(usex build-manual)
+ -DGMX_USE_HDF5=$(usex hdf5)
-DGMX_HWLOC=$(usex hwloc)
-DGMX_DEFAULT_SUFFIX=off
-DGMX_SIMD="$acce"
+ -DGMX_NNPOT="$nnpot"
-DGMX_VMD_PLUGIN_PATH="${EPREFIX}/usr/$(get_libdir)/vmd/plugins/*/molfile/"
-DBUILD_TESTING=$(usex test)
-DGMX_BUILD_UNITTESTS=$(usex test)
@@ -322,7 +337,7 @@ src_install() {
cat "${ED}"/usr/bin/gmx-completion.bash "$x" > "${T}/${n}" || die
newbashcomp "${T}"/"${n}" "${n}"
done
- rm "${ED}"/usr/bin/gmx-completion*.bash || die
+ #rm "${ED}"/usr/bin/gmx-completion*.bash || die
readme.gentoo_create_doc
}
diff --git a/sci-chemistry/gromacs/metadata.xml b/sci-chemistry/gromacs/metadata.xml
index 44ddb19d1d9d..518711308a02 100644
--- a/sci-chemistry/gromacs/metadata.xml
+++ b/sci-chemistry/gromacs/metadata.xml
@@ -19,6 +19,7 @@
<flag name="gmxapi-legacy">Enable installing lagacy headers</flag>
<flag name="hwloc">Enable HWLoc lib support</flag>
<flag name="lmfit">Use external <pkg>sci-libs/lmfit</pkg></flag>
+ <flag name="nnpot">Allow to use <pkg>sci-libs/caffe2</pkg> for NN Potentials</flag>
<flag name="opencl">Enable opencl non-bonded kernels</flag>
<flag name="single-precision">Single precision version of gromacs (default)</flag>
<flag name="tng">Enable new trajectory format - tng</flag>