summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:11:30 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:10:34 +0100
commit1e173f1ead049fb9f663bbb137eaebbbe2660e93 (patch)
tree6430340d4a7ab57a6b2ffc590c01f04ae2304644
parentx11-wm/xmonad-contrib: add 0.17.1 (diff)
downloadgentoo-1e173f1ead049fb9f663bbb137eaebbbe2660e93.tar.gz
gentoo-1e173f1ead049fb9f663bbb137eaebbbe2660e93.tar.bz2
gentoo-1e173f1ead049fb9f663bbb137eaebbbe2660e93.zip
x11-wm/xmonad: add 0.17.2
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--x11-wm/xmonad/Manifest1
-rw-r--r--x11-wm/xmonad/metadata.xml4
-rw-r--r--x11-wm/xmonad/xmonad-0.17.2.ebuild81
3 files changed, 86 insertions, 0 deletions
diff --git a/x11-wm/xmonad/Manifest b/x11-wm/xmonad/Manifest
index ecf9a5947d34..057e65f36fc6 100644
--- a/x11-wm/xmonad/Manifest
+++ b/x11-wm/xmonad/Manifest
@@ -1 +1,2 @@
DIST xmonad-0.17.0.tar.gz 93489 BLAKE2B 6990bc408194c99378f949b28f2115b7096e6474b5305f935be2c8af1eba4bff3e3c05477af9f833d1b52422e4fb95f857398b05f7f1081e3a2cc5dd8c50fc3a SHA512 1ec46ee61f4bf1879ea638e9be83378273050670ed2ee0f00e7d43b188cc29a874aa5b40076162a1ef0038802cc43f675773951f9b7d1f26329f9d105c28b3f7
+DIST xmonad-0.17.2.tar.gz 94730 BLAKE2B 4e65472830694048d051394222ceb889b1997d1dec37b8d1773fecee9385292448acda3c5a9b7e99a7de1582e8a403d976ef357dc474531e6166905d1129c3a2 SHA512 8d02422f473499516acf3cfe920b15df1d24a1fbf47f8cded5eb465186427e82cd43d65a63936993016797680335e59380931e9bad82b2181ecdef6b63d9bfd9
diff --git a/x11-wm/xmonad/metadata.xml b/x11-wm/xmonad/metadata.xml
index b0337e3fc024..e2d24eac2abe 100644
--- a/x11-wm/xmonad/metadata.xml
+++ b/x11-wm/xmonad/metadata.xml
@@ -8,4 +8,8 @@
<use>
<flag name="no-autorepeat-keys">Allow ignoring of keyboard autorepeat.</flag>
</use>
+ <upstream>
+ <remote-id type="hackage">xmonad</remote-id>
+ <remote-id type="github">xmonad/xmonad</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/x11-wm/xmonad/xmonad-0.17.2.ebuild b/x11-wm/xmonad/xmonad-0.17.2.ebuild
new file mode 100644
index 000000000000..6b2df3bd3107
--- /dev/null
+++ b/x11-wm/xmonad/xmonad-0.17.2.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.3.0
+#hackport: flags: -pedantic,quickcheck-classes:test
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal ghc-package
+
+DESCRIPTION="A tiling window manager"
+HOMEPAGE="https://xmonad.org"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="no-autorepeat-keys"
+
+RDEPEND="dev-haskell/data-default-class:=[profile?]
+ dev-haskell/setlocale:=[profile?]
+ >=dev-haskell/x11-1.10:=[profile?] <dev-haskell/x11-1.11:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? ( >=dev-haskell/quickcheck-2
+ >=dev-haskell/quickcheck-classes-0.4.3 )
+"
+
+DOCS=( README.md CHANGES.md )
+HTML_DOCS=( man/${PN}.1.html )
+
+SAMPLE_CONFIG="${PN}.hs"
+
+src_prepare() {
+ default
+ use no-autorepeat-keys && eapply "${FILESDIR}"/${PN}-0.14-check-repeat.patch
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-pedantic \
+ $(cabal_flag test quickcheck-classes)
+}
+
+src_install() {
+ default
+
+ cabal_src_install
+
+ echo -e "#!/bin/sh\n/usr/bin/${PN}" > "${T}/${PN}"
+ exeinto /etc/X11/Sessions
+ doexe "${T}/${PN}"
+
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}/${PN}.desktop"
+
+ insinto /usr/share/${PF}/ghc-$(ghc-version)/man
+ doins man/${SAMPLE_CONFIG}
+
+ doman man/${PN}.1
+}
+
+pkg_postinst() {
+ haskell-cabal_pkg_postinst
+
+ elog "A sample ${SAMPLE_CONFIG} configuration file can be found here:"
+ elog " /usr/share/${PF}/ghc-$(ghc-version)/man/${SAMPLE_CONFIG}"
+ elog "The parameters in this file are the defaults used by ${PN}."
+ elog "To customize ${PN}, copy this file to:"
+ elog " ~/.${PN}/${SAMPLE_CONFIG}"
+ elog "After editing, use 'mod-q' to dynamically restart ${PN} "
+ elog "(where the 'mod' key defaults to 'Alt')."
+ elog ""
+ elog "Read the README or man page for more information, and to see "
+ elog "other possible configurations go to:"
+ elog " http://haskell.org/haskellwiki/Xmonad/Config_archive"
+ elog "Please note that many of these configurations will require the "
+ elog "x11-wm/xmonad-contrib package to be installed."
+}