summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2025-01-03 03:03:19 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2025-01-03 03:03:19 +0000
commit25f5c560ccf70a24122f6c36926b875a1c2572fc (patch)
treedb9dd3b92f1b16b68abc42a8ace4450183c70a8c
parent2025-01-03 02:48:30 UTC (diff)
parentdev-qt/qtwebengine: workaround -D_GLIBCXX_ASSERTIONS issues in 6.8 (diff)
downloadgentoo-25f5c560ccf70a24122f6c36926b875a1c2572fc.tar.gz
gentoo-25f5c560ccf70a24122f6c36926b875a1c2572fc.tar.bz2
gentoo-25f5c560ccf70a24122f6c36926b875a1c2572fc.zip
Merge updates from master
-rw-r--r--dev-qt/qtwebengine/qtwebengine-6.8.1-r1.ebuild (renamed from dev-qt/qtwebengine/qtwebengine-6.8.1.ebuild)5
-rw-r--r--dev-qt/qtwebengine/qtwebengine-6.8.9999.ebuild5
2 files changed, 8 insertions, 2 deletions
diff --git a/dev-qt/qtwebengine/qtwebengine-6.8.1.ebuild b/dev-qt/qtwebengine/qtwebengine-6.8.1-r1.ebuild
index b0261e05d1d0..0ae70e897de7 100644
--- a/dev-qt/qtwebengine/qtwebengine-6.8.1.ebuild
+++ b/dev-qt/qtwebengine/qtwebengine-6.8.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2021-2024 Gentoo Authors
+# Copyright 2021-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -236,6 +236,9 @@ src_configure() {
if use !custom-cflags; then
strip-flags # fragile
+ # temporary workaround for bug #947356, should be fixed in Qt 6.9.x
+ append-cppflags -U_GLIBCXX_ASSERTIONS
+
if is-flagq '-g?(gdb)?([2-9])'; then #914475
replace-flags '-g?(gdb)?([2-9])' -g1
ewarn "-g2+/-ggdb* *FLAGS replaced with -g1 (enable USE=custom-cflags to keep)"
diff --git a/dev-qt/qtwebengine/qtwebengine-6.8.9999.ebuild b/dev-qt/qtwebengine/qtwebengine-6.8.9999.ebuild
index 5272dee74a6a..aabbe2abf000 100644
--- a/dev-qt/qtwebengine/qtwebengine-6.8.9999.ebuild
+++ b/dev-qt/qtwebengine/qtwebengine-6.8.9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2021-2024 Gentoo Authors
+# Copyright 2021-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -235,6 +235,9 @@ src_configure() {
if use !custom-cflags; then
strip-flags # fragile
+ # temporary workaround for bug #947356, should be fixed in Qt 6.9.x
+ append-cppflags -U_GLIBCXX_ASSERTIONS
+
if is-flagq '-g?(gdb)?([2-9])'; then #914475
replace-flags '-g?(gdb)?([2-9])' -g1
ewarn "-g2+/-ggdb* *FLAGS replaced with -g1 (enable USE=custom-cflags to keep)"