summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason A. Donenfeld <zx2c4@gentoo.org>2016-02-21 01:39:54 +0100
committerJason A. Donenfeld <zx2c4@gentoo.org>2016-02-21 01:42:21 +0100
commit26a14377821f2bb94c3f47723c33c6b4836fe007 (patch)
tree4e6dfad01c2f433b4d7c792436319bafe622fc3e
parentdev-go/go-tools: version bump to 0_pre20160220 (diff)
downloadgentoo-26a14377821f2bb94c3f47723c33c6b4836fe007.tar.gz
gentoo-26a14377821f2bb94c3f47723c33c6b4836fe007.tar.bz2
gentoo-26a14377821f2bb94c3f47723c33c6b4836fe007.zip
app-misc/tmux: rely on libutempter
If utempter.h is installed, tmux unconditionally links against libutempter, and there isn't a configure switch to disable it. As such, systems that already had installed libutempter (for use with, say, mosh) found that there would be issues when libutempter was removed, since it wasn't an explicit dependency of this package. Meanwhile, there were issues with the other utempter (non-lib prefix), causing that to be a blocker. So, the fix for both of these at once is to replace the blocker against utempter with a dependency on libutempter, because libutempter already blocks utempter. This simplifes things greatly. Fixes: 566990 Fixes: 560652 Signed-off-by: Jason A. Donenfeld <zx2c4@gentoo.org>
-rw-r--r--app-misc/tmux/tmux-2.1.ebuild2
-rw-r--r--app-misc/tmux/tmux-9999.ebuild1
2 files changed, 2 insertions, 1 deletions
diff --git a/app-misc/tmux/tmux-2.1.ebuild b/app-misc/tmux/tmux-2.1.ebuild
index 9a9ea612da85..9862e65ee629 100644
--- a/app-misc/tmux/tmux-2.1.ebuild
+++ b/app-misc/tmux/tmux-2.1.ebuild
@@ -22,7 +22,7 @@ CDEPEND="
=dev-libs/libevent-2.0*
>=dev-libs/libevent-2.1.5-r4
)
- !sys-apps/utempter
+ sys-libs/libutempter
sys-libs/ncurses:0="
DEPEND="${CDEPEND}
virtual/pkgconfig"
diff --git a/app-misc/tmux/tmux-9999.ebuild b/app-misc/tmux/tmux-9999.ebuild
index 1e3c5867dabc..2709b1a41bdb 100644
--- a/app-misc/tmux/tmux-9999.ebuild
+++ b/app-misc/tmux/tmux-9999.ebuild
@@ -20,6 +20,7 @@ IUSE="debug selinux vim-syntax"
CDEPEND="
>=dev-libs/libevent-2.0.10
+ sys-libs/libutempter
sys-libs/ncurses:0="
DEPEND="${CDEPEND}
virtual/pkgconfig"