summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-31 17:16:22 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-31 17:58:00 +0200
commit2bb4b9209197ab068f418adf1791651b61bf70d8 (patch)
tree2130f80609c99be7c264f051f9d9c8d40cf2af69
parentdev-python/twisted: comment for exported LINES and COLUMNS envs (diff)
downloadgentoo-2bb4b9209197ab068f418adf1791651b61bf70d8.tar.gz
gentoo-2bb4b9209197ab068f418adf1791651b61bf70d8.tar.bz2
gentoo-2bb4b9209197ab068f418adf1791651b61bf70d8.zip
dev-python/sphinx-notfound-page: Bump to 1.0.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/sphinx-notfound-page/Manifest1
-rw-r--r--dev-python/sphinx-notfound-page/sphinx-notfound-page-1.0.4.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/sphinx-notfound-page/Manifest b/dev-python/sphinx-notfound-page/Manifest
index df65c0f1cb23..f7acdbd4f3cc 100644
--- a/dev-python/sphinx-notfound-page/Manifest
+++ b/dev-python/sphinx-notfound-page/Manifest
@@ -1 +1,2 @@
DIST sphinx-notfound-page-1.0.2.gh.tar.gz 543984 BLAKE2B a6a7a1f157c9500618c296152f44a441db9bf4198e196e5be5c71444e05f2623457d0807103dcc55d08c869afb0d35b719dc73f7f43e57f08a025aa08a4f42b1 SHA512 faa6c2cf59dcb3ab90e00176f1f9480ad8f5ff07e76dfd49a17985e638ea05329faaffa15f64d5c7cedc37028d0beeee9de10927429eb85d5b0bb1397d6bd14e
+DIST sphinx-notfound-page-1.0.4.gh.tar.gz 544117 BLAKE2B f8155167183fa3d6487cfd9f93eff8a99dd3253ed7f44632ca822b9da3d0b409a6897edd4f972fc9535b4759c2ef976c5f66daf85249ba9de4c83ae96ff65d7a SHA512 d6643e29768b31834c73302f8995cd92c052b2a51a4ecffc997f4ea4d15cf830c17a2f538fec637b1a3a7e187fa787252652b5ab8ce0ab92f44996a63669b504
diff --git a/dev-python/sphinx-notfound-page/sphinx-notfound-page-1.0.4.ebuild b/dev-python/sphinx-notfound-page/sphinx-notfound-page-1.0.4.ebuild
new file mode 100644
index 000000000000..2160322293ab
--- /dev/null
+++ b/dev-python/sphinx-notfound-page/sphinx-notfound-page-1.0.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Create a custom 404 page with absolute URLs hardcoded"
+HOMEPAGE="
+ https://sphinx-notfound-page.readthedocs.io/
+ https://github.com/readthedocs/sphinx-notfound-page/
+ https://pypi.org/project/sphinx-notfound-page/
+"
+SRC_URI="
+ https://github.com/readthedocs/sphinx-notfound-page/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/sphinx-5[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # calls sphinx-build directly, works around venv
+ tests/test_urls.py::test_parallel_build
+)