summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-09-23 02:05:43 +0100
committerSam James <sam@gentoo.org>2024-09-23 02:06:53 +0100
commit2ebde6581d1aa42be8c21c701217394e1b33c9a5 (patch)
tree37090461883a48635bf60e7f10b4ff09b823d907
parentdev-libs/libjcat: Stabilize 0.2.1 ppc64, #940067 (diff)
downloadgentoo-2ebde6581d1aa42be8c21c701217394e1b33c9a5.tar.gz
gentoo-2ebde6581d1aa42be8c21c701217394e1b33c9a5.tar.bz2
gentoo-2ebde6581d1aa42be8c21c701217394e1b33c9a5.zip
net-analyzer/cloudshark: fix invalid PDEPEND use
pkgcheck now reports: ``` net-analyzer/cloudshark BadDependency: version 1.0.4: ':=' operator is invalid in: PDEPEND="net-analyzer/wireshark:=[lua]" ``` This showed up in breaking CI when infra updated pkgcheck. As for the PDEPEND use here in general, it's invalid both because: a) PDEPEND should *only* be used for breaking circular dependencies; b) := is ill-defined in PDEPEND. This is a plugin for Wireshark hence needs to be in DEPEND+RDEPEND. Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-analyzer/cloudshark/cloudshark-1.0.4-r1.ebuild (renamed from net-analyzer/cloudshark/cloudshark-1.0.4.ebuild)9
1 files changed, 6 insertions, 3 deletions
diff --git a/net-analyzer/cloudshark/cloudshark-1.0.4.ebuild b/net-analyzer/cloudshark/cloudshark-1.0.4-r1.ebuild
index 3904b2a51763..0eee6336f1e0 100644
--- a/net-analyzer/cloudshark/cloudshark-1.0.4.ebuild
+++ b/net-analyzer/cloudshark/cloudshark-1.0.4-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -12,8 +12,11 @@ SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
IUSE=""
-PDEPEND="net-analyzer/wireshark:=[lua]
- net-misc/curl"
+RDEPEND="
+ net-analyzer/wireshark:=[lua]
+ net-misc/curl
+"
+DEPEND="${RDEPEND}"
S="${WORKDIR}/wireshark-plugin-${PV}"