summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrancesco Riosa <friosa@gaikai.com>2017-03-20 13:00:05 +0100
committerLuca Barbato <lu_zero@gentoo.org>2017-03-20 13:31:39 +0000
commit31190d713dfa98b06b29646786e6ab2d3b5653ed (patch)
tree910cd47dce26fe7977516c41d125ac4b392bd832
parentdev-php/PEAR-XML_Util: remove unused version 1.3.0-r1. (diff)
downloadgentoo-31190d713dfa98b06b29646786e6ab2d3b5653ed.tar.gz
gentoo-31190d713dfa98b06b29646786e6ab2d3b5653ed.tar.bz2
gentoo-31190d713dfa98b06b29646786e6ab2d3b5653ed.zip
media-gfx/rawtherapee: version bump
New version, with a lot of new features and a switch from gtk2 to gtk3. Thanks Franz Fellner for converting the ebuild fromn git to tarballs and Marek Szuba (marecki) for suggestion on how to improve it. See bug #606896 for details, #c13 for Franz ebuild and #c17 for Marek suggestions. Signed-off-by: Luca Barbato <lu_zero@gentoo.org>
-rw-r--r--media-gfx/rawtherapee/Manifest1
-rw-r--r--media-gfx/rawtherapee/rawtherapee-5.0.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/media-gfx/rawtherapee/Manifest b/media-gfx/rawtherapee/Manifest
index 69203b495930..efc46b3bc7b0 100644
--- a/media-gfx/rawtherapee/Manifest
+++ b/media-gfx/rawtherapee/Manifest
@@ -1 +1,2 @@
DIST rawtherapee-4.2.tar.xz 7787664 SHA256 fa4c13e8842df096b19d2dabaed5a61f5f9d4547f7b4f0dc6b77f80bdec16479 SHA512 feec61aeb84804cf01ff03fa9d7309f0eb3c04c43818c8397cc6f3ee762aca19484bce7594414d2141248b9740bdd4269fd86f76dcf391c61d4647fa169d48f6 WHIRLPOOL 56cc3e95ae7484cb91cd6c5fd32504b3fbfb17b9d50a38fa490300ff1b096e80a1d5060db3619c34f8b214dd413bfaab57a9748f5a365a87d257e75c753f307a
+DIST rawtherapee-5.0-gtk3.tar.xz 10442940 SHA256 25c6bb738535d1efa905bd21fb732bdea352d589d9740a730ec409a49e7eacd8 SHA512 febcde98ada1059d6553a1dc2a86235adaf5fb8ca81b9f744748d3e8ef52109048ce43996f261796b2f345f2ce4a27c4ccc219b33ccfb79c2c2fa6476f19b41a WHIRLPOOL 479a7f37f523c533cf268edc8f2c710ded867febc13df3c4156040ca4d36ad86ff4af2613e9155506eb6a4620d4323fdc3d3f1374c4332393ba57b4b01bcc948
diff --git a/media-gfx/rawtherapee/rawtherapee-5.0.ebuild b/media-gfx/rawtherapee/rawtherapee-5.0.ebuild
new file mode 100644
index 000000000000..141d13abcc15
--- /dev/null
+++ b/media-gfx/rawtherapee/rawtherapee-5.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils toolchain-funcs flag-o-matic
+
+DESCRIPTION="A powerful cross-platform raw image processing program"
+HOMEPAGE="http://www.rawtherapee.com/"
+
+MY_P=${P/_p1/-r1}
+SRC_URI="http://rawtherapee.com/shared/source/${MY_P}-gtk3.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bzip2 openmp"
+
+RDEPEND="bzip2? ( app-arch/bzip2 )
+ x11-libs/gtk+:3
+ dev-libs/expat
+ dev-libs/libsigc++:2
+ media-libs/libcanberra[gtk3]
+ media-libs/tiff:0
+ media-libs/libpng:0
+ media-libs/libiptcdata
+ media-libs/lcms:2
+ sci-libs/fftw:3.0
+ sys-libs/zlib
+ virtual/jpeg:0"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ virtual/pkgconfig
+ dev-cpp/gtkmm:3.0"
+
+S="${WORKDIR}/${MY_P}-gtk3"
+
+pkg_pretend() {
+ if use openmp ; then
+ tc-has-openmp || die "Please switch to an openmp compatible compiler"
+ fi
+ # https://bugs.gentoo.org/show_bug.cgi?id=606896#c2
+ # https://github.com/vivo75/vivovl/issues/2
+ if [[ $(get-flag -O3) != "-O3" ]] ; then
+ ewarn "upstream suggest using {C,CXX}FLAGS+=\"-O3\" for better performances"
+ ewarn "see bug#606896#c2"
+ ewarn "take a look at https://wiki.gentoo.org/wiki//etc/portage/package.env"
+ ewarn "for suggestion on how to change environment for a single package"
+ fi
+}
+
+src_configure() {
+ filter-flags -ffast-math
+ local mycmakeargs=(
+ -DOPTION_OMP=$(usex openmp)
+ -DBZIP=$(usex bzip2)
+ -DDOCDIR=/usr/share/doc/${PF}
+ -DCREDITSDIR=/usr/share/${PN}
+ -DLICENCEDIR=/usr/share/${PN}
+ -DCACHE_NAME_SUFFIX=""
+ -DCMAKE_CXX_FLAGS="-std=c++11"
+ )
+ cmake-utils_src_configure
+}