summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-12-14 07:28:06 +0100
committerHans de Graaff <graaff@gentoo.org>2023-12-14 07:30:39 +0100
commit3435fe802c78ae4b3af3ca9a041b696cd0198404 (patch)
tree7a619c3db7144a6ca72e46879abbf47ef5c1c9e8
parentdev-util/jenkins-bin: add 2.426.2 (diff)
downloadgentoo-3435fe802c78ae4b3af3ca9a041b696cd0198404.tar.gz
gentoo-3435fe802c78ae4b3af3ca9a041b696cd0198404.tar.bz2
gentoo-3435fe802c78ae4b3af3ca9a041b696cd0198404.zip
dev-ruby/bigdecimal: add 3.1.5
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/bigdecimal/Manifest1
-rw-r--r--dev-ruby/bigdecimal/bigdecimal-3.1.5.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/bigdecimal/Manifest b/dev-ruby/bigdecimal/Manifest
index 8445b6e055ca..7901af5de2a2 100644
--- a/dev-ruby/bigdecimal/Manifest
+++ b/dev-ruby/bigdecimal/Manifest
@@ -1 +1,2 @@
DIST bigdecimal-3.1.4.tar.gz 115069 BLAKE2B 7c7df4ceac6caa44414cf2fe4e16ee21b8d4a868097e5a6d3e7bdae8521b572b6facae5023fac28dafe9a659a93f0cb56ef2762f84b85959358ee9a33be687b1 SHA512 5e89906d4df0890d61ddca9cc88549acac6c94fc7267975a0ad8684855283c60a2f5fbd48051569c33fa513b6c25485d474446066911577f8cad00c26b57cd43
+DIST bigdecimal-3.1.5.tar.gz 105064 BLAKE2B 472f364f34ab37478e7d6570bb7cd9a35a82f973ef09806fc9229793392a5daa2f66b2303a75ca43b098c7413c9a358ffe07bd592d499d671bac5136690b2b11 SHA512 fd6c463412dbe626e98cffaf977967eb5bbaa15670131132e16050470184443b0d773ede9df1a8196f7f2c0362060f7d79727a970ad5bd6b4031d5875867b8c5
diff --git a/dev-ruby/bigdecimal/bigdecimal-3.1.5.ebuild b/dev-ruby/bigdecimal/bigdecimal-3.1.5.ebuild
new file mode 100644
index 000000000000..d2aa1a8266e2
--- /dev/null
+++ b/dev-ruby/bigdecimal/bigdecimal-3.1.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTENSIONS=(ext/bigdecimal/extconf.rb)
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+RUBY_FAKEGEM_GEMSPEC="bigdecimal.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Arbitrary-precision decimal floating-point number library for Ruby"
+HOMEPAGE="https://github.com/ruby/bigdecimal"
+SRC_URI="https://github.com/ruby/bigdecimal/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( Ruby-BSD BSD-2 )"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+SLOT="0"
+IUSE="test"
+
+all_ruby_prepare() {
+ sed -e '/^source_version/,/^end/ s:^:#:' \
+ -e "/s.version/ s/= source_version/= '${PV}'/" \
+ -e "/s.name/ s/= name/= 'bigdecimal'/" \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test:. -rtest/lib/helper -e "Dir['test/**/test_*.rb'].each { require _1 }" || die
+}