summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-20 23:04:15 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-21 00:10:23 +0100
commit3e702a551fc851843a2b7477df72009618db5d76 (patch)
treef35bbb927c716aa9cccf1f5d206873da35f3b92c
parentdev-python/prettytable: Bump to 2.5.0 (diff)
downloadgentoo-3e702a551fc851843a2b7477df72009618db5d76.tar.gz
gentoo-3e702a551fc851843a2b7477df72009618db5d76.tar.bz2
gentoo-3e702a551fc851843a2b7477df72009618db5d76.zip
dev-python/jsonschema: Bump to 4.3.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/jsonschema/Manifest1
-rw-r--r--dev-python/jsonschema/jsonschema-4.3.2.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/jsonschema/Manifest b/dev-python/jsonschema/Manifest
index a03c23107cd4..f77fd48ed993 100644
--- a/dev-python/jsonschema/Manifest
+++ b/dev-python/jsonschema/Manifest
@@ -2,3 +2,4 @@ DIST jsonschema-3.2.0.tar.gz 167226 BLAKE2B f89a8198f6b7b4dd56b0320ddecdd834423c
DIST jsonschema-4.2.1.tar.gz 310668 BLAKE2B ba36be8abf0678fda773a9950f06e4d15f6a4c19fdd9f855310b80f45be1a25f44ce329c35667c4e107aab6ba381b02ff2caa305222932e2cbe733f293de82cc SHA512 349993c00e663f3efa2304e60c8b75e90c012d29faa498a01d5d2a5c47ddf0485f28894fd2ddf4766f9ab91e468f4b4f24a53390c72b7a31fae37d75c6f2b774
DIST jsonschema-4.3.0.tar.gz 311317 BLAKE2B 6ec3d2cf05923657e9875b5f51b9356a730a7f9a1ab8e07bbf7226fdf1005f729a06c110ec52b62d12a4bba96a14dc647786398e66a6439de93fb38c02eef848 SHA512 3772952fb482660da86b0f71ed509ef267375a80ba2db0e4c12b9bb17f79c1f31f1a8ed2746a0bef76c620d61a63ccf967c77cc55255c7d3fe4e688dc0413b38
DIST jsonschema-4.3.1.tar.gz 311425 BLAKE2B e524675d64fece5f7687d62ed043ffb35e7627c6d1f213fde3e9c2f35b929fc56b998d39e84148fe24c507361114e047540fcf23606f4d77b2bdfc0454c6d529 SHA512 621093b8964ea94dadd23aab7c0bbbf5eb23ae615b569278886a4213ef7adc779fddcd75cfff87e243087f788fca180f4472cd3bafe8f2f8157e30c04b5f33e7
+DIST jsonschema-4.3.2.tar.gz 311576 BLAKE2B df6e656244b3ad963714e3a5e457971ad29455529b1e032e4ead2aa60a76ef332d31c871d6e9cc98b1a76d52e53b6586e6ef0b601d4b1b6fef8b39e2ea29acfa SHA512 a849282e6661ac28d3116754e87235a1970993bedeb4590d67605409ef875c5c26efe12a35bce7eeb624778a6d7770feda0356b4a0c05f6bc0364da9aefcaed6
diff --git a/dev-python/jsonschema/jsonschema-4.3.2.ebuild b/dev-python/jsonschema/jsonschema-4.3.2.ebuild
new file mode 100644
index 000000000000..67432d9cab8c
--- /dev/null
+++ b/dev-python/jsonschema/jsonschema-4.3.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="An implementation of JSON-Schema validation for Python"
+HOMEPAGE="https://pypi.org/project/jsonschema/ https://github.com/Julian/jsonschema"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+ >=dev-python/pyrsistent-0.18.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_resources-1.4.0[${PYTHON_USEDEP}]
+ ' pypy3 python3_8)
+"
+
+# formatter deps
+RDEPEND+="
+ dev-python/fqdn[${PYTHON_USEDEP}]
+ dev-python/idna[${PYTHON_USEDEP}]
+ dev-python/isoduration[${PYTHON_USEDEP}]
+ >=dev-python/jsonpointer-1.13[${PYTHON_USEDEP}]
+ dev-python/rfc3339-validator[${PYTHON_USEDEP}]
+ dev-python/rfc3986-validator[${PYTHON_USEDEP}]
+ dev-python/rfc3987[${PYTHON_USEDEP}]
+ dev-python/uritemplate[${PYTHON_USEDEP}]
+ >=dev-python/webcolors-1.11[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/twisted[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # requires pip, does not make much sense for the users
+ jsonschema/tests/test_cli.py::TestCLIIntegration::test_license
+)