summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2017-03-20 16:19:52 -0400
committerIan Stakenvicius <axs@gentoo.org>2017-03-20 16:20:19 -0400
commit412d060e4222bc2fb2001f989e3d3b86a4dee23b (patch)
treec483afc4a2101cb4e559d5c1a4a907140424d786
parentdev-perl/Digest-CRC: Bump to version 0.220.0_p2 (diff)
downloadgentoo-412d060e4222bc2fb2001f989e3d3b86a4dee23b.tar.gz
gentoo-412d060e4222bc2fb2001f989e3d3b86a4dee23b.tar.bz2
gentoo-412d060e4222bc2fb2001f989e3d3b86a4dee23b.zip
www-client/firefox: add nsplugin use flag to override the NPAPI-plugin-disable default
As of 52.0, mozilla has dropped support of all NPAPI plugins except for flash. 52.0ESR (which is what gentoo stabilized) will retain this support, but for this particular package we can also hotwire the switch used in 52.0ESR to allow plugin support to continue on the release version. Note, this may not work after 52 and if so the flag will be removed. Package-Manager: portage-2.3.3
-rw-r--r--www-client/firefox/firefox-52.0.1.ebuild8
-rw-r--r--www-client/firefox/metadata.xml1
2 files changed, 8 insertions, 1 deletions
diff --git a/www-client/firefox/firefox-52.0.1.ebuild b/www-client/firefox/firefox-52.0.1.ebuild
index f1c5c911af54..dee4ffb1bdaf 100644
--- a/www-client/firefox/firefox-52.0.1.ebuild
+++ b/www-client/firefox/firefox-52.0.1.ebuild
@@ -39,7 +39,7 @@ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-lin
SLOT="0"
LICENSE="MPL-2.0 GPL-2 LGPL-2.1"
-IUSE="bindist +gmp-autoupdate hardened hwaccel jack pgo rust selinux test"
+IUSE="bindist +gmp-autoupdate hardened hwaccel jack nsplugin pgo rust selinux test"
RESTRICT="!bindist? ( bindist )"
PATCH_URIS=( https://dev.gentoo.org/~{anarchy,axs,polynomial-c}/mozilla/patchsets/${PATCH}.tar.xz )
@@ -296,6 +296,12 @@ src_install() {
"${BUILD_OBJ_DIR}/dist/bin/browser/defaults/preferences/all-gentoo.js" \
|| die
+ if use nsplugin; then
+ echo "pref(\"plugin.load_flash_only\", false);" >> \
+ "${BUILD_OBJ_DIR}/dist/bin/browser/defaults/preferences/all-gentoo.js" \
+ || die
+ fi
+
local plugin
use gmp-autoupdate || for plugin in "${GMP_PLUGIN_LIST[@]}" ; do
echo "pref(\"media.${plugin}.autoupdate\", false);" >> \
diff --git a/www-client/firefox/metadata.xml b/www-client/firefox/metadata.xml
index 1a10a23ec9cb..479508ffdaef 100644
--- a/www-client/firefox/metadata.xml
+++ b/www-client/firefox/metadata.xml
@@ -16,6 +16,7 @@
<flag name="hwaccel">Force-enable hardware-accelerated rendering (Mozilla bug 594876)</flag>
<flag name="jemalloc">Enable or disable jemalloc</flag>
<flag name="jemalloc3">Enable or disable jemalloc3 (forced-on when supported prior to 38.0)</flag>
+ <flag name="nsplugin">Enable support for NPAPI plugins other than flash</flag>
<flag name="pgo">Add support for profile-guided optimization using gcc-4.5,
for faster binaries. This option will double the compile time.</flag>
<flag name="rust">Enable support for using rust compiler (experimental)</flag>