summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <Matt.Jolly@footclan.ninja>2022-08-18 14:09:55 +1000
committerSam James <sam@gentoo.org>2022-08-26 08:18:48 +0100
commit463a06f28960ff4931f3811e884eef363573701e (patch)
treebd2613073053a43833ec597d62923b9c751952e6
parentx11-misc/appmenu-gtk-module: drop 0.7.3-r2 (diff)
downloadgentoo-463a06f28960ff4931f3811e884eef363573701e.tar.gz
gentoo-463a06f28960ff4931f3811e884eef363573701e.tar.bz2
gentoo-463a06f28960ff4931f3811e884eef363573701e.zip
net-p2p/deluge: add 2.1.1, update 9999
- USE gtk -> gui - distutils PEP517 Signed-off-by: Matt Jolly <Matt.Jolly@footclan.ninja> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-p2p/deluge/Manifest1
-rw-r--r--net-p2p/deluge/deluge-2.1.1.ebuild169
-rw-r--r--net-p2p/deluge/deluge-9999.ebuild111
3 files changed, 238 insertions, 43 deletions
diff --git a/net-p2p/deluge/Manifest b/net-p2p/deluge/Manifest
index 35c526df0cbb..1304a7562619 100644
--- a/net-p2p/deluge/Manifest
+++ b/net-p2p/deluge/Manifest
@@ -1 +1,2 @@
DIST deluge-2.0.5.tar.xz 1895268 BLAKE2B 2c815aa9dbbbed5ba780d694b0518f224577b9c370a03712b15c706eda6de55e34b834f624ec18001c9d41b925677b6a001a384691a7ffd9f29c16731a735d4b SHA512 6c2994ca2906fdb92e96aa3534a4ffd5199e9ab6a1b5b12de94c94ec29850cad0cef7546ae1bea5188075fd16a07e584a17bf2f8b5eb1d2b91dee2da1e494588
+DIST deluge-2.1.1.tar.xz 2541968 BLAKE2B 3fe59ad8b402281dd0e19504d10a8d9e2967911e9967613a0d5a146d9ca261cb59d2208f8bd529e7f1da824e125ffb590d12b337dd9655e78b54252b021ae8da SHA512 e94208981aee45f42b88e1c544b07e7b0d0f2c4ade6b7f37257b69d4a3394c89aff217cde699e79ad59de6d2ee4eca7a558f2b85505d2140ba73f1f76f184455
diff --git a/net-p2p/deluge/deluge-2.1.1.ebuild b/net-p2p/deluge/deluge-2.1.1.ebuild
new file mode 100644
index 000000000000..10e6eba69d52
--- /dev/null
+++ b/net-p2p/deluge/deluge-2.1.1.ebuild
@@ -0,0 +1,169 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=setuptools
+DISTUTILS_SINGLE_IMPL=1
+inherit xdg distutils-r1 systemd
+
+DESCRIPTION="BitTorrent client with a client/server model"
+HOMEPAGE="https://deluge-torrent.org/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.deluge-torrent.org/${PN}"
+else
+ SRC_URI="http://download.deluge-torrent.org/source/$(ver_cut 1-2)/${P}.tar.xz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="console gui libnotify sound webinterface"
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ libnotify? ( gui )
+ sound? ( gui )
+"
+
+BDEPEND="
+ dev-util/intltool
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/pytest-twisted[${PYTHON_USEDEP}]
+ ')
+ )
+"
+
+RDEPEND="
+ acct-group/deluge
+ acct-user/deluge
+ net-libs/libtorrent-rasterbar:=[python,${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep '
+ gui? (
+ sound? ( dev-python/pygame[${PYTHON_USEDEP}] )
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ gnome-base/librsvg
+ libnotify? ( x11-libs/libnotify )
+ )
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/distro[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ dev-python/rencode[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]
+ || (
+ >=dev-python/twisted-17.1.0[ssl(-),${PYTHON_USEDEP}]
+ >=dev-python/twisted-17.1.0[crypt(-),${PYTHON_USEDEP}]
+ )
+ >=dev-python/zope-interface-4.4.2[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ ')
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ local args=(
+ -e 's|"new_release_check": True|"new_release_check": False|'
+ -e 's|"check_new_releases": True|"check_new_releases": False|'
+ -e 's|"show_new_releases": True|"show_new_releases": False|'
+ )
+ sed -i "${args[@]}" -- 'deluge/core/preferencesmanager.py' || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # Upstream CI/CD skips these and they seem to intentionally segfault to collect core dumps...
+ deluge/plugins/Stats/deluge_stats/tests/test_stats.py
+ # Skipped upstream
+ deluge/tests/test_security.py
+ )
+ local EPYTEST_DESELECT=(
+ # Skipped upstream
+ 'deluge/plugins/WebUi/deluge_webui/tests/test_plugin_webui.py::TestWebUIPlugin::test_enable_webui'
+ 'deluge/tests/test_torrent.py::TestTorrent::test_torrent_error_resume_data_unaltered'
+ 'deluge/tests/test_tracker_icons.py::TestTrackerIcons::test_get_seo_svg_with_sni'
+ # never returns
+ 'deluge/tests/test_ui_entry.py::TestConsoleScriptEntryWithDaemon'
+ # failing network(?)-related tests, even with sandbox disabled
+ 'deluge/tests/test_common.py::TestCommon::test_is_interface'
+ # fails
+ 'deluge/tests/test_core.py::TestCore::test_pause_torrents'
+ # fails because of network sandbox
+ 'deluge/tests/test_core.py::TestCore::test_test_listen_port'
+ 'deluge/tests/test_tracker_icons.py::TestTrackerIcons::test_get_deluge_png'
+ 'deluge/tests/test_tracker_icons.py::TestTrackerIcons::test_get_google_ico'
+ 'deluge/tests/test_tracker_icons.py::TestTrackerIcons::test_get_google_ico_hebrew'
+ 'deluge/tests/test_tracker_icons.py::TestTrackerIcons::test_get_google_ico_with_redirect'
+ # segfaults with FEATURES="network-sandbox"
+ 'deluge/tests/test_core.py::TestCore::test_pause_torrent'
+ )
+
+ # dev-python/pytest-twisted has disabled autoloading
+ epytest -m "not (todo or gtkui)" -p pytest_twisted -v
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if ! use console ; then
+ rm -r "${D}/$(python_get_sitedir)/deluge/ui/console/" || die
+ rm "${ED}/usr/bin/deluge-console" || die
+ rm "${ED}/usr/share/man/man1/deluge-console.1" ||die
+ fi
+ if ! use gui ; then
+ rm -r "${D}/$(python_get_sitedir)/deluge/ui/gtk3/" || die
+ rm -r "${ED}/usr/share/icons/" || die
+ rm "${ED}/usr/bin/deluge-gtk" || die
+ rm "${ED}/usr/share/man/man1/deluge-gtk.1" || die
+ else
+ mkdir -p "${ED}/usr/share/applications/" || die
+ cp "${WORKDIR}/${P}/deluge/ui/data/share/applications/deluge.desktop" "${ED}/usr/share/applications/" || die
+ mkdir -p "${ED}/usr/share/metainfo" || die
+ cp "${WORKDIR}/${P}/deluge/ui/data/share/appdata/deluge.appdata.xml" "${ED}/usr/share/metainfo/" || die
+ fi
+
+ if use webinterface; then
+ newinitd "${FILESDIR}/deluge-web.init-2" deluge-web
+ newconfd "${FILESDIR}/deluge-web.conf" deluge-web
+ systemd_newunit "${FILESDIR}/deluge-web.service-3" deluge-web.service
+ systemd_install_serviced "${FILESDIR}/deluge-web.service.conf"
+ else
+ rm -r "${D}/$(python_get_sitedir)/deluge/ui/web/" || die
+ rm "${ED}/usr/bin/deluge-web" || die
+ rm "${ED}/usr/share/man/man1/deluge-web.1" || die
+ fi
+
+ newinitd "${FILESDIR}"/deluged.init-2 deluged
+ newconfd "${FILESDIR}"/deluged.conf-2 deluged
+ systemd_newunit "${FILESDIR}"/deluged.service-2 deluged.service
+ systemd_install_serviced "${FILESDIR}"/deluged.service.conf
+
+ python_optimize
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ elog
+ elog "If, after upgrading, deluge doesn't work please back up and then"
+ elog "remove your '~/.config/deluge' directory and try again"
+ elog
+ elog "To start the daemon either run 'deluged' as user"
+ elog "or modify /etc/conf.d/deluged and run"
+ elog "/etc/init.d/deluged start as root"
+ elog "You can still use deluge the old way"
+ elog
+ elog "Systemd unit files for deluged and deluge-web no longer source"
+ elog "/etc/conf.d/deluge* files. Environment variable customization now"
+ elog "happens in /etc/systemd/system/deluged.service.d/00gentoo.conf"
+ elog "and /etc/systemd/system/deluge-web.service.d/00gentoo.conf"
+ elog
+ elog "For more information see https://dev.deluge-torrent.org/wiki/Faq"
+ elog
+}
diff --git a/net-p2p/deluge/deluge-9999.ebuild b/net-p2p/deluge/deluge-9999.ebuild
index 344df118563b..10e6eba69d52 100644
--- a/net-p2p/deluge/deluge-9999.ebuild
+++ b/net-p2p/deluge/deluge-9999.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="7"
+EAPI="8"
-PYTHON_COMPAT=( python3_{8,9,10} )
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=setuptools
DISTUTILS_SINGLE_IMPL=1
inherit xdg distutils-r1 systemd
@@ -14,30 +15,39 @@ if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://git.deluge-torrent.org/${PN}"
else
- SRC_URI="http://download.deluge-torrent.org/source/2.0/${P}.tar.xz"
- KEYWORDS="~amd64 ~arm ~ppc ~x86"
+ SRC_URI="http://download.deluge-torrent.org/source/$(ver_cut 1-2)/${P}.tar.xz"
+ KEYWORDS="~amd64"
fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="console gtk libnotify sound webinterface"
+IUSE="console gui libnotify sound webinterface"
REQUIRED_USE="
${PYTHON_REQUIRED_USE}
- libnotify? ( gtk )
- sound? ( gtk )
+ libnotify? ( gui )
+ sound? ( gui )
"
-DEPEND="
- net-libs/libtorrent-rasterbar:=[python,${PYTHON_SINGLE_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/wheel[${PYTHON_USEDEP}]
- ')
+BDEPEND="
dev-util/intltool
- acct-group/deluge
- acct-user/deluge"
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/pytest-twisted[${PYTHON_USEDEP}]
+ ')
+ )
+"
+
RDEPEND="
+ acct-group/deluge
+ acct-user/deluge
net-libs/libtorrent-rasterbar:=[python,${PYTHON_SINGLE_USEDEP}]
$(python_gen_cond_dep '
+ gui? (
+ sound? ( dev-python/pygame[${PYTHON_USEDEP}] )
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ gnome-base/librsvg
+ libnotify? ( x11-libs/libnotify )
+ )
dev-python/chardet[${PYTHON_USEDEP}]
dev-python/distro[${PYTHON_USEDEP}]
dev-python/pillow[${PYTHON_USEDEP}]
@@ -45,32 +55,19 @@ RDEPEND="
dev-python/pyxdg[${PYTHON_USEDEP}]
dev-python/rencode[${PYTHON_USEDEP}]
dev-python/setproctitle[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
|| (
>=dev-python/twisted-17.1.0[ssl(-),${PYTHON_USEDEP}]
>=dev-python/twisted-17.1.0[crypt(-),${PYTHON_USEDEP}]
)
>=dev-python/zope-interface-4.4.2[${PYTHON_USEDEP}]
- gtk? (
- sound? ( dev-python/pygame[${PYTHON_USEDEP}] )
- dev-python/pygobject:3[${PYTHON_USEDEP}]
- gnome-base/librsvg
- libnotify? ( x11-libs/libnotify )
- )
dev-python/mako[${PYTHON_USEDEP}]
- ')"
+ ')
+"
-PATCHES=(
- "${FILESDIR}/${PN}-2.0.3-setup.py.patch"
- "${FILESDIR}/${PN}-2.0.3-UI-status.patch"
-)
+distutils_enable_tests pytest
python_prepare_all() {
local args=(
- -e "/Compiling po file/a \\\tuptoDate = False"
- )
- sed -i "${args[@]}" -- 'setup.py' || die
- args=(
-e 's|"new_release_check": True|"new_release_check": False|'
-e 's|"check_new_releases": True|"check_new_releases": False|'
-e 's|"show_new_releases": True|"show_new_releases": False|'
@@ -80,13 +77,36 @@ python_prepare_all() {
distutils-r1_python_prepare_all
}
-esetup.py() {
- # bug 531370: deluge has its own plugin system. No need to relocate its egg info files.
- # Override this call from the distutils-r1 eclass.
- # This does not respect the distutils-r1 API. DONOT copy this example.
- set -- "${PYTHON}" setup.py "$@"
- echo "$@"
- "$@" || die
+python_test() {
+ local EPYTEST_IGNORE=(
+ # Upstream CI/CD skips these and they seem to intentionally segfault to collect core dumps...
+ deluge/plugins/Stats/deluge_stats/tests/test_stats.py
+ # Skipped upstream
+ deluge/tests/test_security.py
+ )
+ local EPYTEST_DESELECT=(
+ # Skipped upstream
+ 'deluge/plugins/WebUi/deluge_webui/tests/test_plugin_webui.py::TestWebUIPlugin::test_enable_webui'
+ 'deluge/tests/test_torrent.py::TestTorrent::test_torrent_error_resume_data_unaltered'
+ 'deluge/tests/test_tracker_icons.py::TestTrackerIcons::test_get_seo_svg_with_sni'
+ # never returns
+ 'deluge/tests/test_ui_entry.py::TestConsoleScriptEntryWithDaemon'
+ # failing network(?)-related tests, even with sandbox disabled
+ 'deluge/tests/test_common.py::TestCommon::test_is_interface'
+ # fails
+ 'deluge/tests/test_core.py::TestCore::test_pause_torrents'
+ # fails because of network sandbox
+ 'deluge/tests/test_core.py::TestCore::test_test_listen_port'
+ 'deluge/tests/test_tracker_icons.py::TestTrackerIcons::test_get_deluge_png'
+ 'deluge/tests/test_tracker_icons.py::TestTrackerIcons::test_get_google_ico'
+ 'deluge/tests/test_tracker_icons.py::TestTrackerIcons::test_get_google_ico_hebrew'
+ 'deluge/tests/test_tracker_icons.py::TestTrackerIcons::test_get_google_ico_with_redirect'
+ # segfaults with FEATURES="network-sandbox"
+ 'deluge/tests/test_core.py::TestCore::test_pause_torrent'
+ )
+
+ # dev-python/pytest-twisted has disabled autoloading
+ epytest -m "not (todo or gtkui)" -p pytest_twisted -v
}
python_install_all() {
@@ -96,13 +116,18 @@ python_install_all() {
rm "${ED}/usr/bin/deluge-console" || die
rm "${ED}/usr/share/man/man1/deluge-console.1" ||die
fi
- if ! use gtk ; then
+ if ! use gui ; then
rm -r "${D}/$(python_get_sitedir)/deluge/ui/gtk3/" || die
rm -r "${ED}/usr/share/icons/" || die
rm "${ED}/usr/bin/deluge-gtk" || die
rm "${ED}/usr/share/man/man1/deluge-gtk.1" || die
- rm "${ED}/usr/share/applications/deluge.desktop" || die
+ else
+ mkdir -p "${ED}/usr/share/applications/" || die
+ cp "${WORKDIR}/${P}/deluge/ui/data/share/applications/deluge.desktop" "${ED}/usr/share/applications/" || die
+ mkdir -p "${ED}/usr/share/metainfo" || die
+ cp "${WORKDIR}/${P}/deluge/ui/data/share/appdata/deluge.appdata.xml" "${ED}/usr/share/metainfo/" || die
fi
+
if use webinterface; then
newinitd "${FILESDIR}/deluge-web.init-2" deluge-web
newconfd "${FILESDIR}/deluge-web.conf" deluge-web
@@ -113,6 +138,7 @@ python_install_all() {
rm "${ED}/usr/bin/deluge-web" || die
rm "${ED}/usr/share/man/man1/deluge-web.1" || die
fi
+
newinitd "${FILESDIR}"/deluged.init-2 deluged
newconfd "${FILESDIR}"/deluged.conf-2 deluged
systemd_newunit "${FILESDIR}"/deluged.service-2 deluged.service
@@ -125,9 +151,8 @@ pkg_postinst() {
xdg_pkg_postinst
elog
- elog "If, after upgrading, deluge doesn't work, please remove the"
- elog "'~/.config/deluge' directory and try again, but make a backup"
- elog "first!"
+ elog "If, after upgrading, deluge doesn't work please back up and then"
+ elog "remove your '~/.config/deluge' directory and try again"
elog
elog "To start the daemon either run 'deluged' as user"
elog "or modify /etc/conf.d/deluged and run"
@@ -139,6 +164,6 @@ pkg_postinst() {
elog "happens in /etc/systemd/system/deluged.service.d/00gentoo.conf"
elog "and /etc/systemd/system/deluge-web.service.d/00gentoo.conf"
elog
- elog "For more information look at https://dev.deluge-torrent.org/wiki/Faq"
+ elog "For more information see https://dev.deluge-torrent.org/wiki/Faq"
elog
}