summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-07-16 08:52:34 +0100
committerSam James <sam@gentoo.org>2024-07-16 08:52:34 +0100
commit48aa1651c505a9a8bfc516e9eaeec8beb97065a7 (patch)
tree8ad51d43a5353d05ad64b36d5b8fd06abff8dba8
parentgames-util/xboxdrv: fix build w/ boost-1.85 (diff)
downloadgentoo-48aa1651c505a9a8bfc516e9eaeec8beb97065a7.tar.gz
gentoo-48aa1651c505a9a8bfc516e9eaeec8beb97065a7.tar.bz2
gentoo-48aa1651c505a9a8bfc516e9eaeec8beb97065a7.zip
media-gfx/superslicer: fix build w/ boost-1.85 (harder)
Closes: https://bugs.gentoo.org/936144 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--media-gfx/superslicer/files/superslicer-2.5.59.10-boost-1.85.patch54
-rw-r--r--media-gfx/superslicer/superslicer-2.5.59.10.ebuild1
2 files changed, 55 insertions, 0 deletions
diff --git a/media-gfx/superslicer/files/superslicer-2.5.59.10-boost-1.85.patch b/media-gfx/superslicer/files/superslicer-2.5.59.10-boost-1.85.patch
new file mode 100644
index 000000000000..8d9f11d3897d
--- /dev/null
+++ b/media-gfx/superslicer/files/superslicer-2.5.59.10-boost-1.85.patch
@@ -0,0 +1,54 @@
+https://bugs.gentoo.org/936144
+https://github.com/supermerill/SuperSlicer/commit/75d4bee84740a8dcc9e4e2113795fd67107d03d1
+
+From 75d4bee84740a8dcc9e4e2113795fd67107d03d1 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Luk=C3=A1=C5=A1=20Hejl?= <hejl.lukas@gmail.com>
+Date: Wed, 3 Jan 2024 23:55:02 +0100
+Subject: [PATCH] Replace some deprecated boost functions.
+
+Actually, all those deprecated functions were internally called those new functions. So there isn't any risk to use them directly.
+---
+ src/libslic3r/PrintBase.cpp | 2 +-
+ src/libslic3r/utils.cpp | 2 +-
+ src/slic3r/GUI/RemovableDriveManager.cpp | 2 +-
+ 3 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/src/libslic3r/PrintBase.cpp b/src/libslic3r/PrintBase.cpp
+index 29bdc1301d0..60e40644cb8 100644
+--- a/src/libslic3r/PrintBase.cpp
++++ b/src/libslic3r/PrintBase.cpp
+@@ -123,7 +123,7 @@ std::string PrintBase::output_filename(const std::string &format, const std::str
+ filepath = filename + extension;
+ }
+ if (filepath.extension().empty())
+- filepath = boost::filesystem::change_extension(filepath, default_ext);
++ filepath.replace_extension(default_ext);
+ return filepath.string();
+ } catch (std::runtime_error &err) {
+ throw Slic3r::PlaceholderParserError(L("Failed processing of the output_filename_format template.") + "\n" + err.what());
+diff --git a/src/libslic3r/utils.cpp b/src/libslic3r/utils.cpp
+index 71089ceea64..6eac962b20e 100644
+--- a/src/libslic3r/utils.cpp
++++ b/src/libslic3r/utils.cpp
+@@ -836,7 +836,7 @@ CopyFileResult copy_file_inner(const boost::filesystem::path& source, const boos
+ // That may happen when copying on some exotic file system, for example Linux on Chrome.
+ copy_file_linux(source, target, ec);
+ #else // __linux__
+- boost::filesystem::copy_file(source, target, boost::filesystem::copy_option::overwrite_if_exists, ec);
++ boost::filesystem::copy_file(source, target, boost::filesystem::copy_options::overwrite_existing, ec);
+ #endif // __linux__
+ if (ec) {
+ error_message = ec.message();
+diff --git a/src/slic3r/GUI/RemovableDriveManager.cpp b/src/slic3r/GUI/RemovableDriveManager.cpp
+index 5fb8b013210..2f8ac96a1a2 100644
+--- a/src/slic3r/GUI/RemovableDriveManager.cpp
++++ b/src/slic3r/GUI/RemovableDriveManager.cpp
+@@ -202,7 +202,7 @@ namespace search_for_drives_internal
+ stat(path.c_str(), &buf);
+ uid_t uid = buf.st_uid;
+ if (getuid() == uid)
+- out.emplace_back(DriveData{ boost::filesystem::basename(boost::filesystem::path(path)), path });
++ out.emplace_back(DriveData{ boost::filesystem::path(path).stem().string(), path });
+ }
+ }
+ }
diff --git a/media-gfx/superslicer/superslicer-2.5.59.10.ebuild b/media-gfx/superslicer/superslicer-2.5.59.10.ebuild
index 054295f8cc12..b1c347c004cc 100644
--- a/media-gfx/superslicer/superslicer-2.5.59.10.ebuild
+++ b/media-gfx/superslicer/superslicer-2.5.59.10.ebuild
@@ -68,6 +68,7 @@ PATCHES=(
"${FILESDIR}/${PN}-2.5.59.8-fix-compilation-error-gnu17.patch"
"${FILESDIR}/${PN}-2.5.59.8-libnest2d-link-xcb.patch"
"${FILESDIR}/${PN}-2.5.59.8-boost-replace-load-string-file.patch"
+ "${FILESDIR}/${PN}-2.5.59.10-boost-1.85.patch"
)
S="${WORKDIR}/${MY_PN}-${PV}"