summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-04-30 03:04:14 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-04-30 03:04:59 +0200
commit48e9dffe89142a528409ef9a57a56e4ac62bc72c (patch)
treeff0e75b0d2b0e28e36d7d600255662f21be21adc
parentdev-libs/clhpp: Drop old versions (diff)
downloadgentoo-48e9dffe89142a528409ef9a57a56e4ac62bc72c.tar.gz
gentoo-48e9dffe89142a528409ef9a57a56e4ac62bc72c.tar.bz2
gentoo-48e9dffe89142a528409ef9a57a56e4ac62bc72c.zip
sys-apps/coreutils: fix sandbox-env-test.patch
I extended PR and excluded more tests. However, I overlooked that one of these tests aren't present in 8.31. This commit will fix previous commit a48e67d33ef6edd58b2cd6111884dbb4fdef7491 and provide two versions of the patch. Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
-rw-r--r--sys-apps/coreutils/coreutils-8.32-r1.ebuild2
-rw-r--r--sys-apps/coreutils/files/coreutils-8.31-sandbox-env-test.patch12
-rw-r--r--sys-apps/coreutils/files/coreutils-8.32-sandbox-env-test.patch64
3 files changed, 65 insertions, 13 deletions
diff --git a/sys-apps/coreutils/coreutils-8.32-r1.ebuild b/sys-apps/coreutils/coreutils-8.32-r1.ebuild
index 3eac2b76aae2..153e7d36ac9e 100644
--- a/sys-apps/coreutils/coreutils-8.32-r1.ebuild
+++ b/sys-apps/coreutils/coreutils-8.32-r1.ebuild
@@ -71,7 +71,7 @@ src_prepare() {
if ! use vanilla ; then
PATCHES+=( "${WORKDIR}"/patch )
- PATCHES+=( "${FILESDIR}"/${PN}-8.31-sandbox-env-test.patch )
+ PATCHES+=( "${FILESDIR}"/${PN}-8.32-sandbox-env-test.patch )
fi
default
diff --git a/sys-apps/coreutils/files/coreutils-8.31-sandbox-env-test.patch b/sys-apps/coreutils/files/coreutils-8.31-sandbox-env-test.patch
index 40b1554d948a..f81ea13776b3 100644
--- a/sys-apps/coreutils/files/coreutils-8.31-sandbox-env-test.patch
+++ b/sys-apps/coreutils/files/coreutils-8.31-sandbox-env-test.patch
@@ -12,18 +12,6 @@ Skip tests known to fail when running under Gentoo sandbox.
print_ver_ du
require_perl_
---- a/tests/ls/removed-directory.sh
-+++ b/tests/ls/removed-directory.sh
-@@ -19,6 +19,9 @@
- # along with this program. If not, see <https://www.gnu.org/licenses/>.
-
- . "${srcdir=.}/tests/init.sh"; path_prepend_ ./src
-+# Avoid #413621 until #548250 is resolved
-+test -n "$SANDBOX_ACTIVE" && skip_ "Gentoo: Test known bad under sandbox (#413621)"
-+
- print_ver_ ls
-
- case $host_triplet in
--- a/tests/ls/stat-free-symlinks.sh
+++ b/tests/ls/stat-free-symlinks.sh
@@ -17,6 +17,9 @@
diff --git a/sys-apps/coreutils/files/coreutils-8.32-sandbox-env-test.patch b/sys-apps/coreutils/files/coreutils-8.32-sandbox-env-test.patch
new file mode 100644
index 000000000000..40b1554d948a
--- /dev/null
+++ b/sys-apps/coreutils/files/coreutils-8.32-sandbox-env-test.patch
@@ -0,0 +1,64 @@
+Skip tests known to fail when running under Gentoo sandbox.
+
+--- a/tests/du/long-from-unreadable.sh
++++ b/tests/du/long-from-unreadable.sh
+@@ -29,6 +29,9 @@
+ # unnecessarily to using FTS_NOCHDIR mode in this corner case.
+
+ . "${srcdir=.}/tests/init.sh"; path_prepend_ ./src
++# Avoid #413621 until #548250 is resolved
++test -n "$SANDBOX_ACTIVE" && skip_ "Gentoo: Test known bad under sandbox (#413621)"
++
+ print_ver_ du
+
+ require_perl_
+--- a/tests/ls/removed-directory.sh
++++ b/tests/ls/removed-directory.sh
+@@ -19,6 +19,9 @@
+ # along with this program. If not, see <https://www.gnu.org/licenses/>.
+
+ . "${srcdir=.}/tests/init.sh"; path_prepend_ ./src
++# Avoid #413621 until #548250 is resolved
++test -n "$SANDBOX_ACTIVE" && skip_ "Gentoo: Test known bad under sandbox (#413621)"
++
+ print_ver_ ls
+
+ case $host_triplet in
+--- a/tests/ls/stat-free-symlinks.sh
++++ b/tests/ls/stat-free-symlinks.sh
+@@ -17,6 +17,9 @@
+ # along with this program. If not, see <https://www.gnu.org/licenses/>.
+
+ . "${srcdir=.}/tests/init.sh"; path_prepend_ ./src
++# Avoid #413621 until #548250 is resolved
++test -n "$SANDBOX_ACTIVE" && skip_ "Gentoo: Test known bad under sandbox (#413621)"
++
+ print_ver_ ls
+ require_strace_ stat
+
+--- a/tests/misc/env-S.pl
++++ b/tests/misc/env-S.pl
+@@ -30,6 +30,11 @@ $env = $1;
+ # Turn off localization of executable's output.
+ @ENV{qw(LANGUAGE LANG LC_ALL)} = ('C') x 3;
+
++# Skip if sandbox is enabled
++if ($ENV{SANDBOX_ACTIVE}) {
++ CuSkip::skip "Gentoo: Test known bad under sandbox (#675802)\n";
++}
++
+ my @Tests =
+ (
+ # Test combination of -S and regular arguments
+--- a/tests/rm/deep-2.sh
++++ b/tests/rm/deep-2.sh
+@@ -17,6 +17,9 @@
+ # along with this program. If not, see <https://www.gnu.org/licenses/>.
+
+ . "${srcdir=.}/tests/init.sh"; path_prepend_ ./src
++# Avoid #413621 until #548250 is resolved
++test -n "$SANDBOX_ACTIVE" && skip_ "Gentoo: Test known bad under sandbox (#413621)"
++
+ print_ver_ rm
+ require_perl_
+