summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGöktürk Yüksek <gokturk@gentoo.org>2020-10-05 21:35:49 -0400
committerGöktürk Yüksek <gokturk@gentoo.org>2020-10-05 21:36:12 -0400
commit4dec7e01411cddff4b1f9b57a3cbd390576832c4 (patch)
tree386314e41ff0e7724c2e6e2a3babdb8000b78010
parentapp-emulation/crun: bump to 0.15 (diff)
downloadgentoo-4dec7e01411cddff4b1f9b57a3cbd390576832c4.tar.gz
gentoo-4dec7e01411cddff4b1f9b57a3cbd390576832c4.tar.bz2
gentoo-4dec7e01411cddff4b1f9b57a3cbd390576832c4.zip
app-crypt/yubikey-manager-qt: bump to 1.1.5
Package-Manager: Portage-2.3.89, Repoman-2.3.22 Signed-off-by: Göktürk Yüksek <gokturk@gentoo.org>
-rw-r--r--app-crypt/yubikey-manager-qt/Manifest1
-rw-r--r--app-crypt/yubikey-manager-qt/yubikey-manager-qt-1.1.5.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/app-crypt/yubikey-manager-qt/Manifest b/app-crypt/yubikey-manager-qt/Manifest
index 674ca074aac6..5f156d8403a4 100644
--- a/app-crypt/yubikey-manager-qt/Manifest
+++ b/app-crypt/yubikey-manager-qt/Manifest
@@ -1 +1,2 @@
DIST yubikey-manager-qt-1.1.4.tar.gz 13318769 BLAKE2B 4ca85d8f9681f725cf9f8d547d850516c77a618c595814c8add12250677e495952229c966a2e59d449dfa33ac9c6788f6daa8494702137eab937b299f896e8dd SHA512 9e3e85a22d7be4e6ab30b3fd068fcc3406348d2b38f96e1ef8d693bf37edafaf8f16dc408cc9319173e871cc24d2cc4db5853ec3f8a0365221722504dc6fde04
+DIST yubikey-manager-qt-1.1.5.tar.gz 16066508 BLAKE2B cd15950c68cacc3e2904a5e1fbb3a2d98544084717f379202ccfe70082b0971959178730afb9ddbbfa20f436ef8d7cdf820df1e88539f99ce77913f60228af0f SHA512 b019a7cdebd741cd536a18670795f83c7e010e221b4f9c82dcd3c57b0c4bce878865c6605f10c962f4bd5e926c285a894ea97d2925ba091847ece5ffa7ce5bb6
diff --git a/app-crypt/yubikey-manager-qt/yubikey-manager-qt-1.1.5.ebuild b/app-crypt/yubikey-manager-qt/yubikey-manager-qt-1.1.5.ebuild
new file mode 100644
index 000000000000..7154bd824ef8
--- /dev/null
+++ b/app-crypt/yubikey-manager-qt/yubikey-manager-qt-1.1.5.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit eutils qmake-utils python-single-r1 desktop
+
+DESCRIPTION="Cross-platform application for configuring any YubiKey over all USB transports"
+HOMEPAGE="https://developers.yubico.com/yubikey-manager-qt https://github.com/Yubico/yubikey-manager-qt"
+SRC_URI="https://developers.yubico.com/${PN}/Releases/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+DEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ >=app-crypt/yubikey-manager-1.0.0[${PYTHON_MULTI_USEDEP}]
+ <app-crypt/yubikey-manager-4.0.0[${PYTHON_MULTI_USEDEP}]
+ dev-python/cryptography[${PYTHON_MULTI_USEDEP}]
+ ')
+ dev-python/pyotherside[${PYTHON_SINGLE_USEDEP}]
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgraphicaleffects:5
+ dev-qt/qtgui:5
+ dev-qt/qtquickcontrols:5[widgets]
+ dev-qt/qtquickcontrols2:5[widgets]
+ dev-qt/qtsingleapplication[qt5(+),X]
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-${P}"
+
+src_prepare() {
+ default
+
+ sed -i -e "s/ykman-cli//" ${PN}.pro || die
+ sed -e "/CONFIG += c++11/a CONFIG += qtsingleapplication" \
+ -i ykman-gui/ykman-gui.pro || die
+}
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ emake install INSTALL_ROOT="${D}"
+
+ domenu resources/ykman-gui.desktop
+ doicon -s 128 resources/icons/ykman.png
+ doicon -s scalable resources/icons/ykman.svg
+
+ einstalldocs
+}