summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-03-19 01:29:30 -0400
committerTim Harder <radhermit@gentoo.org>2018-03-19 01:35:59 -0400
commit528dbc6694ed801b6f38bdd042198e3db6ecc5db (patch)
tree6be0717ca78312a392575b5288fe9392039e9cc4
parentdev-python/setuptools-git: remove old (diff)
downloadgentoo-528dbc6694ed801b6f38bdd042198e3db6ecc5db.tar.gz
gentoo-528dbc6694ed801b6f38bdd042198e3db6ecc5db.tar.bz2
gentoo-528dbc6694ed801b6f38bdd042198e3db6ecc5db.zip
dev-python/setuptools_scm: version bump to 1.15.7
-rw-r--r--dev-python/setuptools_scm/Manifest1
-rw-r--r--dev-python/setuptools_scm/setuptools_scm-1.15.7.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/setuptools_scm/Manifest b/dev-python/setuptools_scm/Manifest
index cdc9e4973a0d..c65b9404aaa0 100644
--- a/dev-python/setuptools_scm/Manifest
+++ b/dev-python/setuptools_scm/Manifest
@@ -1,2 +1,3 @@
DIST setuptools_scm-1.15.0.tar.gz 23677 BLAKE2B 72d1bb9e3bfd15157ded9a46804dc8a18bdb529268d014e5a4ba9d4a32e48cbc124cdb65ab93136a7a1b6b62a3d24e4c5775f4738db8e3e75c9c149ae9c61f9a SHA512 860fd9460f0d1d5ec9369c2936342f9679b8815e1d705999698b7bd82adb41a65048df68e57065e530972ef57e43a251ac41d6587972b1d5af40cd0249bd081d
DIST setuptools_scm-1.15.6.tar.gz 25779 BLAKE2B 01d6771c24015f072a46ff1429b964130f370f42a5cd3c634cc1bf9a506ca8547783087a0b9589ed4038168d034dddbe435540cd25a846536dc5a5c116f4168f SHA512 ae91ac28d396215be5418df3b36af726b6f2fb89707424383e920072fe8f9f75f613a99fe406cfbfffc61f9a857a3294259191694899351ef78aebba73d08816
+DIST setuptools_scm-1.15.7.tar.gz 15426 BLAKE2B 6c23f2bd74f51ec8633a814ce22e63e5afb9953244659833a61e810c9029227e1cc25a067a59cec5666add76863070ae5b7dc2600953a45def886e52378a3399 SHA512 0aa6056c03fe100cdaa7b11c9d2073431bb5c3904a80a994a8263c0ccac81f7a2c0b6c7e6dfd09ad605c5ff0e86981b894b42920cb69d1ef1d43ea08b2ddd4a0
diff --git a/dev-python/setuptools_scm/setuptools_scm-1.15.7.ebuild b/dev-python/setuptools_scm/setuptools_scm-1.15.7.ebuild
new file mode 100644
index 000000000000..dc80764a3b50
--- /dev/null
+++ b/dev-python/setuptools_scm/setuptools_scm-1.15.7.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="package to manage versions by scm tags via setuptools"
+HOMEPAGE="https://github.com/pypa/setuptools_scm https://pypi.python.org/pypi/setuptools_scm"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~amd64-fbsd"
+IUSE="git mercurial test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ git? ( dev-vcs/git )
+ mercurial? ( dev-vcs/mercurial )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+# pypi tarballs don't include tests and github tarballs don't have proper internal versioning
+RESTRICT="test"
+
+python_test() {
+ distutils_install_for_testing
+ py.test -v -v -x -k testing/test_basic_api.py || die "tests failed under ${EPYTHON}"
+ py.test -v -v -x -k testing/test_functions.py || die "tests failed under ${EPYTHON}"
+ py.test -v -v -x -k testing/test_main.py || die "tests failed under ${EPYTHON}"
+ py.test -v -v -x -k testing/test_regressions.py || die "tests failed under ${EPYTHON}"
+ if use git; then
+ py.test -v -v -x -k testing/test_git.py || die "tests failed under ${EPYTHON}"
+ fi
+ if use mercurial; then
+ py.test -v -v -x -k testing/test_mercurial.py || die "tests failed under ${EPYTHON}"
+ fi
+}