summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2023-05-09 12:00:03 +0200
committerAgostino Sarubbo <ago@gentoo.org>2023-05-09 12:00:03 +0200
commit566d99c8c6599e5920594628f8abb4ccc0f2c681 (patch)
tree7544d8d067218e08ba914e7618b2f2c642900ba6
parentwww-client/firefox: add 113.0 (diff)
downloadgentoo-566d99c8c6599e5920594628f8abb4ccc0f2c681.tar.gz
gentoo-566d99c8c6599e5920594628f8abb4ccc0f2c681.tar.bz2
gentoo-566d99c8c6599e5920594628f8abb4ccc0f2c681.zip
app-admin/hcloud: version bump to 1.33.2
Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
-rw-r--r--app-admin/hcloud/Manifest1
-rw-r--r--app-admin/hcloud/hcloud-1.33.2.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/app-admin/hcloud/Manifest b/app-admin/hcloud/Manifest
index 317db4de3a3e..ceb01f2418f2 100644
--- a/app-admin/hcloud/Manifest
+++ b/app-admin/hcloud/Manifest
@@ -1,2 +1,3 @@
DIST hcloud-1.31.1.tar.xz 1735560 BLAKE2B 66b2deaefbf61a72bf6a9e004c29d1198e5cfd40956e9936d5db27903aff5f8151c230da61b33ce4231885613d53ba5c96f99fb10df03fdcc241ec32fa465de5 SHA512 b61683ea54455be1db0ae196615642d0247e56ca51f3848847fba09124a45606aea2495f4408694acc5e819d9dc79ffdb2b9ce4e85aade7dea0335be94461066
DIST hcloud-1.33.1.tar.xz 1815372 BLAKE2B 06cdf9082a842f1103d9c446979f230ad6d2f59779321dee5a6fa1eddfb372ac7576cca411a4b296c1fda5f14b7e43c9debe6dc2542256d28a1fa7c64429ef77 SHA512 e0a09b347c9baf955a631d8ab04c7da4ea8add86006522a7551375bbf86f8b30a13d463dce12990c08ef606d2f536c5b632b4880288192cec1db9ee07416eeeb
+DIST hcloud-1.33.2.tar.xz 1826612 BLAKE2B c9c09d0d89bbec7eb95044ddabdf63eebdd778772fe068bcb1492a689764f6542c2aad6d05ead8825d603288d0d58a61f22be8a734612ad708c523b52e746625 SHA512 3475299c6a70550360ccfeb5dfb26a8f2ffc76f49e38a26cd3fa4d837ea36efe9b0873655c57cf3cad8eb000581c729a1be7c8bdf76f302f2ea95ce3fb288c2f
diff --git a/app-admin/hcloud/hcloud-1.33.2.ebuild b/app-admin/hcloud/hcloud-1.33.2.ebuild
new file mode 100644
index 000000000000..c9186ddd8470
--- /dev/null
+++ b/app-admin/hcloud/hcloud-1.33.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A command-line interface for Hetzner Cloud"
+HOMEPAGE="https://github.com/hetznercloud/cli"
+SRC_URI="https://dev.gentoo.org/~ago/distfiles/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE=""
+DEPEND="dev-lang/go:="
+RESTRICT="strip"
+QA_FLAGS_IGNORED=".*"
+
+src_compile() {
+ go build -mod vendor -o ${PN} -ldflags "-w -X github.com/hetznercloud/cli/internal/version.Version=${PV}-gentoo" ./cmd/${PN} || die "build failed"
+}
+
+src_test() {
+ # For upstream a simple test is run 'hcloud version'
+ ./hcloud version
+ if [[ $? -ne 0 ]]
+ then
+ die "Test failed"
+ fi
+}
+
+src_install() {
+ dobin ${PN}
+}