summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-06 16:16:43 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-06 16:34:22 +0100
commit5ebd4ea56c2d7d3e316db89fbc991dcffe29ad63 (patch)
treecd6345c11b07d1f9cca2a6fc3c88fcd37895bf50
parentsys-devel/clang: Add 15.x live ebuild (diff)
downloadgentoo-5ebd4ea56c2d7d3e316db89fbc991dcffe29ad63.tar.gz
gentoo-5ebd4ea56c2d7d3e316db89fbc991dcffe29ad63.tar.bz2
gentoo-5ebd4ea56c2d7d3e316db89fbc991dcffe29ad63.zip
dev-python/clang-python: Add 15.x live ebuild
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/clang-python/clang-python-15.0.0.9999.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/clang-python/clang-python-15.0.0.9999.ebuild b/dev-python/clang-python/clang-python-15.0.0.9999.ebuild
new file mode 100644
index 000000000000..fb6456619641
--- /dev/null
+++ b/dev-python/clang-python/clang-python-15.0.0.9999.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit llvm.org python-r1
+
+DESCRIPTION="Python bindings for sys-devel/clang"
+HOMEPAGE="https://llvm.org/"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+# The module is opening libclang.so directly, and doing some blasphemy
+# on top of it.
+RDEPEND="
+ >=sys-devel/clang-${PV}:*
+ !sys-devel/llvm:0[clang(-),python(-)]
+ !sys-devel/clang:0[python(-)]
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+
+LLVM_COMPONENTS=( clang/bindings/python )
+llvm.org_set_globals
+
+python_test() {
+ "${EPYTHON}" -m unittest discover -v || die "Tests fail with ${EPYTHON}"
+}
+
+src_test() {
+ python_foreach_impl python_test
+}
+
+src_install() {
+ python_foreach_impl python_domodule clang
+}