summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-01-19 21:02:27 +0000
committerSam James <sam@gentoo.org>2023-01-19 21:02:27 +0000
commit6c47136646d941a54a8e5b65df7e6a1b716c4a24 (patch)
tree19e3f8ed026ef7aa5b16836755463dfdcf4553d3
parentapp-arch/ncompress: Fix installation of the uncompress symlink (diff)
downloadgentoo-6c47136646d941a54a8e5b65df7e6a1b716c4a24.tar.gz
gentoo-6c47136646d941a54a8e5b65df7e6a1b716c4a24.tar.bz2
gentoo-6c47136646d941a54a8e5b65df7e6a1b716c4a24.zip
sys-devel/clang-common: fix path to fortify.h for cross-compilation
ESYSROOT is definitely wrong here because this is used on the final system. There's no guarantee ESYSROOT even exists then. I'd realised a few days ago and forgot to come back to this. Thanks to tt_1 for reminding. Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-devel/clang-common/clang-common-15.0.6-r1.ebuild2
-rw-r--r--sys-devel/clang-common/clang-common-15.0.7-r1.ebuild (renamed from sys-devel/clang-common/clang-common-15.0.7.ebuild)2
-rw-r--r--sys-devel/clang-common/clang-common-16.0.0.9999.ebuild2
-rw-r--r--sys-devel/clang-common/clang-common-16.0.0_pre20230101-r1.ebuild2
-rw-r--r--sys-devel/clang-common/clang-common-16.0.0_pre20230107-r1.ebuild (renamed from sys-devel/clang-common/clang-common-16.0.0_pre20230107.ebuild)2
5 files changed, 5 insertions, 5 deletions
diff --git a/sys-devel/clang-common/clang-common-15.0.6-r1.ebuild b/sys-devel/clang-common/clang-common-15.0.6-r1.ebuild
index 047c2afbd37e..4c031af64c3b 100644
--- a/sys-devel/clang-common/clang-common-15.0.6-r1.ebuild
+++ b/sys-devel/clang-common/clang-common-15.0.6-r1.ebuild
@@ -96,7 +96,7 @@ src_install() {
-fstack-clash-protection
-fstack-protector-strong
-fPIE
- -include "${ESYSROOT}/usr/include/gentoo/fortify.h"
+ -include "${EPREFIX}/usr/include/gentoo/fortify.h"
EOF
dodir /usr/include/gentoo
diff --git a/sys-devel/clang-common/clang-common-15.0.7.ebuild b/sys-devel/clang-common/clang-common-15.0.7-r1.ebuild
index 047c2afbd37e..4c031af64c3b 100644
--- a/sys-devel/clang-common/clang-common-15.0.7.ebuild
+++ b/sys-devel/clang-common/clang-common-15.0.7-r1.ebuild
@@ -96,7 +96,7 @@ src_install() {
-fstack-clash-protection
-fstack-protector-strong
-fPIE
- -include "${ESYSROOT}/usr/include/gentoo/fortify.h"
+ -include "${EPREFIX}/usr/include/gentoo/fortify.h"
EOF
dodir /usr/include/gentoo
diff --git a/sys-devel/clang-common/clang-common-16.0.0.9999.ebuild b/sys-devel/clang-common/clang-common-16.0.0.9999.ebuild
index 2fdd5cbe6a13..be17e87b775a 100644
--- a/sys-devel/clang-common/clang-common-16.0.0.9999.ebuild
+++ b/sys-devel/clang-common/clang-common-16.0.0.9999.ebuild
@@ -96,7 +96,7 @@ src_install() {
-fstack-clash-protection
-fstack-protector-strong
-fPIE
- -include "${ESYSROOT}/usr/include/gentoo/fortify.h"
+ -include "${EPREFIX}/usr/include/gentoo/fortify.h"
EOF
dodir /usr/include/gentoo
diff --git a/sys-devel/clang-common/clang-common-16.0.0_pre20230101-r1.ebuild b/sys-devel/clang-common/clang-common-16.0.0_pre20230101-r1.ebuild
index 842dddf858fd..eb35afdbc695 100644
--- a/sys-devel/clang-common/clang-common-16.0.0_pre20230101-r1.ebuild
+++ b/sys-devel/clang-common/clang-common-16.0.0_pre20230101-r1.ebuild
@@ -94,7 +94,7 @@ src_install() {
-fstack-clash-protection
-fstack-protector-strong
-fPIE
- -include "${ESYSROOT}/usr/include/gentoo/fortify.h"
+ -include "${EPREFIX}/usr/include/gentoo/fortify.h"
EOF
dodir /usr/include/gentoo
diff --git a/sys-devel/clang-common/clang-common-16.0.0_pre20230107.ebuild b/sys-devel/clang-common/clang-common-16.0.0_pre20230107-r1.ebuild
index 6f1eacac9cc2..3c407f5a1af6 100644
--- a/sys-devel/clang-common/clang-common-16.0.0_pre20230107.ebuild
+++ b/sys-devel/clang-common/clang-common-16.0.0_pre20230107-r1.ebuild
@@ -96,7 +96,7 @@ src_install() {
-fstack-clash-protection
-fstack-protector-strong
-fPIE
- -include "${ESYSROOT}/usr/include/gentoo/fortify.h"
+ -include "${EPREFIX}/usr/include/gentoo/fortify.h"
EOF
dodir /usr/include/gentoo