summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <mthode@mthode.org>2015-09-21 14:19:27 -0500
committerMatthew Thode <mthode@mthode.org>2015-09-21 14:19:51 -0500
commit703a5a3857497d85c0c40d7ca177c2d2a097d2ca (patch)
tree0e813f69028212a199d901b57f1c3d4c22ca2e28
parentdev-lang/python: Don't patch pyconfig.h.in either (diff)
downloadgentoo-703a5a3857497d85c0c40d7ca177c2d2a097d2ca.tar.gz
gentoo-703a5a3857497d85c0c40d7ca177c2d2a097d2ca.tar.bz2
gentoo-703a5a3857497d85c0c40d7ca177c2d2a097d2ca.zip
media-sound/spotify: readding paxmarks
Package-Manager: portage-2.2.20.1
-rw-r--r--media-sound/spotify/spotify-1.0.14.ebuild11
1 files changed, 11 insertions, 0 deletions
diff --git a/media-sound/spotify/spotify-1.0.14.ebuild b/media-sound/spotify/spotify-1.0.14.ebuild
index 71eb9807b20e..1105ded0ba74 100644
--- a/media-sound/spotify/spotify-1.0.14.ebuild
+++ b/media-sound/spotify/spotify-1.0.14.ebuild
@@ -80,6 +80,17 @@ src_install() {
"spotify-client.png"
done
domenu "${S}${SPOTIFY_PKG_HOME}/spotify.desktop"
+ if use pax_kernel; then
+ #create the headers, reset them to default, then paxmark -m them
+ pax-mark C "${ED}${SPOTIFY_HOME}/${PN}" || die
+ pax-mark z "${ED}${SPOTIFY_HOME}/${PN}" || die
+ pax-mark m "${ED}${SPOTIFY_HOME}/${PN}" || die
+ eqawarn "You have set USE=pax_kernel meaning that you intend to run"
+ eqawarn "${PN} under a PaX enabled kernel. To do so, we must modify"
+ eqawarn "the ${PN} binary itself and this *may* lead to breakage! If"
+ eqawarn "you suspect that ${PN} is being broken by this modification,"
+ eqawarn "please open a bug."
+ fi
}
pkg_preinst() {