summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-11-20 15:51:29 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-11-20 20:17:26 +0100
commit73e7c34f32850b62dbbe7c437d9ddb082f62ce84 (patch)
tree45a4808d6dccaa8d587d74600e88242fca2a6c5b
parentsys-apps/polychromatic: bump to 0.8.3 (diff)
downloadgentoo-73e7c34f32850b62dbbe7c437d9ddb082f62ce84.tar.gz
gentoo-73e7c34f32850b62dbbe7c437d9ddb082f62ce84.tar.bz2
gentoo-73e7c34f32850b62dbbe7c437d9ddb082f62ce84.zip
media-gfx/pinta: fix pinta launcher script
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--media-gfx/pinta/pinta-2.1.1-r1.ebuild (renamed from media-gfx/pinta/pinta-2.1.1.ebuild)7
1 files changed, 7 insertions, 0 deletions
diff --git a/media-gfx/pinta/pinta-2.1.1.ebuild b/media-gfx/pinta/pinta-2.1.1-r1.ebuild
index 0c8314e184e8..d3493a121fb7 100644
--- a/media-gfx/pinta/pinta-2.1.1.ebuild
+++ b/media-gfx/pinta/pinta-2.1.1-r1.ebuild
@@ -123,6 +123,13 @@ src_compile() {
src_install() {
emake DESTDIR="${ED}" install
+ local pinta_home="/usr/$(get_libdir)/${PN}"
+
+ mv "${ED}/usr/bin/pinta" "${ED}/${pinta_home}" || die
+ sed -e 's|dotnet|${DOTNET_ROOT}/dotnet|g' -i "${ED}/${pinta_home}/pinta" \
+ || die # No interpolation!
+ dotnet-pkg-base_dolauncher "${pinta_home}/${PN}" "${PN}"
+
rm "${ED}/usr/share/man/man1/${PN}.1.gz" || die
doman xdg/${PN}.1
}