summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-10-24 17:13:31 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-10-24 18:09:30 -0400
commit78e0d4ea5ceacc407f7c3acdec0b0eb2eff08ef0 (patch)
treed5ec73151409e16b51566f85905e6f954bfcb7db
parentsci-libs/gsl: drop 1.16, 2.5-r1 (diff)
downloadgentoo-78e0d4ea5ceacc407f7c3acdec0b0eb2eff08ef0.tar.gz
gentoo-78e0d4ea5ceacc407f7c3acdec0b0eb2eff08ef0.tar.bz2
gentoo-78e0d4ea5ceacc407f7c3acdec0b0eb2eff08ef0.zip
dev-util/maturin: filter out -flto
ring crate uses C and not seeing a way to skip using it, filter out lto to avoid undefined references Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--dev-util/maturin/maturin-0.11.5.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/dev-util/maturin/maturin-0.11.5.ebuild b/dev-util/maturin/maturin-0.11.5.ebuild
index 3ab6a9155f46..896159452b6d 100644
--- a/dev-util/maturin/maturin-0.11.5.ebuild
+++ b/dev-util/maturin/maturin-0.11.5.ebuild
@@ -243,7 +243,7 @@ CRATES_TEST="
scopeguard-1.1.0
smallvec-1.7.0"
PYTHON_COMPAT=( python3_{8..10} )
-inherit cargo python-any-r1
+inherit cargo flag-o-matic python-any-r1
DESCRIPTION="Build and publish crates with pyo3, rust-cpython and cffi bindings"
HOMEPAGE="https://github.com/pyo3/maturin"
@@ -278,6 +278,12 @@ pkg_setup() {
use test && python-any-r1_pkg_setup
}
+src_configure() {
+ filter-flags '-flto*' # undefined references with ring crate
+
+ cargo_src_configure
+}
+
src_test() {
cargo_src_test -- --skip locked_doesnt_build_without_cargo_lock
}