summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatoro Mahri <matoro@users.noreply.github.com>2023-06-04 20:22:44 -0400
committerSam James <sam@gentoo.org>2023-06-06 08:18:05 +0100
commit7bd5f73712cedd79493e2b3e3447562191202ee0 (patch)
treea80292e2fc4473ab9a19e8c38f382e95c4250350
parentdev-util/plan9port: X always needs fontconfig/freetype now (diff)
downloadgentoo-7bd5f73712cedd79493e2b3e3447562191202ee0.tar.gz
gentoo-7bd5f73712cedd79493e2b3e3447562191202ee0.tar.bz2
gentoo-7bd5f73712cedd79493e2b3e3447562191202ee0.zip
dev-libs/nettle: wire up power8/power9 intrinsics
Signed-off-by: Matoro Mahri <matoro@users.noreply.github.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-libs/nettle/nettle-3.9.1.ebuild8
1 files changed, 3 insertions, 5 deletions
diff --git a/dev-libs/nettle/nettle-3.9.1.ebuild b/dev-libs/nettle/nettle-3.9.1.ebuild
index 8e0867d6b2f1..81c854b6b187 100644
--- a/dev-libs/nettle/nettle-3.9.1.ebuild
+++ b/dev-libs/nettle/nettle-3.9.1.ebuild
@@ -15,7 +15,7 @@ LICENSE="|| ( LGPL-3 LGPL-2.1 )"
# Subslot = libnettle - libhogweed soname version
SLOT="0/8-6"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
-IUSE="+asm doc +gmp static-libs cpu_flags_arm_neon cpu_flags_arm_aes cpu_flags_arm_sha1 cpu_flags_arm_sha2 cpu_flags_ppc_altivec cpu_flags_x86_aes cpu_flags_x86_sha cpu_flags_x86_pclmul"
+IUSE="+asm doc +gmp static-libs cpu_flags_arm_neon cpu_flags_arm_aes cpu_flags_arm_sha1 cpu_flags_arm_sha2 cpu_flags_ppc_altivec cpu_flags_ppc_vsx2 cpu_flags_ppc_vsx3 cpu_flags_x86_aes cpu_flags_x86_sha cpu_flags_x86_pclmul"
# The arm64 crypto option controls AES, SHA1, and SHA2 usage.
REQUIRED_USE="
cpu_flags_arm_aes? ( cpu_flags_arm_sha1 cpu_flags_arm_sha2 )
@@ -63,13 +63,11 @@ multilib_src_configure() {
$(use_enable cpu_flags_arm_neon arm-neon)
$(use_enable cpu_flags_arm_aes arm64-crypto)
$(use_enable cpu_flags_ppc_altivec power-altivec)
+ $(use_enable cpu_flags_ppc_vsx2 power-crypto-ext)
+ $(use_enable cpu_flags_ppc_vsx3 power9)
$(use_enable cpu_flags_x86_aes x86-aesni)
$(use_enable cpu_flags_x86_sha x86-sha-ni)
$(use_enable cpu_flags_x86_pclmul x86-pclmul)
- # TODO: PPC crypto flag?
- --disable-power-crypto-ext
- # TODO: How do we detect this in ebuilds reliably?
- --disable-power9
$([[ ${CHOST} == *-solaris* ]] && echo '--disable-symbol-versions')
# TODO: cpu_flags_s390?
--disable-s390x-vf