summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-10-30 18:16:58 +0100
committerMichał Górny <mgorny@gentoo.org>2020-10-30 18:23:22 +0100
commit7c5b8d43b61e2dfc2d8ba2608743e7ada698cfbc (patch)
treee6a859ae7f246502118d86fba1ce13888b0ab109
parentdev-python/pytest-services: Bump to 2.2.1 (diff)
downloadgentoo-7c5b8d43b61e2dfc2d8ba2608743e7ada698cfbc.tar.gz
gentoo-7c5b8d43b61e2dfc2d8ba2608743e7ada698cfbc.tar.bz2
gentoo-7c5b8d43b61e2dfc2d8ba2608743e7ada698cfbc.zip
dev-python/elementpath: Bump to 2.0.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/elementpath/Manifest1
-rw-r--r--dev-python/elementpath/elementpath-2.0.4.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/elementpath/Manifest b/dev-python/elementpath/Manifest
index b47eed41300f..fd26efdec1f0 100644
--- a/dev-python/elementpath/Manifest
+++ b/dev-python/elementpath/Manifest
@@ -1 +1,2 @@
DIST elementpath-2.0.3.tar.gz 191499 BLAKE2B dd8ee226b5e04168de90e0375db971bb51aad233cbc56a63e1a79aa847fffbeddc5438ca769317ccd0ad6f30aad61ec65fe9dc7c32dfff687e8cd208ccf9ee46 SHA512 fccb291405aafa5751f0dbb636171145a41941e929dd93b097d61f11366e71757f47a65c32b83fd8ad0fafcfb530315417ea879b3e05421bc479b2e309960006
+DIST elementpath-2.0.4.tar.gz 191601 BLAKE2B fc2f29a737c180fb04cc289b8cd9149b7a4f3c317a5efd746c42658aa6fbfe5cb78b957f517ba9a9e8650cc1ba0ee885a723695a8a107ec4cc05328828f5cf21 SHA512 b114ebe054eb6f46e261ae2a39c8126b86abafba26803eee676731d8d46d613daf5493215873ae96c9b098f6ebf9961a1ac777ddc0a1e2b1e4a3ca924d74c213
diff --git a/dev-python/elementpath/elementpath-2.0.4.ebuild b/dev-python/elementpath/elementpath-2.0.4.ebuild
new file mode 100644
index 000000000000..c7a8e1d2336a
--- /dev/null
+++ b/dev-python/elementpath/elementpath-2.0.4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="XPath 1.0/2.0 parsers and selectors for ElementTree and lxml"
+HOMEPAGE="https://github.com/sissaschool/elementpath
+ https://pypi.org/project/elementpath/"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/xmlschema[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests unittest