summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-21 09:41:25 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-21 09:56:16 +0200
commit802bc18da2867e88f290b6889b1d58e1cf21a284 (patch)
treecb5513b727da80de90e54ebca8374e1e27f9a93b
parentdev-python/mako: Bump to 1.1.5 (diff)
downloadgentoo-802bc18da2867e88f290b6889b1d58e1cf21a284.tar.gz
gentoo-802bc18da2867e88f290b6889b1d58e1cf21a284.tar.bz2
gentoo-802bc18da2867e88f290b6889b1d58e1cf21a284.zip
dev-python/django-mptt: Bump to 0.13
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/django-mptt/Manifest1
-rw-r--r--dev-python/django-mptt/django-mptt-0.13.ebuild31
-rw-r--r--dev-python/django-mptt/files/django-mptt-0.13-test-install.patch26
3 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/django-mptt/Manifest b/dev-python/django-mptt/Manifest
index 3aa926d0a79a..9f942579e7d4 100644
--- a/dev-python/django-mptt/Manifest
+++ b/dev-python/django-mptt/Manifest
@@ -1 +1,2 @@
DIST django-mptt-0.11.0.tar.gz 98300 BLAKE2B cbae24143007dfe8913aacf4cbe22bbccdf929617adc31640c2d429d6ea8be727a937be0aa8353e82862b9fe8c571397db4dd3877015eb17c2c5a56172cc66a5 SHA512 21af30007661db1474628b6f8af86a3f6de52494efe1aaf9235f8b1660ba153f0de3ad91ff979588e4b681b00b44652a05146df7d3951d6ee62da38a1900fd89
+DIST django-mptt-0.13.gh.tar.gz 302525 BLAKE2B 21b2fde5c81d83321bf7569d2064db87aec3c184f27cf3fc3bd34421be04212188e15f79a575b08aabb3a7b95d116bf3e5f0fb57c56cadf9ad2ac166e8e77845 SHA512 63dbb61dab59d42b5e747f35370a0840d40ed465979d1f93e66561cf4c0726635cae774f87e39cc1ac480847f3ccf0eb65dc8593759a0860d586e334fdd37256
diff --git a/dev-python/django-mptt/django-mptt-0.13.ebuild b/dev-python/django-mptt/django-mptt-0.13.ebuild
new file mode 100644
index 000000000000..584beed17861
--- /dev/null
+++ b/dev-python/django-mptt/django-mptt-0.13.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="utilities for modified preorder tree traversal and trees of model instances"
+HOMEPAGE="https://github.com/django-mptt/django-mptt"
+SRC_URI="
+ https://github.com/django-mptt/django-mptt/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/django-1.11[${PYTHON_USEDEP}]
+ dev-python/django-js-asset[${PYTHON_USEDEP}]
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-test-install.patch
+)
+
+python_test() {
+ "${EPYTHON}" tests/manage.py test -v2 myapp ||
+ die "Tests failed with ${EPYTHON}"
+}
diff --git a/dev-python/django-mptt/files/django-mptt-0.13-test-install.patch b/dev-python/django-mptt/files/django-mptt-0.13-test-install.patch
new file mode 100644
index 000000000000..886d5c6e4ebd
--- /dev/null
+++ b/dev-python/django-mptt/files/django-mptt-0.13-test-install.patch
@@ -0,0 +1,26 @@
+From 6bc5860575d491e8cf1edbabee7b07f1c072bdba Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Sat, 21 Aug 2021 09:45:45 +0200
+Subject: [PATCH] Do not install tests.myapp
+
+Fix options.packages.find.exclude to cover subpackages of "tests"
+recursively. Otherwise, tests.myapp is installed.
+---
+ setup.cfg | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/setup.cfg b/setup.cfg
+index b4094dc..b8ebee3 100644
+--- a/setup.cfg
++++ b/setup.cfg
+@@ -44,6 +44,7 @@ tests =
+ [options.packages.find]
+ exclude =
+ tests
++ tests.*
+ myapp
+
+ [flake8]
+--
+2.33.0
+