summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-03-23 01:42:44 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-03-23 01:49:15 +0100
commit892ca486d3898986d789d825a606f5ca71eab843 (patch)
treeb907bc54e7e668e7967bc5760297644ac8c53e4b
parentapp-containers/devcontainer: bump to 0.58.0 (diff)
downloadgentoo-892ca486d3898986d789d825a606f5ca71eab843.tar.gz
gentoo-892ca486d3898986d789d825a606f5ca71eab843.tar.bz2
gentoo-892ca486d3898986d789d825a606f5ca71eab843.zip
dev-util/blueprint-compiler: bump to 0.12.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--dev-util/blueprint-compiler/Manifest1
-rw-r--r--dev-util/blueprint-compiler/blueprint-compiler-0.12.0.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-util/blueprint-compiler/Manifest b/dev-util/blueprint-compiler/Manifest
index e4e30da6e882..82f29714c460 100644
--- a/dev-util/blueprint-compiler/Manifest
+++ b/dev-util/blueprint-compiler/Manifest
@@ -1 +1,2 @@
DIST blueprint-compiler-v0.10.0.tar.bz2 81856 BLAKE2B 8e63c27fc160244eb11776ea57c57b9c4b06aded76f3d59fc3190609f20a58985e3e800eebb5c69e681f8f8aba35f06f457f4dde241f78ff76d3e9348c4df46d SHA512 5d6a14a42aed64a82572a59730d454a920938d3b2c8aa1e61ab1d5fba47647ab5e3d6201c8ffe3e622b450ffcfb1eaf106951489897422c3e578d4d3695ae9ab
+DIST blueprint-compiler-v0.12.0.tar.bz2 90521 BLAKE2B 0c54f287c2d9e6869f323981eaff16785aa4fa7b1c600629bccde059205950f70f2202642130500133c69235ce42abfb5b5492a5727da561db9fe6c865939bb8 SHA512 c1f2f1ab02773b8c9c1d92035a51cd3b5c769a129ea028e02b8d2d88a7a9cb44f14edefd0f8718b90313a22134d8cbab4f699942f7049edd3146b41735e68f56
diff --git a/dev-util/blueprint-compiler/blueprint-compiler-0.12.0.ebuild b/dev-util/blueprint-compiler/blueprint-compiler-0.12.0.ebuild
new file mode 100644
index 000000000000..7690faf1230b
--- /dev/null
+++ b/dev-util/blueprint-compiler/blueprint-compiler-0.12.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit meson python-single-r1 virtualx
+
+DESCRIPTION="Compiler for Blueprint, a markup language for GTK user interfaces"
+HOMEPAGE="https://jwestman.pages.gitlab.gnome.org/blueprint-compiler/
+ https://gitlab.gnome.org/jwestman/blueprint-compiler/"
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://gitlab.gnome.org/jwestman/${PN}.git"
+else
+ SRC_URI="https://gitlab.gnome.org/jwestman/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.bz2"
+ S="${WORKDIR}/${PN}-v${PV}"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="LGPL-3+"
+SLOT="0"
+IUSE="doc test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+"
+BDEPEND="
+ ${RDEPEND}
+ doc? (
+ $(python_gen_cond_dep '
+ dev-python/furo[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ ')
+ )
+ test? (
+ gui-libs/gtk:4[introspection]
+ gui-libs/libadwaita:1[introspection]
+ )
+"
+
+DOCS=( CONTRIBUTING.md MAINTENANCE.md NEWS.md README.md )
+
+src_configure() {
+ local -a emesonargs=(
+ $(meson_use doc docs)
+ )
+ meson_src_configure
+}
+
+src_compile() {
+ meson_src_compile
+
+ use doc && build_sphinx docs
+}
+
+src_test() {
+ virtx meson_src_test
+}
+
+src_install() {
+ meson_src_install
+ python_fix_shebang "${ED}"/usr/bin
+ python_optimize
+}