summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2015-09-21 12:51:19 -0700
committerMatt Turner <mattst88@gentoo.org>2015-09-21 12:51:42 -0700
commit8a3f7a2f99c04c6d43988d17b18f19c00cf1db0f (patch)
treedcea224f6462f46a1896e46060d8bf31bb839fd9
parentapp-crypt/monkeysphere-0.37: Stable for amd64 (diff)
downloadgentoo-8a3f7a2f99c04c6d43988d17b18f19c00cf1db0f.tar.gz
gentoo-8a3f7a2f99c04c6d43988d17b18f19c00cf1db0f.tar.bz2
gentoo-8a3f7a2f99c04c6d43988d17b18f19c00cf1db0f.zip
media-libs/mesa: Update to use upstream glx-read-only-text flag.
Package-Manager: portage-2.2.20.1
-rw-r--r--media-libs/mesa/mesa-9999.ebuild11
1 files changed, 3 insertions, 8 deletions
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index d166219537e8..e7cf9a92e44e 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -191,10 +191,7 @@ pkg_setup() {
}
src_prepare() {
- # fix for hardened pax_kernel, bug 240956
- [[ ${PV} != 9999* ]] && epatch "${FILESDIR}"/glx_ro_text_segm.patch
-
- eautoreconf
+ [[ ${PV} == 9999 ]] && eautoreconf
}
multilib_src_configure() {
@@ -268,11 +265,9 @@ multilib_src_configure() {
fi
fi
- # x86 hardened pax_kernel needs glx-rts, bug 240956
+ # x86 hardened pax_kernel needs glx-read-only-text, bug 240956
if use pax_kernel; then
- myconf+="
- $(use_enable x86 glx-rts)
- "
+ myconf+="$(use_enable x86 glx-read-only-text)"
fi
# on abi_x86_32 hardened we need to have asm disable