summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2024-08-01 07:49:13 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2024-08-01 07:49:13 +0000
commit924795db1da88d5249c4b73db77bf7e3ed5820a4 (patch)
treeaf95a0f9bfa9f20319be16591837890a14842224
parent2024-08-01 07:34:15 UTC (diff)
parentmedia-sound/wavplay: fix pkgcheck issues (diff)
downloadgentoo-924795db1da88d5249c4b73db77bf7e3ed5820a4.tar.gz
gentoo-924795db1da88d5249c4b73db77bf7e3ed5820a4.tar.bz2
gentoo-924795db1da88d5249c4b73db77bf7e3ed5820a4.zip
Merge updates from master
-rw-r--r--eclass/java-utils-2.eclass2
-rw-r--r--media-sound/aeolus/aeolus-0.10.4.ebuild7
-rw-r--r--media-sound/alsamixer-app/alsamixer-app-0.1-r1.ebuild6
-rw-r--r--media-sound/alsamixergui/alsamixergui-0.9.0.1.2-r4.ebuild5
-rw-r--r--media-sound/apetag/apetag-1.12-r3.ebuild5
-rw-r--r--media-sound/awesfx/awesfx-0.5.2-r1.ebuild1
-rw-r--r--media-sound/bempc/bempc-0.11_p20160207.ebuild3
-rw-r--r--media-sound/cdtool/cdtool-2.1.8-r1.ebuild7
-rw-r--r--media-sound/coquillo/coquillo-2.0.1.ebuild3
-rw-r--r--media-sound/frescobaldi/frescobaldi-3.3.0.ebuild3
-rw-r--r--media-sound/helm/helm-0.9.0-r2.ebuild3
-rw-r--r--media-sound/id3ted/id3ted-1.0.ebuild3
-rw-r--r--media-sound/justeport/justeport-0.2.ebuild10
-rw-r--r--media-sound/meterbridge/meterbridge-0.9.3.ebuild7
-rw-r--r--media-sound/mp3cat/mp3cat-0.5.ebuild3
-rw-r--r--media-sound/mp3diags/mp3diags-1.5.01-r1.ebuild4
-rw-r--r--media-sound/mpdas/mpdas-0.4.5.ebuild7
-rw-r--r--media-sound/musique/musique-1.5-r1.ebuild3
-rw-r--r--media-sound/ogg2mp3/ogg2mp3-0.6.1-r1.ebuild3
-rw-r--r--media-sound/peercast/peercast-0.1218-r2.ebuild15
-rw-r--r--media-sound/podcatcher/podcatcher-3.1.6.ebuild6
-rw-r--r--media-sound/ptabtools/ptabtools-0.5.0.ebuild5
-rw-r--r--media-sound/pulseaudio-ctl/pulseaudio-ctl-1.70-r1.ebuild3
-rw-r--r--media-sound/qastools/qastools-0.23.0.ebuild8
-rw-r--r--media-sound/qastools/qastools-1.4.0.ebuild5
-rw-r--r--media-sound/qtagger/qtagger-1.0.1_p20150402.ebuild6
-rw-r--r--media-sound/qtscrobbler/qtscrobbler-0.11_pre20130123.ebuild8
-rw-r--r--media-sound/quimup/quimup-1.4.4.ebuild4
-rw-r--r--media-sound/sidplay/sidplay-2.0.9-r2.ebuild1
-rw-r--r--media-sound/smixer/smixer-1.0.4.ebuild6
-rw-r--r--media-sound/taginfo/taginfo-1.2-r2.ebuild3
-rw-r--r--media-sound/vsound/vsound-0.6-r1.ebuild3
-rw-r--r--media-sound/wavplay/wavplay-2.0.ebuild3
33 files changed, 54 insertions, 107 deletions
diff --git a/eclass/java-utils-2.eclass b/eclass/java-utils-2.eclass
index 559342068cc0..9c657cc4c1f9 100644
--- a/eclass/java-utils-2.eclass
+++ b/eclass/java-utils-2.eclass
@@ -1926,7 +1926,7 @@ etestng() {
local runner=org.testng.TestNG
if [[ ${PN} != testng ]]; then
- local cp=$(java-pkg_getjars --with-dependencies testng)
+ local cp=$(java-pkg_getjars --build-only --with-dependencies testng)
else
local cp=testng.jar
fi
diff --git a/media-sound/aeolus/aeolus-0.10.4.ebuild b/media-sound/aeolus/aeolus-0.10.4.ebuild
index 81f44ef16f3c..e1892d33fb6e 100644
--- a/media-sound/aeolus/aeolus-0.10.4.ebuild
+++ b/media-sound/aeolus/aeolus-0.10.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -12,11 +12,8 @@ SRC_URI="http://kokkinizita.linuxaudio.org/linuxaudio/downloads/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE=""
-BDEPEND="
- virtual/pkgconfig
-"
+BDEPEND="virtual/pkgconfig"
CDEPEND="
dev-libs/libclthreads
media-libs/alsa-lib
diff --git a/media-sound/alsamixer-app/alsamixer-app-0.1-r1.ebuild b/media-sound/alsamixer-app/alsamixer-app-0.1-r1.ebuild
index 7a212477239b..a612a07692aa 100644
--- a/media-sound/alsamixer-app/alsamixer-app-0.1-r1.ebuild
+++ b/media-sound/alsamixer-app/alsamixer-app-0.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -11,11 +11,11 @@ MY_P=${MY_PN}-${PV}
DESCRIPTION="simple alsa mixer dockapp"
HOMEPAGE="https://www.dockapps.net/alsamixerapp"
SRC_URI="https://www.dockapps.net/download/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
RDEPEND="x11-libs/libX11
x11-libs/libXpm
@@ -24,8 +24,6 @@ RDEPEND="x11-libs/libX11
DEPEND="${RDEPEND}
x11-base/xorg-proto"
-S=${WORKDIR}/${MY_P}
-
PATCHES=( "${FILESDIR}"/${P}-Makefile.patch )
src_compile() {
diff --git a/media-sound/alsamixergui/alsamixergui-0.9.0.1.2-r4.ebuild b/media-sound/alsamixergui/alsamixergui-0.9.0.1.2-r4.ebuild
index 1144c94e53b2..aed21c078e94 100644
--- a/media-sound/alsamixergui/alsamixergui-0.9.0.1.2-r4.ebuild
+++ b/media-sound/alsamixergui/alsamixergui-0.9.0.1.2-r4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -10,11 +10,11 @@ MY_P=${PN}-0.9.0rc1-2
DESCRIPTION="FLTK based amixer Frontend"
HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 arm ppc ppc64 sparc x86"
-IUSE=""
RDEPEND="
media-libs/alsa-lib:=
@@ -22,7 +22,6 @@ RDEPEND="
x11-libs/fltk:1"
DEPEND="${RDEPEND}"
-S="${WORKDIR}/${MY_P}"
PATCHES=(
"${FILESDIR}"/${P}-gcc34.patch
"${FILESDIR}"/segfault-on-exit.patch
diff --git a/media-sound/apetag/apetag-1.12-r3.ebuild b/media-sound/apetag/apetag-1.12-r3.ebuild
index 38204d8befaf..fb7826821296 100644
--- a/media-sound/apetag/apetag-1.12-r3.ebuild
+++ b/media-sound/apetag/apetag-1.12-r3.ebuild
@@ -10,18 +10,17 @@ inherit python-single-r1 toolchain-funcs
DESCRIPTION="Command-line ape 2.0 tagger"
HOMEPAGE="https://robert.muth.org/Apetag/"
SRC_URI="https://robert.muth.org/Apetag/${PN}.${PV}.tar.gz"
+S="${WORKDIR}/${PN^}"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="amd64 ppc ppc64 ~riscv x86"
-IUSE=""
+
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="${PYTHON_DEPS}"
DEPEND="${RDEPEND}"
-S=${WORKDIR}/${PN^}
-
DOCS=( 00readme )
PATCHES=(
diff --git a/media-sound/awesfx/awesfx-0.5.2-r1.ebuild b/media-sound/awesfx/awesfx-0.5.2-r1.ebuild
index 082914feb1dd..72b3b33d73bf 100644
--- a/media-sound/awesfx/awesfx-0.5.2-r1.ebuild
+++ b/media-sound/awesfx/awesfx-0.5.2-r1.ebuild
@@ -12,7 +12,6 @@ SRC_URI="https://github.com/tiwai/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="amd64 ~ppc ~sparc x86"
-IUSE=""
DEPEND="media-libs/alsa-lib"
RDEPEND="${DEPEND}"
diff --git a/media-sound/bempc/bempc-0.11_p20160207.ebuild b/media-sound/bempc/bempc-0.11_p20160207.ebuild
index b56d80d99133..853e61ad836f 100644
--- a/media-sound/bempc/bempc-0.11_p20160207.ebuild
+++ b/media-sound/bempc/bempc-0.11_p20160207.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -13,7 +13,6 @@ SRC_URI="https://sourceforge.net/code-snapshots/git/b/be/be-mpc/code.git/be-mpc-
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
RDEPEND="
dev-qt/qtcore:5
diff --git a/media-sound/cdtool/cdtool-2.1.8-r1.ebuild b/media-sound/cdtool/cdtool-2.1.8-r1.ebuild
index 0d81cefca180..c95d197d9ecb 100644
--- a/media-sound/cdtool/cdtool-2.1.8-r1.ebuild
+++ b/media-sound/cdtool/cdtool-2.1.8-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -10,11 +10,10 @@ SRC_URI="http://hinterhof.net/cdtool/dist/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc sparc x86"
-IUSE=""
RDEPEND="!media-sound/cdplay"
PATCHES=(
- "${FILESDIR}"/${P}-glibc-2.10.patch
- "${FILESDIR}"/${P}-fix-build-system.patch
+ "${FILESDIR}/${P}-glibc-2.10.patch"
+ "${FILESDIR}/${P}-fix-build-system.patch"
)
diff --git a/media-sound/coquillo/coquillo-2.0.1.ebuild b/media-sound/coquillo/coquillo-2.0.1.ebuild
index bf07ce9d9997..58e806189020 100644
--- a/media-sound/coquillo/coquillo-2.0.1.ebuild
+++ b/media-sound/coquillo/coquillo-2.0.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -12,7 +12,6 @@ SRC_URI="https://github.com/sjuvonen/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="LGPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
DEPEND="
dev-qt/qtconcurrent:5
diff --git a/media-sound/frescobaldi/frescobaldi-3.3.0.ebuild b/media-sound/frescobaldi/frescobaldi-3.3.0.ebuild
index bda72123c1cb..443bf7ca7fa8 100644
--- a/media-sound/frescobaldi/frescobaldi-3.3.0.ebuild
+++ b/media-sound/frescobaldi/frescobaldi-3.3.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -14,7 +14,6 @@ SRC_URI="https://github.com/frescobaldi/frescobaldi/archive/refs/tags/v${PV}.tar
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~x86"
-IUSE=""
DEPEND="
dev-python/PyQt5[gui,network,printsupport,svg,widgets,${PYTHON_USEDEP}]
diff --git a/media-sound/helm/helm-0.9.0-r2.ebuild b/media-sound/helm/helm-0.9.0-r2.ebuild
index 46ef109dc534..24c298e694e9 100644
--- a/media-sound/helm/helm-0.9.0-r2.ebuild
+++ b/media-sound/helm/helm-0.9.0-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -12,7 +12,6 @@ SRC_URI="https://github.com/mtytel/helm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="amd64"
-IUSE=""
DEPEND="
media-libs/alsa-lib
diff --git a/media-sound/id3ted/id3ted-1.0.ebuild b/media-sound/id3ted/id3ted-1.0.ebuild
index bc33e7789072..53f2ab73db34 100644
--- a/media-sound/id3ted/id3ted-1.0.ebuild
+++ b/media-sound/id3ted/id3ted-1.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -12,7 +12,6 @@ SRC_URI="https://github.com/xyb3rt/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE=""
RDEPEND="
media-libs/taglib
diff --git a/media-sound/justeport/justeport-0.2.ebuild b/media-sound/justeport/justeport-0.2.ebuild
index 9ae648843057..d0de69fdd0d8 100644
--- a/media-sound/justeport/justeport-0.2.ebuild
+++ b/media-sound/justeport/justeport-0.2.ebuild
@@ -1,26 +1,22 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit mono multilib
-
-MY_P=JustePort-${PV}
+MY_P="JustePort-${PV}"
DESCRIPTION="Stream audio to your AirPort Express"
HOMEPAGE="http://nanocrew.net/software/justeport/"
SRC_URI="http://nanocrew.net/sw/justeport/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
DEPEND="dev-lang/mono"
RDEPEND="${DEPEND}"
-S=${WORKDIR}/${MY_P}
-
src_install() {
insinto /usr/$(get_libdir)/justeport
doins *.exe
diff --git a/media-sound/meterbridge/meterbridge-0.9.3.ebuild b/media-sound/meterbridge/meterbridge-0.9.3.ebuild
index 795b52410328..ca459c792598 100644
--- a/media-sound/meterbridge/meterbridge-0.9.3.ebuild
+++ b/media-sound/meterbridge/meterbridge-0.9.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -12,11 +12,8 @@ SRC_URI="http://plugin.org.uk/meterbridge/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86"
-IUSE=""
-BDEPEND="
- virtual/pkgconfig
-"
+BDEPEND="virtual/pkgconfig"
RDEPEND="
>=media-libs/libsdl-1.2
>=media-libs/sdl-image-1.2.10[png]
diff --git a/media-sound/mp3cat/mp3cat-0.5.ebuild b/media-sound/mp3cat/mp3cat-0.5.ebuild
index f12a8af66ec2..60b2e84b18ed 100644
--- a/media-sound/mp3cat/mp3cat-0.5.ebuild
+++ b/media-sound/mp3cat/mp3cat-0.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -12,7 +12,6 @@ SRC_URI="https://github.com/tomclegg/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
src_prepare() {
default
diff --git a/media-sound/mp3diags/mp3diags-1.5.01-r1.ebuild b/media-sound/mp3diags/mp3diags-1.5.01-r1.ebuild
index b255fbbcf6d3..f24ca83fc6c4 100644
--- a/media-sound/mp3diags/mp3diags-1.5.01-r1.ebuild
+++ b/media-sound/mp3diags/mp3diags-1.5.01-r1.ebuild
@@ -11,11 +11,11 @@ MY_P=${MY_PN}-${PV}
DESCRIPTION="Qt-based MP3 diagnosis and repair tool"
HOMEPAGE="http://mp3diags.sourceforge.net"
SRC_URI="https://downloads.sourceforge.net/${PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
LICENSE="LGPL-3 GPL-2"
SLOT="0"
KEYWORDS="~amd64"
-IUSE=""
DEPEND="
dev-libs/boost:=
@@ -29,8 +29,6 @@ RDEPEND="${DEPEND}
dev-qt/qtsvg:5
"
-S=${WORKDIR}/${MY_P}
-
src_prepare() {
# unused dependency - bug #711086
sed -i -e "/^network/d" src/src.pro || die
diff --git a/media-sound/mpdas/mpdas-0.4.5.ebuild b/media-sound/mpdas/mpdas-0.4.5.ebuild
index 3ef2228a59fe..1aabaeef5389 100644
--- a/media-sound/mpdas/mpdas-0.4.5.ebuild
+++ b/media-sound/mpdas/mpdas-0.4.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -12,11 +12,8 @@ SRC_URI="https://50hz.ws/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE=""
-BDEPEND="
- virtual/pkgconfig
-"
+BDEPEND="virtual/pkgconfig"
DEPEND="
media-libs/libmpdclient
net-misc/curl"
diff --git a/media-sound/musique/musique-1.5-r1.ebuild b/media-sound/musique/musique-1.5-r1.ebuild
index 1763328bfb02..08415ee2a643 100644
--- a/media-sound/musique/musique-1.5-r1.ebuild
+++ b/media-sound/musique/musique-1.5-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -12,7 +12,6 @@ SRC_URI="https://github.com/flaviotordini/${PN}/archive/${PV}.tar.gz -> ${P}.tar
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE=""
RDEPEND="
dev-qt/qtcore:5
diff --git a/media-sound/ogg2mp3/ogg2mp3-0.6.1-r1.ebuild b/media-sound/ogg2mp3/ogg2mp3-0.6.1-r1.ebuild
index ce4c6570fe3b..8e9cc446398d 100644
--- a/media-sound/ogg2mp3/ogg2mp3-0.6.1-r1.ebuild
+++ b/media-sound/ogg2mp3/ogg2mp3-0.6.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -13,7 +13,6 @@ S="${WORKDIR}/${PN}-${COMMIT}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86"
-IUSE=""
RDEPEND="
dev-perl/String-ShellQuote
diff --git a/media-sound/peercast/peercast-0.1218-r2.ebuild b/media-sound/peercast/peercast-0.1218-r2.ebuild
index 463ecc557718..d311a2b90d14 100644
--- a/media-sound/peercast/peercast-0.1218-r2.ebuild
+++ b/media-sound/peercast/peercast-0.1218-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -8,21 +8,16 @@ inherit flag-o-matic toolchain-funcs
DESCRIPTION="A client and server for Peercast P2P-radio network"
HOMEPAGE="http://www.peercast.org"
SRC_URI="http://www.peercast.org/src/${P}-src.tgz"
+S="${WORKDIR}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE=""
-
-RDEPEND=""
-DEPEND=""
-
-S=${WORKDIR}
PATCHES=(
- "${FILESDIR}/${P}-CVE-2008-2040.patch" \
- "${FILESDIR}/${PN}-0.1216-makefile.patch" \
- "${FILESDIR}/${PN}-0.1216-amd64.patch" \
+ "${FILESDIR}/${P}-CVE-2008-2040.patch"
+ "${FILESDIR}/${PN}-0.1216-makefile.patch"
+ "${FILESDIR}/${PN}-0.1216-amd64.patch"
"${FILESDIR}/${P}-glibc-2.10.patch"
)
diff --git a/media-sound/podcatcher/podcatcher-3.1.6.ebuild b/media-sound/podcatcher/podcatcher-3.1.6.ebuild
index 454b549b1920..ca561acfcdf1 100644
--- a/media-sound/podcatcher/podcatcher-3.1.6.ebuild
+++ b/media-sound/podcatcher/podcatcher-3.1.6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -6,17 +6,15 @@ EAPI=7
DESCRIPTION="Podcast client for the command-line written in Ruby"
HOMEPAGE="http://podcatcher.rubyforge.org/"
SRC_URI="http://rubyforge.org/frs/download.php/76053/${P}.tar.gz"
+S="${WORKDIR}/${PN}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
RDEPEND="dev-lang/ruby"
DEPEND="${RDEPEND}"
-S="${WORKDIR}/${PN}"
-
src_install() {
dobin bin/podcatcher
dodoc -r demo/.
diff --git a/media-sound/ptabtools/ptabtools-0.5.0.ebuild b/media-sound/ptabtools/ptabtools-0.5.0.ebuild
index 15641a2b9e4c..02304ba134eb 100644
--- a/media-sound/ptabtools/ptabtools-0.5.0.ebuild
+++ b/media-sound/ptabtools/ptabtools-0.5.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -12,14 +12,13 @@ SRC_URI="https://www.samba.org/~jelmer/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc x86"
-IUSE=""
+BDEPEND="virtual/pkgconfig"
RDEPEND="
dev-libs/popt:=
dev-libs/libxml2:=
dev-libs/libxslt:="
DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig"
PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
diff --git a/media-sound/pulseaudio-ctl/pulseaudio-ctl-1.70-r1.ebuild b/media-sound/pulseaudio-ctl/pulseaudio-ctl-1.70-r1.ebuild
index f6150651fbb2..3b02371e59e5 100644
--- a/media-sound/pulseaudio-ctl/pulseaudio-ctl-1.70-r1.ebuild
+++ b/media-sound/pulseaudio-ctl/pulseaudio-ctl-1.70-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2019-2023 Gentoo Authors
+# Copyright 2019-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -10,7 +10,6 @@ SRC_URI="https://github.com/graysky2/pulseaudio-ctl/archive/v${PV}.tar.gz -> ${P
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
-IUSE=""
# Optional runtime deps: dbus-send for KDE OSD, notify-send for libnotify
# in both cases they should be already present if DE supports them
diff --git a/media-sound/qastools/qastools-0.23.0.ebuild b/media-sound/qastools/qastools-0.23.0.ebuild
index 739a04e7b390..789af4082220 100644
--- a/media-sound/qastools/qastools-0.23.0.ebuild
+++ b/media-sound/qastools/qastools-0.23.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -7,12 +7,12 @@ inherit cmake
DESCRIPTION="Qt5 GUI ALSA tools: mixer, configuration browser"
HOMEPAGE="https://gitlab.com/sebholt/qastools"
-SRC_URI="https://gitlab.com/sebholt/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.gz"
+SRC_URI="https://gitlab.com/sebholt/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.bz2"
+S="${WORKDIR}/${PN}-v${PV}"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE=""
BDEPEND="
dev-qt/linguist-tools:5
@@ -30,8 +30,6 @@ DEPEND="${RDEPEND}"
PATCHES=( "${FILESDIR}/${P}-nomancompress.patch" )
-S="${WORKDIR}"/${PN}-v${PV}
-
src_configure() {
local mycmakeargs=(
-DSKIP_LICENSE_INSTALL=ON
diff --git a/media-sound/qastools/qastools-1.4.0.ebuild b/media-sound/qastools/qastools-1.4.0.ebuild
index fd5462cfef8f..37704ef41fe2 100644
--- a/media-sound/qastools/qastools-1.4.0.ebuild
+++ b/media-sound/qastools/qastools-1.4.0.ebuild
@@ -7,13 +7,12 @@ inherit cmake
DESCRIPTION="Qt GUI ALSA tools: mixer, configuration browser"
HOMEPAGE="https://gitlab.com/sebholt/qastools"
-SRC_URI="https://gitlab.com/sebholt/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.gz"
-S="${WORKDIR}"/${PN}-v${PV}
+SRC_URI="https://gitlab.com/sebholt/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.bz2"
+S="${WORKDIR}/${PN}-v${PV}"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
RDEPEND="
dev-qt/qtbase:6[dbus,gui,network,widgets]
diff --git a/media-sound/qtagger/qtagger-1.0.1_p20150402.ebuild b/media-sound/qtagger/qtagger-1.0.1_p20150402.ebuild
index f85a7a431edc..d03fe2b1e684 100644
--- a/media-sound/qtagger/qtagger-1.0.1_p20150402.ebuild
+++ b/media-sound/qtagger/qtagger-1.0.1_p20150402.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -10,11 +10,11 @@ inherit cmake qmake-utils
DESCRIPTION="Simple Qt5 ID3v2 tag editor"
HOMEPAGE="https://github.com/DOOMer/qtagger"
SRC_URI="https://github.com/DOOMer/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
BDEPEND="dev-qt/linguist-tools:5"
DEPEND="
@@ -25,8 +25,6 @@ DEPEND="
"
RDEPEND="${DEPEND}"
-S="${WORKDIR}/${PN}-${COMMIT}"
-
src_prepare() {
# fix doc installation path
sed -i -e "s/doc\/${PN}/doc\/${PF}/" CMakeLists.txt || die
diff --git a/media-sound/qtscrobbler/qtscrobbler-0.11_pre20130123.ebuild b/media-sound/qtscrobbler/qtscrobbler-0.11_pre20130123.ebuild
index 861d0f3cab74..e599a6fea17d 100644
--- a/media-sound/qtscrobbler/qtscrobbler-0.11_pre20130123.ebuild
+++ b/media-sound/qtscrobbler/qtscrobbler-0.11_pre20130123.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -6,16 +6,16 @@ EAPI=7
COMMIT=33ed278b9b543554fd6a556fd391eb4c78faab07
MY_PN=qtscrob
MY_P=${MY_PN}-${PV}
-inherit desktop qmake-utils toolchain-funcs xdg-utils
+inherit desktop qmake-utils xdg-utils
DESCRIPTION="Updates last.fm profiles using information from supported portable music players"
HOMEPAGE="http://qtscrob.sourceforge.net/"
SRC_URI="https://sourceforge.net/code-snapshots/git/q/qt/${MY_PN}/code.git/${MY_PN}-code-${COMMIT}.zip -> ${P}.zip"
+S="${WORKDIR}/${MY_PN}-code-${COMMIT}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE=""
BDEPEND="
app-arch/unzip
@@ -32,8 +32,6 @@ RDEPEND="
net-misc/curl"
DEPEND="${RDEPEND}"
-S="${WORKDIR}/${MY_PN}-code-${COMMIT}"
-
PATCHES=(
"${FILESDIR}"/${P}-qt5.patch
"${FILESDIR}"/${P}-qt5.11.patch
diff --git a/media-sound/quimup/quimup-1.4.4.ebuild b/media-sound/quimup/quimup-1.4.4.ebuild
index c6078900aae7..c00fc7b82423 100644
--- a/media-sound/quimup/quimup-1.4.4.ebuild
+++ b/media-sound/quimup/quimup-1.4.4.ebuild
@@ -8,11 +8,11 @@ inherit desktop qmake-utils
DESCRIPTION="Qt5 client for the music player daemon (MPD)"
HOMEPAGE="https://sourceforge.net/projects/quimup/"
SRC_URI="https://downloads.sourceforge.net/${PN}/${PN^}_${PV}_source.tar.gz"
+S="${WORKDIR}/${PN^}_${PV}_source"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE=""
RDEPEND="
dev-qt/qtcore:5
@@ -25,8 +25,6 @@ RDEPEND="
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
-S="${WORKDIR}/${PN^}_${PV}_source"
-
DOCS=( changelog FAQ.txt README )
src_configure() {
diff --git a/media-sound/sidplay/sidplay-2.0.9-r2.ebuild b/media-sound/sidplay/sidplay-2.0.9-r2.ebuild
index 8ec69de1d0f1..277c92d9489f 100644
--- a/media-sound/sidplay/sidplay-2.0.9-r2.ebuild
+++ b/media-sound/sidplay/sidplay-2.0.9-r2.ebuild
@@ -10,7 +10,6 @@ SRC_URI="https://downloads.sourceforge.net/sidplay2/${P}.tar.gz"
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~alpha amd64 ~hppa ppc ~sparc x86"
-IUSE=""
BDEPEND="virtual/pkgconfig"
DEPEND="media-libs/libsidplay:2"
diff --git a/media-sound/smixer/smixer-1.0.4.ebuild b/media-sound/smixer/smixer-1.0.4.ebuild
index 4234c69cbbed..ce78f306617c 100644
--- a/media-sound/smixer/smixer-1.0.4.ebuild
+++ b/media-sound/smixer/smixer-1.0.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -8,13 +8,11 @@ inherit toolchain-funcs
DESCRIPTION="command-line tool for setting and viewing mixer settings"
HOMEPAGE="http://centerclick.org/programs/smixer"
SRC_URI="http://centerclick.org/programs/${PN}/${PN}${PV}.tgz"
+S="${WORKDIR}/${PN}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~hppa ppc x86"
-IUSE=""
-
-S="${WORKDIR}/${PN}"
src_compile() {
emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LFLAGS="${LDFLAGS}"
diff --git a/media-sound/taginfo/taginfo-1.2-r2.ebuild b/media-sound/taginfo/taginfo-1.2-r2.ebuild
index 8c20895d3dec..55efb585c09e 100644
--- a/media-sound/taginfo/taginfo-1.2-r2.ebuild
+++ b/media-sound/taginfo/taginfo-1.2-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -12,7 +12,6 @@ SRC_URI="http://grecni.com/software/taginfo/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE=""
RDEPEND="media-libs/taglib"
DEPEND="${RDEPEND}"
diff --git a/media-sound/vsound/vsound-0.6-r1.ebuild b/media-sound/vsound/vsound-0.6-r1.ebuild
index 90bd0fd78986..4ec13f349851 100644
--- a/media-sound/vsound/vsound-0.6-r1.ebuild
+++ b/media-sound/vsound/vsound-0.6-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -12,7 +12,6 @@ SRC_URI="http://www.vsound.org/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~ppc sparc x86"
-IUSE=""
RDEPEND="media-sound/sox:="
DEPEND="${RDEPEND}"
diff --git a/media-sound/wavplay/wavplay-2.0.ebuild b/media-sound/wavplay/wavplay-2.0.ebuild
index 9ff1dad6f397..b0fda596d1b1 100644
--- a/media-sound/wavplay/wavplay-2.0.ebuild
+++ b/media-sound/wavplay/wavplay-2.0.ebuild
@@ -12,9 +12,8 @@ SRC_URI="https://downloads.sourceforge.net/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 x86"
-IUSE=""
-PATCHES=( "${FILESDIR}"/${PN}-2.0-pkgdata-install-fix.patch )
+PATCHES=( "${FILESDIR}/${PN}-2.0-pkgdata-install-fix.patch" )
src_prepare() {
default