summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2021-10-01 19:36:22 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2021-10-01 19:36:22 +0000
commit957c7ff918d74995f7160771310f7dc8958c0d40 (patch)
tree3f3b2982525c50bcd520d61f7a1d247075c21f7a
parent2021-10-01 19:21:27 UTC (diff)
parentdev-ml/ounit2: build with ocaml-4.12 (diff)
downloadgentoo-957c7ff918d74995f7160771310f7dc8958c0d40.tar.gz
gentoo-957c7ff918d74995f7160771310f7dc8958c0d40.tar.bz2
gentoo-957c7ff918d74995f7160771310f7dc8958c0d40.zip
Merge updates from master
-rw-r--r--dev-ml/ounit2/ounit2-2.2.3.ebuild4
-rw-r--r--dev-ml/ounit2/ounit2-2.2.4.ebuild4
2 files changed, 8 insertions, 0 deletions
diff --git a/dev-ml/ounit2/ounit2-2.2.3.ebuild b/dev-ml/ounit2/ounit2-2.2.3.ebuild
index 40be073255c0..b53206f8e388 100644
--- a/dev-ml/ounit2/ounit2-2.2.3.ebuild
+++ b/dev-ml/ounit2/ounit2-2.2.3.ebuild
@@ -20,3 +20,7 @@ BDEPEND=""
IUSE="+ocamlopt"
S="${WORKDIR}/ounit-v${PV}"
+
+src_compile() {
+ dune build @install --profile release || die
+}
diff --git a/dev-ml/ounit2/ounit2-2.2.4.ebuild b/dev-ml/ounit2/ounit2-2.2.4.ebuild
index b67e4a2fd511..967a9daf84da 100644
--- a/dev-ml/ounit2/ounit2-2.2.4.ebuild
+++ b/dev-ml/ounit2/ounit2-2.2.4.ebuild
@@ -20,3 +20,7 @@ DEPEND="
dev-ml/stdlib-shims:=
"
RDEPEND="${DEPEND}"
+
+src_compile() {
+ dune build @install --profile release || die
+}