summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-18 07:19:48 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-18 07:31:07 +0200
commit9fbf28fb6736db1ad3454b1aae9802b338c25790 (patch)
treef5d45f2e3ac088100061974c90da79cee6f35aae
parentdev-python/notebook: Bump to 7.1.3 (diff)
downloadgentoo-9fbf28fb6736db1ad3454b1aae9802b338c25790.tar.gz
gentoo-9fbf28fb6736db1ad3454b1aae9802b338c25790.tar.bz2
gentoo-9fbf28fb6736db1ad3454b1aae9802b338c25790.zip
dev-python/sphinx-autodoc-typehints: Bump to 2.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/sphinx-autodoc-typehints/Manifest1
-rw-r--r--dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-2.1.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/sphinx-autodoc-typehints/Manifest b/dev-python/sphinx-autodoc-typehints/Manifest
index 8a66c0fe78fc..c09b8527aa59 100644
--- a/dev-python/sphinx-autodoc-typehints/Manifest
+++ b/dev-python/sphinx-autodoc-typehints/Manifest
@@ -1 +1,2 @@
DIST sphinx_autodoc_typehints-2.0.0.tar.gz 37951 BLAKE2B 55fc5bd4a430095b9b80b7313da96ac177f55d8e31068ded7c740cc2757580b611bfdb0aa53cc8344564cf01b052518854ea040a70ea568bd098505f8c2dfca8 SHA512 e37839b8f9393334f43b2b97f3d9ade4a2e11182e634c4ee37a916bcf4425c624376edcd3b25b054a23e15624393e3a79fdbc1775f6b3808e09bc8a85a2262d5
+DIST sphinx_autodoc_typehints-2.1.0.tar.gz 39386 BLAKE2B ccf6b618fc3db2a576a2d9a36a575087cdc3c7c5cf59a6057a956478a12715b1623dc4bc1ae3f7c30deab317a15fa187faf19f9d050fa61c293dc20bee41effd SHA512 59c5b4c682fadc1d0ec62a5aa639bb87d6e4710db89793824c348c7598d73b144f0b083ce6462ea32d958b1ed7fd2fb96c2a92780267adef03b625e64c08c412
diff --git a/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-2.1.0.ebuild b/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-2.1.0.ebuild
new file mode 100644
index 000000000000..dc13f14770e4
--- /dev/null
+++ b/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-2.1.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Type hints support for the Sphinx autodoc extension"
+HOMEPAGE="
+ https://github.com/tox-dev/sphinx-autodoc-typehints/
+ https://pypi.org/project/sphinx-autodoc-typehints/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/sphinx-7.1.2[${PYTHON_USEDEP}]
+"
+# skipping optional test dep on dev-python/nptyping as that package
+# is horribly broken and on its way out
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/sphobjinv-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4.5[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # this package is addicted to Internet
+ tests/test_sphinx_autodoc_typehints.py::test_format_annotation
+ # TODO
+ 'tests/test_sphinx_autodoc_typehints.py::test_always_document_param_types[doc_param_type]'
+)