summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-25 12:54:26 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-25 14:08:45 +0200
commita1607cdac4a9ec3b89d4de00d0057f09f86bce39 (patch)
tree7a5ec92c0ae5aab8281c4961ec8545265abaf4f6
parentdev-python/jedi: Remove old (diff)
downloadgentoo-a1607cdac4a9ec3b89d4de00d0057f09f86bce39.tar.gz
gentoo-a1607cdac4a9ec3b89d4de00d0057f09f86bce39.tar.bz2
gentoo-a1607cdac4a9ec3b89d4de00d0057f09f86bce39.zip
dev-python/parso: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/parso/Manifest1
-rw-r--r--dev-python/parso/files/parso-0.7.1-flaky-test.patch37
-rw-r--r--dev-python/parso/files/parso-0.8.2-flaky-test.patch23
-rw-r--r--dev-python/parso/parso-0.7.1-r1.ebuild34
4 files changed, 0 insertions, 95 deletions
diff --git a/dev-python/parso/Manifest b/dev-python/parso/Manifest
index 91bdb40e9e69..bdcfd4c9eab0 100644
--- a/dev-python/parso/Manifest
+++ b/dev-python/parso/Manifest
@@ -1,2 +1 @@
-DIST parso-0.7.1.tar.gz 399842 BLAKE2B 1e47c1dd6846d01aa5820d7cedc3eafcf12ea0d4a2e95fa3f54429633b1c12dc39a4abe237fa46eb629408006777bd1f512cf878025b55119568ac19729b8c19 SHA512 318969a7a941c4a0948e58643b07b6f5c446ea166b3a8e44a556f0677ec9a36d7dc8c6d37ca7bce3f8276ee3d7144e22fbaaeac90c738fb90f7e94a0cf8abf7d
DIST parso-0.8.3.tar.gz 397648 BLAKE2B 8942408e27198075c92ef51f7a191cc7781eb3a5110119b91fd95f86e13ebe2fbfee11022a2bfec794150f60b3af8c4d5f324cb011703cd581c17f92232ae5bf SHA512 7874460053662d40c2cfcf0015e330e1c8201eeb07682e2079a636db553a82dc25b70b14ad0f0c82fb817f655359d695101a17f616abf9a39f49c61ae5fd49b1
diff --git a/dev-python/parso/files/parso-0.7.1-flaky-test.patch b/dev-python/parso/files/parso-0.7.1-flaky-test.patch
deleted file mode 100644
index 609918f31bb5..000000000000
--- a/dev-python/parso/files/parso-0.7.1-flaky-test.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-From 2799a7a3c2cf87fdc2d0c19a0890acea425091ce Mon Sep 17 00:00:00 2001
-From: Ivan Babrou <github@ivan.computer>
-Date: Tue, 23 Feb 2021 22:27:05 -0800
-Subject: [PATCH] Fix flaky test_cache_last_used_update
-
-Sometimes time moves slowly and strict comparison is not enough:
-
-```
-> assert now < node_cache_item.last_used < time.time()
-E assert 1614147958.869299 < 1614147958.869299
-E + where 1614147958.869299 = <parso.cache._NodeCacheItem object at 0x10456fe80>.last_used
-E + and 1614147958.869299 = <built-in function time>()
-E + where <built-in function time> = time.time
-
-test/test_cache.py:149: AssertionError
-```
-
-In particular, macOS timings can be a bit coarse.
-
-The test failure is from Apple Silicon M1.
----
- test/test_cache.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/test/test_cache.py b/test/test_cache.py
-index bfdbaf5..f4291c2 100644
---- a/test/test_cache.py
-+++ b/test/test_cache.py
-@@ -146,7 +146,7 @@ def test_cache_last_used_update(diff_cache, use_file_io):
- parse('somecode2', cache=True, path=p, diff_cache=diff_cache)
-
- node_cache_item = next(iter(parser_cache.values()))[p]
-- assert now < node_cache_item.last_used < time.time()
-+ assert now <= node_cache_item.last_used <= time.time()
-
-
- @skip_pypy
diff --git a/dev-python/parso/files/parso-0.8.2-flaky-test.patch b/dev-python/parso/files/parso-0.8.2-flaky-test.patch
deleted file mode 100644
index 729ec409c829..000000000000
--- a/dev-python/parso/files/parso-0.8.2-flaky-test.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From 60fed7b9f80cbb3d9cb7a9e42ad8c0f3c513801d Mon Sep 17 00:00:00 2001
-From: Saiyang Gou <gousaiyang@163.com>
-Date: Sat, 29 May 2021 18:17:24 -0700
-Subject: [PATCH] Fix flaky test_cache_last_used_update again (#189)
-
-This is a follow up for #177. On Windows, `assert node_cache_item.last_used < now` may fail as the two time values can be equal.
----
- test/test_cache.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/test/test_cache.py b/test/test_cache.py
-index f4291c2..5e633fc 100644
---- a/test/test_cache.py
-+++ b/test/test_cache.py
-@@ -137,7 +137,7 @@ def test_cache_last_used_update(diff_cache, use_file_io):
- parse('somecode', cache=True, path=p)
- node_cache_item = next(iter(parser_cache.values()))[p]
- now = time.time()
-- assert node_cache_item.last_used < now
-+ assert node_cache_item.last_used <= now
-
- if use_file_io:
- f = _FixedTimeFileIO(p, 'code', node_cache_item.last_used - 10)
diff --git a/dev-python/parso/parso-0.7.1-r1.ebuild b/dev-python/parso/parso-0.7.1-r1.ebuild
deleted file mode 100644
index 61ffc2a3595c..000000000000
--- a/dev-python/parso/parso-0.7.1-r1.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="a python parser that supports error recovery and round-trip parsing"
-HOMEPAGE="https://github.com/davidhalter/parso https://pypi.org/project/parso/"
-SRC_URI="https://github.com/davidhalter/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86"
-
-distutils_enable_sphinx docs
-distutils_enable_tests pytest
-
-PATCHES=(
- "${FILESDIR}"/${P}-flaky-test.patch
- "${FILESDIR}"/${PN}-0.8.2-flaky-test.patch
-)
-
-python_test() {
- local deselect=()
- [[ ${EPYTHON} == python3.10 ]] && deselect+=(
- # py3.10 changed exception messages
- test/test_python_errors.py::test_python_exception_matches
- test/test_python_errors.py::test_default_except_error_postition
- )
- epytest ${deselect[@]/#/--deselect }
-}