summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2020-04-30 05:25:48 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2020-04-30 05:25:48 +0000
commitb1ea659ab1710f7172e9f05f2ac46efe74ef0cff (patch)
tree91e9e4f513222250b795405ca5fc38d3e8a7b9be
parent2020-04-30 02:08:47 UTC (diff)
parentwww-apps/wordpress: bump to 5.4.1 (diff)
downloadgentoo-b1ea659ab1710f7172e9f05f2ac46efe74ef0cff.tar.gz
gentoo-b1ea659ab1710f7172e9f05f2ac46efe74ef0cff.tar.bz2
gentoo-b1ea659ab1710f7172e9f05f2ac46efe74ef0cff.zip
Merge updates from master
-rw-r--r--net-vpn/wireguard-modules/Manifest2
-rw-r--r--net-vpn/wireguard-modules/wireguard-modules-1.0.20200429.ebuild (renamed from net-vpn/wireguard-modules/wireguard-modules-1.0.20200426.ebuild)0
-rw-r--r--sci-libs/scalapack/Manifest1
-rw-r--r--sci-libs/scalapack/scalapack-2.1.0.ebuild71
-rw-r--r--www-apps/wordpress/Manifest1
-rw-r--r--www-apps/wordpress/wordpress-5.4.1.ebuild57
6 files changed, 131 insertions, 1 deletions
diff --git a/net-vpn/wireguard-modules/Manifest b/net-vpn/wireguard-modules/Manifest
index 0408bc30c610..9e53f4badf21 100644
--- a/net-vpn/wireguard-modules/Manifest
+++ b/net-vpn/wireguard-modules/Manifest
@@ -1 +1 @@
-DIST wireguard-linux-compat-1.0.20200426.tar.xz 261452 BLAKE2B 6cbf411c25b916914518478ac9d6f3014a73fb728836aa37f24119cbf832de18d203b51fdf1d57b0ea9a244bfc2030df59717222eae7eae6e5bbd804786da7cf SHA512 7bbf020069df0d0e7f516da0d9ea78747c597f63a3389059e32d341daf1865bc8139cb16a333ae337a0b3724995a7ac3f21b85d6df5aa4617021498f56ae4825
+DIST wireguard-linux-compat-1.0.20200429.tar.xz 261668 BLAKE2B e40f8a43c8b2a9654adbf2c2c12056573b60fd72419200e9e18d895348bd61df30aada47d78320d75135e2180adacb391557775467040920587b432dccbc4b6d SHA512 b1523a7fd9199847f18bcb4b91aa9a15b58e088955cbbd128de64845cb1ff8e7d692e580b80abb38e79f93ffa8be7841a2b6ffc4bedbb88ef6647dd07f48dc5a
diff --git a/net-vpn/wireguard-modules/wireguard-modules-1.0.20200426.ebuild b/net-vpn/wireguard-modules/wireguard-modules-1.0.20200429.ebuild
index 16df945c1ab1..16df945c1ab1 100644
--- a/net-vpn/wireguard-modules/wireguard-modules-1.0.20200426.ebuild
+++ b/net-vpn/wireguard-modules/wireguard-modules-1.0.20200429.ebuild
diff --git a/sci-libs/scalapack/Manifest b/sci-libs/scalapack/Manifest
index 5a13f95440b2..d30e37fd8aab 100644
--- a/sci-libs/scalapack/Manifest
+++ b/sci-libs/scalapack/Manifest
@@ -1 +1,2 @@
DIST scalapack-2.0.2.tgz 4779534 BLAKE2B c2aabd87bc8f7c0d9af31bd8ad8c933703dcbba399658d15c1e5256da2350c1a0feac2ca4a205f697b1c48083df89cbcd64ba432da036081c0f33d5d2acddc9b SHA512 92c71d3de0900955511c527ab3ca57ff69d6d9edc390e69f93ac3769d32ce83a714326bcb6218c8c74b8874be2fdc8aad5e42c912a12581e8d4ce8829ea39248
+DIST scalapack-2.1.0.tgz 5307441 BLAKE2B 4aea055fc3e437bce7108d1555e93c50109bcfe84354903fd711509eedbe686349fda4030e2fa70faf1a9e7e3255e46e48c32b96a2916af6812b8aebceb750c2 SHA512 0e77fb535ebcc28e2d97499ef4bd5161f76ca0ba4a3e308c26ce5071cfc4be4f3814262f3fb38f378ce0b5b31c0913432fea00a1e9e3f7717b853d1182bdf5b4
diff --git a/sci-libs/scalapack/scalapack-2.1.0.ebuild b/sci-libs/scalapack/scalapack-2.1.0.ebuild
new file mode 100644
index 000000000000..a1979a20ad64
--- /dev/null
+++ b/sci-libs/scalapack/scalapack-2.1.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils fortran-2 toolchain-funcs
+
+DESCRIPTION="Subset of LAPACK routines redesigned for heterogenous (MPI) computing"
+HOMEPAGE="https://www.netlib.org/scalapack/"
+SRC_URI="https://www.netlib.org/scalapack/${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ virtual/lapack
+ virtual/mpi"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=(
+)
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ if use static-libs; then
+ mkdir "${WORKDIR}/${PN}_static" || die
+ fi
+ # mpi does not have a pc file
+ sed -i -e 's/mpi//' scalapack.pc.in || die
+}
+
+src_configure() {
+ scalapack_configure() {
+ local mycmakeargs=(
+ -DUSE_OPTIMIZED_LAPACK_BLAS=ON
+ -DBLAS_LIBRARIES="$($(tc-getPKG_CONFIG) --libs blas)"
+ -DLAPACK_LIBRARIES="$($(tc-getPKG_CONFIG) --libs lapack)"
+ -DBUILD_TESTING=$(usex test)
+ $@
+ )
+ cmake-utils_src_configure
+ }
+
+ scalapack_configure -DBUILD_SHARED_LIBS=ON -DBUILD_STATIC_LIBS=OFF
+ use static-libs && \
+ CMAKE_BUILD_DIR="${WORKDIR}/${PN}_static" scalapack_configure \
+ -DBUILD_SHARED_LIBS=OFF -DBUILD_STATIC_LIBS=ON
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ use static-libs && \
+ CMAKE_BUILD_DIR="${WORKDIR}/${PN}_static" cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+ use static-libs && \
+ CMAKE_BUILD_DIR="${WORKDIR}/${PN}_static" cmake-utils_src_install
+
+ insinto /usr/include/blacs
+ doins BLACS/SRC/*.h
+
+ insinto /usr/include/scalapack
+ doins PBLAS/SRC/*.h
+}
diff --git a/www-apps/wordpress/Manifest b/www-apps/wordpress/Manifest
index 1b077c6f81dc..f279a7f954cc 100644
--- a/www-apps/wordpress/Manifest
+++ b/www-apps/wordpress/Manifest
@@ -1 +1,2 @@
+DIST wordpress-5.4.1.tar.gz 12234700 BLAKE2B 0df1f1b1da22c5ad429ef59861dbcb80b5bd6c8720bc96b450d2b6599b903dda813e16f28fc2ee2afe1654b4047556a06bb409f6d0a3be3671b37e54fac52cf3 SHA512 5ed4f3bd593febdf2aec4c582c2ed850d3bf52122273b4306c1fba87939a675228df84092a709052f13e0096b2545cd6f078ab89b232ee4b4dce467d834de0cd
DIST wordpress-5.4.tar.gz 12230487 BLAKE2B bced3e3eec1179b4c52190b24626632b3d0899f3dc33112374f316421ec6287b58d6c8684c85e743f5c92c2278e3e1408091dede6bacbc9b9be093350ed061c8 SHA512 0d2ae85bd0d0d1aeda6bc371d6357660233b604e46d764f2955abc88ccecd8bfb76f9b8d7fac788a3f8d9abb2a10b8ae60cee74ddcbe483136f0fd7ba0b842d8
diff --git a/www-apps/wordpress/wordpress-5.4.1.ebuild b/www-apps/wordpress/wordpress-5.4.1.ebuild
new file mode 100644
index 000000000000..6fc0786bf3b1
--- /dev/null
+++ b/www-apps/wordpress/wordpress-5.4.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit webapp
+
+DESCRIPTION="Wordpress PHP and MySQL based content management system (CMS)"
+HOMEPAGE="https://wordpress.org/"
+SRC_URI="https://wordpress.org/${P/_rc/-RC}.tar.gz"
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="virtual/httpd-php
+ || ( dev-lang/php[mysql] dev-lang/php[mysqli] )"
+
+S=${WORKDIR}/${PN}
+
+need_httpd_cgi
+
+IUSE="+akismet examples +themes vhosts"
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc readme.html
+ rm readme.html license.txt || die
+
+ if use !akismet ; then
+ rm -R wp-content/plugins/akismet/ || die
+ fi
+ if use !examples ; then
+ rm wp-content/plugins/hello.php || die
+ fi
+ if use !themes ; then
+ rm -R wp-content/themes/*/ || die
+ fi
+
+ [[ -f wp-config.php ]] || cp wp-config-sample.php wp-config.php
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/index.php
+ webapp_serverowned "${MY_HTDOCSDIR}"/wp-admin/menu.php
+ webapp_serverowned "${MY_HTDOCSDIR}"
+ # allows plugins update if allowed within WP
+ webapp_serverowned "${MY_HTDOCSDIR}"/wp-admin/includes/file.php
+
+ webapp_configfile "${MY_HTDOCSDIR}"/wp-config.php
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_postupgrade_txt en "${FILESDIR}"/postupgrade-en.txt
+
+ webapp_src_install
+}