summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-06-16 12:15:16 +0200
committerLars Wendler <polynomial-c@gentoo.org>2020-06-16 12:15:32 +0200
commitb2140e1b35fe5a8a1703c199ef5080c786fe4b49 (patch)
treeddddbf6f1889b21504b7dd1068b3f1bc8f14e608
parentnet-misc/youtube-dl: Old (diff)
downloadgentoo-b2140e1b35fe5a8a1703c199ef5080c786fe4b49.tar.gz
gentoo-b2140e1b35fe5a8a1703c199ef5080c786fe4b49.tar.bz2
gentoo-b2140e1b35fe5a8a1703c199ef5080c786fe4b49.zip
net-misc/rsync: Bump to version 3.2.0_pre2
Added support for system-zlib Bug: https://bugs.gentoo.org/666934 Package-Manager: Portage-2.3.101, Repoman-2.3.22 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--net-misc/rsync/Manifest1
-rw-r--r--net-misc/rsync/metadata.xml2
-rw-r--r--net-misc/rsync/rsync-3.2.0_pre2.ebuild114
3 files changed, 117 insertions, 0 deletions
diff --git a/net-misc/rsync/Manifest b/net-misc/rsync/Manifest
index 829c80d46fc4..8bcd788e14ce 100644
--- a/net-misc/rsync/Manifest
+++ b/net-misc/rsync/Manifest
@@ -1 +1,2 @@
DIST rsync-3.1.3.tar.gz 905908 BLAKE2B 616a1f3239327a28b881310f5f249c90b8bcdb05091279cd62f9cb4e35a8428c7cdd9b89e711ba124601a738f0deb9bfbebafba7fd88b72866476138a9f8c75a SHA512 8385f4c0ea37e7a1da3cf45794154f5bc4d1c49bc625ba3b5f85adaf3eafe6d71c15bdcb1410bde731e5d4c19aff3331606637462fa27a68dc3e13192dd78f99
+DIST rsync-3.2.0pre2.tar.gz 1044334 BLAKE2B 5069a09d6a24c4c4adfc2202a0845f156270c23e2c236a8a9d490d0156ece4e81ccca6aa9eefd552cd1512e60fff38fd79d3b4ba4e06b11a22ca591daaaae7b0 SHA512 e88093a44d5ac8ff235429aea6a7f93cd8b5a1de42eeee1b7d6d0ce2c23234ac670a775028e2eca22cbf1144b9bac827c0393c22eaf11fa5ec47dc64129462e7
diff --git a/net-misc/rsync/metadata.xml b/net-misc/rsync/metadata.xml
index 148a18e18adc..cae1f589effe 100644
--- a/net-misc/rsync/metadata.xml
+++ b/net-misc/rsync/metadata.xml
@@ -10,5 +10,7 @@
</upstream>
<use>
<flag name="stunnel">Provide helper scripts for using rsync via &gt;=net-misc/stunnel-4</flag>
+ <flag name="system-zlib">Use system zlib instead of bundled one. This is incompatible with oder rsync releases!</flag>
+ <flag name="xxhash">Enable <pkg>dev-libs/xxhash</pkg> support for hashing</flag>
</use>
</pkgmetadata>
diff --git a/net-misc/rsync/rsync-3.2.0_pre2.ebuild b/net-misc/rsync/rsync-3.2.0_pre2.ebuild
new file mode 100644
index 000000000000..905428051c73
--- /dev/null
+++ b/net-misc/rsync/rsync-3.2.0_pre2.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic prefix systemd
+
+DESCRIPTION="File transfer program to keep remote files into sync"
+HOMEPAGE="https://rsync.samba.org/"
+SRC_URI="https://rsync.samba.org/ftp/rsync/src/${P}.tar.gz"
+[[ "${PV}" = *_pre* ]] && SRC_URI="https://rsync.samba.org/ftp/rsync/src-previews/${P/_/}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+[[ ${PV} = *_pre* ]] || \
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="acl examples iconv ipv6 libressl lz4 ssl static stunnel system-zlib xattr xxhash zstd"
+
+LIB_DEPEND="acl? ( virtual/acl[static-libs(+)] )
+ lz4? ( app-arch/lz4[static-libs(+)] )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0=[static-libs(+)] )
+ libressl? ( dev-libs/libressl:0=[static-libs(+)] )
+ )
+ system-zlib? ( sys-libs/zlib[static-libs(+)] )
+ xattr? ( kernel_linux? ( sys-apps/attr[static-libs(+)] ) )
+ xxhash? ( dev-libs/xxhash[static-libs(+)] )
+ zstd? ( app-arch/zstd[static-libs(+)] )
+ >=dev-libs/popt-1.5[static-libs(+)]"
+RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )
+ iconv? ( virtual/libiconv )"
+DEPEND="${RDEPEND}
+ static? ( ${LIB_DEPEND} )"
+
+S="${WORKDIR}/${P/_/}"
+
+src_configure() {
+ use static && append-ldflags -static
+ local myeconfargs=(
+ --with-rsyncd-conf="${EPREFIX}"/etc/rsyncd.conf
+ --without-included-popt
+ $(use_enable acl acl-support)
+ $(use_enable iconv)
+ $(use_enable ipv6)
+ $(use_enable lz4)
+ $(use_enable ssl openssl)
+ $(use_with !system-zlib included-zlib)
+ $(use_enable xattr xattr-support)
+ $(use_enable xxhash)
+ $(use_enable zstd)
+ )
+ econf "${myeconfargs[@]}"
+ touch proto.h-tstamp #421625
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ newconfd "${FILESDIR}"/rsyncd.conf.d rsyncd
+ newinitd "${FILESDIR}"/rsyncd.init.d-r1 rsyncd
+
+ dodoc NEWS.md OLDNEWS.md README.md TODO tech_report.tex
+
+ insinto /etc
+ newins "${FILESDIR}"/rsyncd.conf-3.0.9-r1 rsyncd.conf
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/rsyncd.logrotate rsyncd
+
+ insinto /etc/xinetd.d
+ newins "${FILESDIR}"/rsyncd.xinetd-3.0.9-r1 rsyncd
+
+ # Install stunnel helpers
+ if use stunnel ; then
+ emake DESTDIR="${D}" install-ssl-client
+ emake DESTDIR="${D}" install-ssl-daemon
+ fi
+
+ # Install the useful contrib scripts
+ if use examples ; then
+ exeinto /usr/share/rsync
+ doexe support/*
+ rm -f "${ED%/}"/usr/share/rsync/{Makefile*,*.c}
+ fi
+
+ eprefixify "${ED}"/etc/{,xinetd.d}/rsyncd*
+
+ systemd_dounit "${FILESDIR}/rsyncd.service"
+}
+
+pkg_postinst() {
+ if egrep -qis '^[[:space:]]use chroot[[:space:]]*=[[:space:]]*(no|0|false)' \
+ "${EROOT}"/etc/rsyncd.conf "${EROOT}"/etc/rsync/rsyncd.conf ; then
+ ewarn "You have disabled chroot support in your rsyncd.conf. This"
+ ewarn "is a security risk which you should fix. Please check your"
+ ewarn "/etc/rsyncd.conf file and fix the setting 'use chroot'."
+ fi
+ if use stunnel ; then
+ einfo "Please install \">=net-misc/stunnel-4\" in order to use stunnel feature."
+ einfo
+ einfo "You maybe have to update the certificates configured in"
+ einfo "${EROOT}/etc/stunnel/rsync.conf"
+ fi
+ if use system-zlib ; then
+ ewarn "Using system-zlib is incompatible with <rsync-3.1.1 when"
+ ewarn "using the --compress option."
+ ewarn
+ ewarn "When syncing with >=rsync-3.1.1 built with bundled zlib,"
+ ewarn "and the --compress option, add --new-compress (-zz)."
+ ewarn
+ ewarn "For syncing the portage tree, add:"
+ ewarn "PORTAGE_RSYNC_EXTRA_OPTS=\"--new-compress\" to make.conf"
+ fi
+}