summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-18 07:28:44 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-18 07:58:23 +0100
commitb5e2637c43aab6e5b12a5b305069513493057eb0 (patch)
treee76b3a4b5cd2defde9edc3c5cafaee9f97c73848
parentdev-python/boto3: Bump to 1.26.51 (diff)
downloadgentoo-b5e2637c43aab6e5b12a5b305069513493057eb0.tar.gz
gentoo-b5e2637c43aab6e5b12a5b305069513493057eb0.tar.bz2
gentoo-b5e2637c43aab6e5b12a5b305069513493057eb0.zip
app-admin/awscli: Bump to 1.27.51
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.27.51.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index f23913b85437..118e4429e132 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -6,3 +6,4 @@ DIST aws-cli-1.27.47.gh.tar.gz 2346342 BLAKE2B d065367cca04ae199a177c5dd21ff49d6
DIST aws-cli-1.27.48.gh.tar.gz 2346735 BLAKE2B 798de19b4c64f149b29d3f643c0e69b2cc9ee394eab82a2926251d64f43f5dbc47f5db5466accb2a51945c97d4c10edc64311304d01687f9c73eba1e446a98ee SHA512 fdd8980792505dac94562f1e152e9ba5c1645655a4ce6cd38ea9ca8066dc00ea066ca08b580b889953c82bb4522585d65808509055a98d319ffc65ceb6eb5e94
DIST aws-cli-1.27.49.gh.tar.gz 2347127 BLAKE2B fb559784817e9d95578139f53d6ff6e8ee72c1f790b08472beb5de704233dbdf0f1c7c8738ddf45633f5ee034d4a0635eef859a57081d48dc6061ff762d8dce0 SHA512 39b27b8410702c28846cd0936736c24eb99757035888f0463ee048d18500a3259a1daa7a267b80891991e3246735f47cdc2db1c3098aa5e43ce2356a97f36e6d
DIST aws-cli-1.27.50.gh.tar.gz 2347235 BLAKE2B cacfe2c8d4fce7de6452a02fa8bcbcde58dbf010328a161e5eecc7305b225264ae68d3e20c6107cfa3b817e2030ffb20dc09a938f8bff59036fab5969e3e6da0 SHA512 af95ad60f2537c12c1353ab0cee045b55834b92b51d0b2fb1bf48991d34f4aa3b61ab20ca438ecba5d8019009065f7993bab64b7e7e0edf89765351c3f4fa168
+DIST aws-cli-1.27.51.gh.tar.gz 2347795 BLAKE2B 5f49ebfe653a7973c5d8645bb0056fa79719c6b6550c208b683a932ede32d5a6f1b17d1549326ac099a770f9a08efb47d17774d6d5ff612e28e01d5e35c79734 SHA512 1cc024d034c36206d61f1553053054c0036097ce88e483402f43d468acc14c704c14bb6d639c7743fe7924deabe969c3cc593c10c1f12b68d11d81b6af725841
diff --git a/app-admin/awscli/awscli-1.27.51.ebuild b/app-admin/awscli/awscli-1.27.51.ebuild
new file mode 100644
index 000000000000..62c19f3a63fb
--- /dev/null
+++ b/app-admin/awscli/awscli-1.27.51.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/functional/eks/test_kubeconfig.py::TestKubeconfigLoader::test_load_simple
+ tests/unit/customizations/eks/test_update_kubeconfig.py::TestKubeconfigSelector::test_choose_env_only
+ tests/unit/customizations/eks/test_update_kubeconfig.py::TestKubeconfigSelector::test_choose_existing
+ tests/unit/customizations/eks/test_kubeconfig.py::TestKubeconfigValidator::test_valid
+ )
+
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)" --forked
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}