summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-06-04 21:52:29 +0200
committerDavid Seifert <soap@gentoo.org>2020-06-04 21:52:29 +0200
commitbdd379b356b2ac8cc735677271a323ff5b7bb23a (patch)
tree19ec597262dca8f8383f1a4b41e62d168fbee76b
parentwww-apps/otrs: Last rites (diff)
downloadgentoo-bdd379b356b2ac8cc735677271a323ff5b7bb23a.tar.gz
gentoo-bdd379b356b2ac8cc735677271a323ff5b7bb23a.tar.bz2
gentoo-bdd379b356b2ac8cc735677271a323ff5b7bb23a.zip
dev-libs/libdivecomputer: [QA] Disable static libs
Closes: https://bugs.gentoo.org/726966 Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--dev-libs/libdivecomputer/libdivecomputer-0.6.0-r1.ebuild (renamed from dev-libs/libdivecomputer/libdivecomputer-0.6.0.ebuild)13
-rw-r--r--dev-libs/libdivecomputer/libdivecomputer-9999.ebuild13
2 files changed, 22 insertions, 4 deletions
diff --git a/dev-libs/libdivecomputer/libdivecomputer-0.6.0.ebuild b/dev-libs/libdivecomputer/libdivecomputer-0.6.0-r1.ebuild
index 0facf2467857..74158781a3b0 100644
--- a/dev-libs/libdivecomputer/libdivecomputer-0.6.0.ebuild
+++ b/dev-libs/libdivecomputer/libdivecomputer-0.6.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -29,5 +29,14 @@ src_prepare() {
}
src_configure() {
- econf $(use_with bluetooth bluez)
+ econf \
+ --disable-static \
+ $(use_with bluetooth bluez)
+}
+
+src_install() {
+ default
+
+ # no static archives
+ find "${D}" -name '*.la' -delete || die
}
diff --git a/dev-libs/libdivecomputer/libdivecomputer-9999.ebuild b/dev-libs/libdivecomputer/libdivecomputer-9999.ebuild
index 0facf2467857..74158781a3b0 100644
--- a/dev-libs/libdivecomputer/libdivecomputer-9999.ebuild
+++ b/dev-libs/libdivecomputer/libdivecomputer-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -29,5 +29,14 @@ src_prepare() {
}
src_configure() {
- econf $(use_with bluetooth bluez)
+ econf \
+ --disable-static \
+ $(use_with bluetooth bluez)
+}
+
+src_install() {
+ default
+
+ # no static archives
+ find "${D}" -name '*.la' -delete || die
}