summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-18 22:38:07 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-18 23:28:29 +0100
commitbfec315ab8d48abd1ace0cca22017b80043dbe45 (patch)
treedf70d73bee8d68da6ed409871d7ea6308ba849d1
parentvirtual/dist-kernel: Bump to 5.15.3 (diff)
downloadgentoo-bfec315ab8d48abd1ace0cca22017b80043dbe45.tar.gz
gentoo-bfec315ab8d48abd1ace0cca22017b80043dbe45.tar.bz2
gentoo-bfec315ab8d48abd1ace0cca22017b80043dbe45.zip
dev-python/botocore: Bump to 1.23.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.23.9.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 46b202160613..1c6da427abf2 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -5,3 +5,4 @@ DIST botocore-1.23.5.tar.gz 8374467 BLAKE2B 467092e7d8aa5ccb756132669049865445a4
DIST botocore-1.23.6.tar.gz 8387968 BLAKE2B 415a177d591a0ef369f17b8f02563be0fb53bc4e65c2767f41ca11300939585a10146874b6ac5297cdd3dcb36cf6fd2065fd09f3c612c4ba1d954b03a5b15579 SHA512 a46e45b7bb67d7c4bcc5508f38448b9ed3778ed6b6080239459b22b7f753adaf12e8d64496f7d7c71b33bb17ae1744000e9269ea0f545286e56fabe39e7f0340
DIST botocore-1.23.7.tar.gz 8391467 BLAKE2B dd6cad44c1b8109b76c44bfffa45e74da0fbeaa027429860640e33134dc5f6e5bb813b46d8b662d80b89af46d437c6fb962f0e0ab1edbeca3ee790f3b6d029bf SHA512 a3270da3b6d906bc2372af221400e14039868598ccd56f40f976bcc2638f300ae9990ff367f76e5b5cdf8d46a8a37716865f9a40ca7e79b73a5b8dbcb2b1af7f
DIST botocore-1.23.8.tar.gz 8407591 BLAKE2B 3b25e56d2408190c3ca6005e902b75dc4e5e7f0909d0f5d79c633e897c0b8b161dde542ccdb02ed6a7e3220d14c1225051e79cc47c945948b750cb58dee65f69 SHA512 11fd831da6e08574d78e3e45b79957dc6c6055ac55955eca7112568a211974a8f985e583b5bbd5f9799117ccb17f71c528930b8b4cc6a113fdbdbf6f72bb1fde
+DIST botocore-1.23.9.tar.gz 8425944 BLAKE2B 0c4cac5574e2bfdee6507221f2901313c50cd05ce97a4ccef75fc6498c963bc2cd144fc7d38a9c71291ccd6f733bb8620b6d4fe145b1fc1ff82c4fbbb5500463 SHA512 983babc0053730e6f300093ed5549a3660c9c0610454e101c0f30f7cf40f73ea93964b2e4dd4f981639bb5bc7081b30c9c2146b4194c5b5074d38e7e4bc79a10
diff --git a/dev-python/botocore/botocore-1.23.9.ebuild b/dev-python/botocore/botocore-1.23.9.ebuild
new file mode 100644
index 000000000000..7337877443c9
--- /dev/null
+++ b/dev-python/botocore/botocore-1.23.9.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ epytest tests/{functional,unit}
+}