summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2024-04-16 09:00:32 +0000
committerPatrick Lauer <patrick@gentoo.org>2024-04-16 09:16:30 +0000
commitc0503ecffadec2c6a06fb51933f4d7d93719ee03 (patch)
tree45426dda1ce0a5df9fd3b029c132d6f169994157
parentmedia-libs/opus: bump to 1.5.2 (diff)
downloadgentoo-c0503ecffadec2c6a06fb51933f4d7d93719ee03.tar.gz
gentoo-c0503ecffadec2c6a06fb51933f4d7d93719ee03.tar.bz2
gentoo-c0503ecffadec2c6a06fb51933f4d7d93719ee03.zip
dev-db/barman: Add py3.12 compat
Closes: https://bugs.gentoo.org/929384 Signed-off-by: Patrick Lauer <patrick@gentoo.org>
-rw-r--r--dev-db/barman/Manifest1
-rw-r--r--dev-db/barman/barman-3.10.0.ebuild48
-rw-r--r--dev-db/barman/barman-3.9.0.ebuild4
3 files changed, 51 insertions, 2 deletions
diff --git a/dev-db/barman/Manifest b/dev-db/barman/Manifest
index c098f680d79f..45b8f62659ce 100644
--- a/dev-db/barman/Manifest
+++ b/dev-db/barman/Manifest
@@ -1,3 +1,4 @@
DIST barman-2.19.tar.gz 1423229 BLAKE2B db316bad10774ff5825af7409ecc69cd502fe447dd91efc52c04ae23d8e5c21e682fcde351b23dea437817d6207765a6cba355399aea0c5799b0f34be55ee524 SHA512 042912aac1e02994fbbe270f9bf6f4340b9b7ba5b1fdb5d588bdf95098a970ed398e002d1d56731f9b96c8bd0c7e0b71463ab6c08517ce3c1f2c77d1a92618ff
+DIST barman-3.10.0.tar.gz 1851778 BLAKE2B 8e481676ae8a41e5a38a206966e26523237ee13f7201d219c405f355795e9755778d5495be3274bb67a931820b069d96be21adbcefc471380f98cd5f41fc1a08 SHA512 d01f4e940a46964aa8359614195c2bdc423c5a57e18331ccd798e0d52a2bd8f6adf299d42c5e1ac47ece5100cb1a828093badd8e1b181b20e4480cf368c8d1d0
DIST barman-3.2.0.tar.gz 1463937 BLAKE2B 9daff4dc1374aef5dfd8eff48438464265189223c7b5e7b39045cdf39362c0d266e437f8ff98aac3c045ab94f09ecc59cd34dd7847b783649cf5e18ab3e85280 SHA512 73b86ce55a034bc1bb4f130ef06f2e05c4a7b5c221b49c9ff1cf2f3693e42a5b30613232e823c5b4a87d201bdc8c3b2137de3b189268354145cc3866526095ab
DIST barman-3.9.0.tar.gz 1819096 BLAKE2B 712ec047f9409014495afd868a9bbe889b6b2d54a511770a95e9c62513d7042673b7c1ebec31d45729211a1da0e55dfdc5cdc0ef62d84e7efa26b2b9fbff5feb SHA512 e5b4796a470f43e4ea79383defabd31cd4d33d8dfc06495bc4485bd1bc5cfab701c3719567bcc302de3f157e9ef08a6848776daa2cf9c537fb2829b7931111fd
diff --git a/dev-db/barman/barman-3.10.0.ebuild b/dev-db/barman/barman-3.10.0.ebuild
new file mode 100644
index 000000000000..d7a56ecd1e99
--- /dev/null
+++ b/dev-db/barman/barman-3.10.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517="setuptools"
+PYTHON_COMPAT=( python3_{10..12} )
+
+RESTRICT="test" # missing azure sdk
+
+inherit distutils-r1
+
+DESCRIPTION="Administration tool for disaster recovery of PostgreSQL servers"
+HOMEPAGE="https://www.pgbarman.org https://sourceforge.net/projects/pgbarman/"
+SRC_URI="https://github.com/2ndquadrant-it/barman/archive/release/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-release-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/boto3[${PYTHON_USEDEP}]
+ dev-python/argh[${PYTHON_USEDEP}]
+ dev-python/psycopg:2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/argcomplete[${PYTHON_USEDEP}]
+ net-misc/rsync
+ dev-db/postgresql[server]
+"
+
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/python-snappy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ default
+
+ sed -i -e \
+ "s/^ def test_xlog_segment_mask(.*:/ @pytest.mark.xfail(reason='Test fails on Gentoo')\n\0/" \
+ tests/test_xlog.py || die
+}
diff --git a/dev-db/barman/barman-3.9.0.ebuild b/dev-db/barman/barman-3.9.0.ebuild
index 1c3e0f925562..d7a56ecd1e99 100644
--- a/dev-db/barman/barman-3.9.0.ebuild
+++ b/dev-db/barman/barman-3.9.0.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517="setuptools"
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
RESTRICT="test" # missing azure sdk