summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristophe Lermytte <gentoo@lermytte.be>2023-10-18 12:05:59 +0200
committerYixun Lan <dlan@gentoo.org>2023-10-18 23:38:32 +0000
commitc1a60b8ac77731c9257713441a29a59f6c91195b (patch)
treeaf4f19c25d52ec7bfebad567bafa403e5e56f462
parentdev-scheme/chez: fix install in eprefix (diff)
downloadgentoo-c1a60b8ac77731c9257713441a29a59f6c91195b.tar.gz
gentoo-c1a60b8ac77731c9257713441a29a59f6c91195b.tar.bz2
gentoo-c1a60b8ac77731c9257713441a29a59f6c91195b.zip
dev-util/stressapptest: bump to 1.0.11
also fix compilation with gcc-13 Closes: https://bugs.gentoo.org/895082 Closes: https://github.com/gentoo/gentoo/pull/33390 Signed-off-by: Christophe Lermytte <gentoo@lermytte.be> Signed-off-by: Yixun Lan <dlan@gentoo.org>
-rw-r--r--dev-util/stressapptest/Manifest1
-rw-r--r--dev-util/stressapptest/stressapptest-1.0.11.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-util/stressapptest/Manifest b/dev-util/stressapptest/Manifest
index f0b635157c3a..8ee802f008d7 100644
--- a/dev-util/stressapptest/Manifest
+++ b/dev-util/stressapptest/Manifest
@@ -1 +1,2 @@
+DIST stressapptest-1.0.11.tar.gz 230797 BLAKE2B 0b1a3cb999c3f7042ecdfc49e118d8abfb28367e9e53a646fe1c89441446b725231997321ecc599b78313a1100df31bf2057f9a60092234597cf633b8520ecd5 SHA512 4d4a1d018e03a857af16773238323a1fddaf2babde491249e80e2644bffa2673bee9a9f2c97931eda04cb9481bffe4434c0986d3660bd5d922955e7c76376597
DIST stressapptest-1.0.9.tar.gz 219517 BLAKE2B 58fdb60b924bedd526cf31ed47a56cf4cca288abb43054fc6de5379ec2c6ea705c92eec1ef657274949009e40e8fa82ee9cc6e1bda2ef160a894ba95519fcfd8 SHA512 2680b9a4e148a2fe0cb7758ffde7624c8874bbae1e7650bb4df6916512be5949996da16d52f530b237fe4c6122fa9bb2d35b11092d106f59d614b44eec250595
diff --git a/dev-util/stressapptest/stressapptest-1.0.11.ebuild b/dev-util/stressapptest/stressapptest-1.0.11.ebuild
new file mode 100644
index 000000000000..ef8787eafda4
--- /dev/null
+++ b/dev-util/stressapptest/stressapptest-1.0.11.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic
+
+DESCRIPTION="Stressful Application Test"
+HOMEPAGE="https://github.com/stressapptest/stressapptest"
+SRC_URI="https://github.com/stressapptest/stressapptest/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~x86"
+IUSE="debug"
+
+RDEPEND="dev-libs/libaio"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ # Matches the configure & sat.cc logic
+ use debug || append-cppflags -DNDEBUG -DCHECKOPTS
+ econf --disable-default-optimizations
+}