summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-01-12 06:01:58 +0000
committerSam James <sam@gentoo.org>2023-01-12 07:06:01 +0000
commitd79b44067a5f16977eca9be728c2504a69cb0485 (patch)
tree2f7d22e1c4e8f4d13431599aa04867234d4f91b6
parentdev-util/jenkins-bin: add 2.375.2 (diff)
downloadgentoo-d79b44067a5f16977eca9be728c2504a69cb0485.tar.gz
gentoo-d79b44067a5f16977eca9be728c2504a69cb0485.tar.bz2
gentoo-d79b44067a5f16977eca9be728c2504a69cb0485.zip
dev-python/pywayland: new package, add 0.4.15
Bug: https://bugs.gentoo.org/846380 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-python/pywayland/Manifest1
-rw-r--r--dev-python/pywayland/metadata.xml11
-rw-r--r--dev-python/pywayland/pywayland-0.4.15.ebuild45
3 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/pywayland/Manifest b/dev-python/pywayland/Manifest
new file mode 100644
index 000000000000..979b3c791fb9
--- /dev/null
+++ b/dev-python/pywayland/Manifest
@@ -0,0 +1 @@
+DIST pywayland-0.4.15.gh.tar.gz 61084 BLAKE2B 2417aa57942f5a7810db3525d16070ed81613bd1ab8f864a95e9f1835f9793348ad1afd2dbaeed2bb08f5bcb58777ab545f8ef7cb70903703c89998095724f8c SHA512 c45d2a24c487cf1785b7bc488808157e2dcae630438c289864df615c98278e7c03de21431fa622e0917713130f5583ff5cb3181c0a7f595cebba2cdeec36a7cf
diff --git a/dev-python/pywayland/metadata.xml b/dev-python/pywayland/metadata.xml
new file mode 100644
index 000000000000..028246926f40
--- /dev/null
+++ b/dev-python/pywayland/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">flacjacket/pywayland</remote-id>
+ <remote-id type="pypi">pywayland</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pywayland/pywayland-0.4.15.ebuild b/dev-python/pywayland/pywayland-0.4.15.ebuild
new file mode 100644
index 000000000000..66023d87ae1f
--- /dev/null
+++ b/dev-python/pywayland/pywayland-0.4.15.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="Python bindings for the libwayland library"
+HOMEPAGE="
+ https://pywayland.readthedocs.io/en/latest/
+ https://github.com/flacjacket/pywayland
+ https://pypi.org/project/pywayland/
+"
+SRC_URI="
+ https://github.com/flacjacket/pywayland/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-libs/wayland
+ virtual/python-cffi[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-libs/wayland-protocols"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Needed for tests (XDG_RUNTIME_DIR)
+ xdg_environment_reset
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # No die deliberately as sometimes it doesn't exist
+ rm -r pywayland
+
+ epytest
+}