summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-25 09:28:56 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-25 09:37:44 +0100
commitdc0102948fa8fc7853e1488dcfb9c946070ad845 (patch)
tree25d497f0349ccb374b1f0f0ee68b77f90a9c9ea3
parentdev-python/ipywidgets: Bump to 7.6.0 (diff)
downloadgentoo-dc0102948fa8fc7853e1488dcfb9c946070ad845.tar.gz
gentoo-dc0102948fa8fc7853e1488dcfb9c946070ad845.tar.bz2
gentoo-dc0102948fa8fc7853e1488dcfb9c946070ad845.zip
dev-python/graphviz: Bump to 0.16
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/graphviz/Manifest1
-rw-r--r--dev-python/graphviz/graphviz-0.16.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/graphviz/Manifest b/dev-python/graphviz/Manifest
index 6678037fff9b..ff6c67433ce8 100644
--- a/dev-python/graphviz/Manifest
+++ b/dev-python/graphviz/Manifest
@@ -1 +1,2 @@
DIST graphviz-0.15.zip 183103 BLAKE2B 81d4a121ca2654e6c08570ede7a1f5ef580b6a281358bf32f4178898fc12cfae21b10ce8f4f6fba4644e3275162cc09dbf5ae287a114fb8503be98d6a2fbf728 SHA512 c2a77f0d52595a70b4f8ccd906907453b59622560f0ff84e267e874f5a1dc9a4b721192d236b0519ee7ec85bae9b225b9919ae51bcf599c93bd5816934afd6cc
+DIST graphviz-0.16.zip 193031 BLAKE2B abedbe170eaf9d3ad83f91b5ad13aa9fbda8669ac19ebbd1087aeab3f9401b0b8e6557313e04d791451ee501c75bc2843d89d1a0f789a219b0db771467b4b8bb SHA512 7896901decf712657d4cb16fad58eab8492e1476e60a32b1a7fa37ede2e9c47ed31c00b7dedcaafdee291e2cfe6b2e2affa352282665782829fd3fb2f30bdf92
diff --git a/dev-python/graphviz/graphviz-0.16.ebuild b/dev-python/graphviz/graphviz-0.16.ebuild
new file mode 100644
index 000000000000..4af9d661d0e2
--- /dev/null
+++ b/dev-python/graphviz/graphviz-0.16.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple Python interface for Graphviz"
+HOMEPAGE="https://graphviz.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+
+RDEPEND="media-gfx/graphviz"
+BDEPEND="
+ app-arch/unzip
+ test? ( ${RDEPEND}
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-1.8[${PYTHON_USEDEP}]
+ media-gfx/graphviz[gts,pdf]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e 's:--cov --cov-report=term --cov-report=html::' \
+ -i setup.cfg || die
+ distutils-r1_src_prepare
+}