summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-04-18 23:45:57 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-04-19 00:22:33 +0200
commitdcf768987550f7c9a7a3774abf1acea19a846d46 (patch)
treeb3f446a7a4f330bac4ea4fda642b3e141e2287e5
parentapp-text/evince: Version bump to 40.1 (diff)
downloadgentoo-dcf768987550f7c9a7a3774abf1acea19a846d46.tar.gz
gentoo-dcf768987550f7c9a7a3774abf1acea19a846d46.tar.bz2
gentoo-dcf768987550f7c9a7a3774abf1acea19a846d46.zip
app-dicts/verbiste: EAPI-7, use desktop.eclass, drop ltprune, gnome2-utils
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--app-dicts/verbiste/verbiste-0.1.44.ebuild27
1 files changed, 11 insertions, 16 deletions
diff --git a/app-dicts/verbiste/verbiste-0.1.44.ebuild b/app-dicts/verbiste/verbiste-0.1.44.ebuild
index 97076d8d151a..216d19d2a72a 100644
--- a/app-dicts/verbiste/verbiste-0.1.44.ebuild
+++ b/app-dicts/verbiste/verbiste-0.1.44.ebuild
@@ -1,25 +1,25 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=7
-inherit eutils gnome2-utils ltprune xdg-utils
+inherit desktop xdg-utils
DESCRIPTION="French conjugation system"
HOMEPAGE="http://sarrazip.com/dev/verbiste.html"
SRC_URI="http://sarrazip.com/dev/${P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="amd64 ppc x86"
-
IUSE="gtk"
RDEPEND="
>=dev-libs/libxml2-2.4.0:2
gtk? ( >=x11-libs/gtk+-2.6:2 )
"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
sys-devel/gettext
virtual/pkgconfig
"
@@ -34,33 +34,28 @@ src_configure() {
src_install() {
default
- prune_libtool_files
+
dodoc HACKING LISEZMOI
# file is only installed with USE=gnome
if use gtk; then
sed -e 's/Exec=.*/Exec=verbiste-gtk/' \
-i src/gnome/verbiste.desktop || die
- insinto usr/share/applications
- doins src/gnome/verbiste.desktop
+ domenu src/gnome/verbiste.desktop
fi
-}
-pkg_preinst() {
- if use gtk; then
- gnome2_icon_savelist
- fi
+ find "${ED}" -name '*.la' -delete || die
}
pkg_postinst() {
if use gtk; then
xdg_desktop_database_update
- gnome2_icon_cache_update
+ xdg_icon_cache_update
fi
}
pkg_postrm() {
if use gtk; then
xdg_desktop_database_update
- gnome2_icon_cache_update
+ xdg_icon_cache_update
fi
}