summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-09-25 05:13:38 +0100
committerSam James <sam@gentoo.org>2023-09-25 05:14:05 +0100
commite1f74f4adf59a93307bd14ec86d8b969144a4d6d (patch)
treeda7d5d52680e7b5180a5a3310c209c29aebe8092
parentsys-libs/pkgcraft: drop 0.0.6 (diff)
downloadgentoo-e1f74f4adf59a93307bd14ec86d8b969144a4d6d.tar.gz
gentoo-e1f74f4adf59a93307bd14ec86d8b969144a4d6d.tar.bz2
gentoo-e1f74f4adf59a93307bd14ec86d8b969144a4d6d.zip
dev-python/pkgcraft: drop 0.0.5
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-python/pkgcraft/Manifest1
-rw-r--r--dev-python/pkgcraft/pkgcraft-0.0.5.ebuild78
2 files changed, 0 insertions, 79 deletions
diff --git a/dev-python/pkgcraft/Manifest b/dev-python/pkgcraft/Manifest
index a9eb28b65b2d..895bd3cece3e 100644
--- a/dev-python/pkgcraft/Manifest
+++ b/dev-python/pkgcraft/Manifest
@@ -1,2 +1 @@
-DIST pkgcraft-0.0.5.tar.gz 400237 BLAKE2B de78c1570ce8080742d3afbff2c9078b56fb14e7b097bd09b47c5b21a5de1062989835c9c12e4efd9d4be4aef7e9dec1350606700d80c5482cf81d1d2c4febc0 SHA512 2366180189314cafa4be8a180eed62a8c994bfd862ebc5292e01d9cd2585b9eca082535e405924ad758d6f89309c5e64727242a52f95f6e71aa6aff3495edd57
DIST pkgcraft-0.0.6.tar.gz 406538 BLAKE2B 5c90b57cb11e9f754cd695989994b3a9be52007482981c997f2e361fbbb72aeb0810d7f41dea1cdcd74c47840bb1c3b2cf225c967ba76b01769da93f909d9911 SHA512 ddd7bf77a3509156e8c16e5aeeb94a5f4530d9d1a3e6617d3974adfae7b46f0b0d31f4828dbd70261b42c883e776bf7572ca2fe8e23c9216637d886b9d8811cc
diff --git a/dev-python/pkgcraft/pkgcraft-0.0.5.ebuild b/dev-python/pkgcraft/pkgcraft-0.0.5.ebuild
deleted file mode 100644
index 41cf2f45a0f4..000000000000
--- a/dev-python/pkgcraft/pkgcraft-0.0.5.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python bindings for pkgcraft"
-HOMEPAGE="
- https://pypi.org/project/pkgcraft/
- https://github.com/pkgcraft/pkgcraft-python
-"
-
-if [[ ${PV} == 9999 ]] ; then
- EGIT_REPO_URI="https://github.com/pkgcraft/pkgcraft-python"
- inherit git-r3
-
- PKGCRAFT_VERSION_MAX="9999"
- PKGCRAFT_VERSION_MIN="9999"
-else
- SRC_URI="https://github.com/pkgcraft/pkgcraft-python/releases/download/v${PV}/${P/-python}.tar.gz"
- S="${WORKDIR}"/${P/-python}
-
- KEYWORDS="~amd64 ~arm64"
-
- PKGCRAFT_VERSION_MAX="9999"
- PKGCRAFT_VERSION_MIN="0.0.6"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="+examples"
-
-RDEPEND="
- <sys-libs/pkgcraft-${PKGCRAFT_VERSION_MAX}
- >=sys-libs/pkgcraft-${PKGCRAFT_VERSION_MIN}:=
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- dev-python/cython
- dev-python/setuptools-scm
- virtual/pkgconfig
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- if [[ ${PV} != 9999 ]] ; then
- local actual_pkgcraft_min=$(sed -En '/^MIN_VERSION =/{s/[^0-9.]//gp}' setup.py || die)
- if [[ ${actual_pkgcraft_min} != ${PKGCRAFT_VERSION_MIN} ]] ; then
- eerror "Expected minimum pkgcraft-c version: ${PKGCRAFT_VERSION_MIN}"
- eerror "Actual minimum pkgcraft-c version: ${actual_pkgcraft_min}"
- die "Mismatch between setup.py's MIN_VERSION and ebuild!"
- fi
- fi
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest
-}
-
-python_install() {
- # Conditional because these aren't installed officially right now
- # and the naming is just for convenience.
- if use examples ; then
- while IFS= read -r -d '' file ; do
- python_newexe "${S}"/examples/${file##*/} pkgcraft-${file##*/}
- done < <(find "${S}"/examples -type f -executable -print0 || die)
- fi
-
- distutils-r1_python_install
-}