summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-02 04:09:36 +0100
committerSam James <sam@gentoo.org>2021-04-03 16:53:57 +0100
commitfe01173cbf1e29a3b44c2aade3b0a1d2a173229a (patch)
tree2d41ba93ff6dc73fa3d0c415f354eb1844e02ca7
parentapp-admin/usbview: EAPI 7, desktop++, eutils-- (diff)
downloadgentoo-fe01173cbf1e29a3b44c2aade3b0a1d2a173229a.tar.gz
gentoo-fe01173cbf1e29a3b44c2aade3b0a1d2a173229a.tar.bz2
gentoo-fe01173cbf1e29a3b44c2aade3b0a1d2a173229a.zip
app-admin/watchfolder: EAPI 7, eutils--, implicit decl patch
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-admin/watchfolder/files/0.3.3-64bit.patch4
-rw-r--r--app-admin/watchfolder/files/0.3.3-fortify-sources.patch4
-rw-r--r--app-admin/watchfolder/files/0.3.3-implicit-decl.patch40
-rw-r--r--app-admin/watchfolder/watchfolder-0.3.3-r1.ebuild14
4 files changed, 52 insertions, 10 deletions
diff --git a/app-admin/watchfolder/files/0.3.3-64bit.patch b/app-admin/watchfolder/files/0.3.3-64bit.patch
index 070e9c019d26..89e0698c3e45 100644
--- a/app-admin/watchfolder/files/0.3.3-64bit.patch
+++ b/app-admin/watchfolder/files/0.3.3-64bit.patch
@@ -1,5 +1,5 @@
---- a/watchd.c 2006-02-23 12:33:32.000000000 -0500
-+++ b/watchd.c 2006-02-23 12:45:30.000000000 -0500
+--- a/watchd.c
++++ b/watchd.c
@@ -176,7 +176,7 @@
// free(p2tmp);
diff --git a/app-admin/watchfolder/files/0.3.3-fortify-sources.patch b/app-admin/watchfolder/files/0.3.3-fortify-sources.patch
index 175e8ed29ec3..9ccfa76c0934 100644
--- a/app-admin/watchfolder/files/0.3.3-fortify-sources.patch
+++ b/app-admin/watchfolder/files/0.3.3-fortify-sources.patch
@@ -1,5 +1,5 @@
---- a/watchd.c 2009-02-27 23:46:42.000000000 +0000
-+++ b/watchd.c 2009-02-27 23:50:22.000000000 +0000
+--- a/watchd.c
++++ b/watchd.c
@@ -671,7 +671,7 @@
{
if (folder->flags&FL_LOG_FILE)
diff --git a/app-admin/watchfolder/files/0.3.3-implicit-decl.patch b/app-admin/watchfolder/files/0.3.3-implicit-decl.patch
new file mode 100644
index 000000000000..1b8e72d72bf8
--- /dev/null
+++ b/app-admin/watchfolder/files/0.3.3-implicit-decl.patch
@@ -0,0 +1,40 @@
+--- a/chain.c
++++ b/chain.c
+@@ -21,7 +21,7 @@ Author : Peter Turczak <p_turczak@wiwa.de>
+ #include "chain.h"
+ #include <stdio.h>
+ #include <stdlib.h>
+-
++#include <string.h>
+
+ struct element* newchain()
+ {
+--- a/filedb.c
++++ b/filedb.c
+@@ -1,5 +1,7 @@
+ #include <sys/types.h>
+ #include <sys/stat.h>
++#include <stdlib.h>
++#include <string.h>
+ #include <unistd.h>
+ #include "chain.h"
+ #include "filedb.h"
+--- a/inifile.c
++++ b/inifile.c
+@@ -1,5 +1,6 @@
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <string.h>
+ #include "inifile.h"
+
+ /*
+--- a/watchd.c
++++ b/watchd.c
+@@ -25,6 +25,7 @@ Syntax : watchd
+ #include <sys/types.h>
+ #include <sys/timeb.h>
+ #include <sys/stat.h>
++#include <sys/time.h>
+ #include <sys/wait.h>
+ #include <stdio.h>
+ #include <stdlib.h>
diff --git a/app-admin/watchfolder/watchfolder-0.3.3-r1.ebuild b/app-admin/watchfolder/watchfolder-0.3.3-r1.ebuild
index d6fc7c4146b5..1622add191e4 100644
--- a/app-admin/watchfolder/watchfolder-0.3.3-r1.ebuild
+++ b/app-admin/watchfolder/watchfolder-0.3.3-r1.ebuild
@@ -1,29 +1,31 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
-DESCRIPTION="watches directories and processes files"
+DESCRIPTION="Watches directories and processes files"
HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
SRC_URI="mirror://gentoo/${P}.tar.gz"
+S="${WORKDIR}/${P/folder/d}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 ~ppc ~x86"
-S="${WORKDIR}/${P/folder/d}"
-
PATCHES=(
# patch to remove warnings on 64 bit systems
"${FILESDIR}"/${PV}-64bit.patch
# and a gcc 4.3.3 / fortify_sources fix
"${FILESDIR}"/${PV}-fortify-sources.patch
+ # various implicit declarations
+ "${FILESDIR}"/${PV}-implicit-decl.patch
)
src_prepare() {
default
+
sed -i \
-e '/-c -o/s:OPT:CFLAGS:' \
-e 's:(\(LD\)\?OPT):(LDFLAGS) $(CFLAGS):' \