summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-12-15 12:10:29 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2020-12-15 14:12:25 -0600
commit080b294ea2a40ef9d0cc9ef6f72e82e76896aad8 (patch)
treebbcfdfef171e518d6f6a1de2d879729a4fe30bb3 /app-admin/ansible-base/ansible-base-2.10.4.ebuild
parentapp-admin/ansible: 2.10.4 bump (diff)
downloadgentoo-080b294ea2a40ef9d0cc9ef6f72e82e76896aad8.tar.gz
gentoo-080b294ea2a40ef9d0cc9ef6f72e82e76896aad8.tar.bz2
gentoo-080b294ea2a40ef9d0cc9ef6f72e82e76896aad8.zip
app-admin/ansible-base: 2.10.4 bump
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-admin/ansible-base/ansible-base-2.10.4.ebuild')
-rw-r--r--app-admin/ansible-base/ansible-base-2.10.4.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/app-admin/ansible-base/ansible-base-2.10.4.ebuild b/app-admin/ansible-base/ansible-base-2.10.4.ebuild
new file mode 100644
index 000000000000..f376ff42569a
--- /dev/null
+++ b/app-admin/ansible-base/ansible-base-2.10.4.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Model-driven deployment, config management, and command execution framework"
+HOMEPAGE="https://ansible.com/"
+SRC_URI="https://releases.ansible.com/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~x64-macos"
+IUSE="test"
+RESTRICT="test"
+# doc removed due to https://github.com/ansible/ansible/issues/71395
+
+RDEPEND="
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/netaddr[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ net-misc/sshpass
+ virtual/ssh
+ !<app-admin/ansible-2.10
+"
+# ansible-2.10 or above is needed for the collections
+DEPEND="
+ !<app-admin/ansible-2.10
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/packaging-16.6[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ dev-python/passlib[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )"
+
+python_compile() {
+ # disable version checks on upgrade
+ export ANSIBLE_SKIP_CONFLICT_CHECK=1
+ distutils-r1_python_compile
+}
+
+python_test() {
+ nosetests -d -w test/units -v --with-coverage --cover-package=ansible --cover-branches || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ dodoc -r examples
+}