summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2024-03-29 10:44:20 +0000
committerMarek Szuba <marecki@gentoo.org>2024-03-29 10:44:20 +0000
commit5ea05a907d6accf942289a75a6b226390e05f88b (patch)
tree8b3958310dfa85cb8f9615ed179af374833be9dc /app-admin/ansible-lint
parentapp-misc/gramps: add 5.2.1 (diff)
downloadgentoo-5ea05a907d6accf942289a75a6b226390e05f88b.tar.gz
gentoo-5ea05a907d6accf942289a75a6b226390e05f88b.tar.bz2
gentoo-5ea05a907d6accf942289a75a6b226390e05f88b.zip
app-admin/ansible-lint: add 24.2.1
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-admin/ansible-lint')
-rw-r--r--app-admin/ansible-lint/Manifest1
-rw-r--r--app-admin/ansible-lint/ansible-lint-24.2.1.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/app-admin/ansible-lint/Manifest b/app-admin/ansible-lint/Manifest
index 6a7b426a5e91..6b2d6daeb705 100644
--- a/app-admin/ansible-lint/Manifest
+++ b/app-admin/ansible-lint/Manifest
@@ -1,2 +1,3 @@
DIST ansible-lint-24.2.0.tar.gz 513719 BLAKE2B 54e05acf982cf13cb2142a10bf04250171f07936df14933525dfae68b312a0d92ceb30867603dc7ce686206b7de010f6ca4eb9ab532ca000fc3c15c77c354c81 SHA512 3276d28c7b85a6087a0142cc56442efddf9ff3e81155455c74686015a2ab45ece64847b0243373ad01145e67599d8449866c122efe8ae404cd819011e41c5235
+DIST ansible-lint-24.2.1.tar.gz 515269 BLAKE2B b6467058665bb46813e910a0245e688dd6cb1b9010b2297c23dc1ea28861b9a20310b54ee761346a1136b6d166f96df79bb6d21019b3054033044181403b0c2b SHA512 de8b8ff3409b95cdadf1beaa4eb5fcd15a06142589b4ce53e0c6b12a9e84613337ef6173bfbeabd3d874ddccb114337e766371c7d3ba8bec831563a8fc232311
DIST ansible-lint-6.22.2.tar.gz 513988 BLAKE2B b46764751a84ff2a699203bf07f4a04362faa99d7433af6ead9f7ada9e581ff8b3d9bbf205a0127950e15e4413a72fc057cd10588dffec2fb9621f58620ae1ca SHA512 b48dec138a37754135e48007636f020524947342ab40f2b9dea36e10989e88ee6899e4742f1715feecfd7e239c80d3bed0581558c39eac783a84523507740180
diff --git a/app-admin/ansible-lint/ansible-lint-24.2.1.ebuild b/app-admin/ansible-lint/ansible-lint-24.2.1.ebuild
new file mode 100644
index 000000000000..e8e336e27738
--- /dev/null
+++ b/app-admin/ansible-lint/ansible-lint-24.2.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Checks ansible playbooks for practices and behaviour that can be improved"
+HOMEPAGE="https://github.com/ansible/ansible-lint"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv"
+
+# Upstream has stated explicitly that all tests require Internet access
+PROPERTIES="test_network"
+RESTRICT="test"
+
+RDEPEND="
+ >=app-admin/ansible-core-2.12.0[${PYTHON_USEDEP}]
+ >=dev-python/ansible-compat-4.1.11[${PYTHON_USEDEP}]
+ >=dev-python/black-22.8.0[${PYTHON_USEDEP}]
+ >=dev-python/filelock-3.8.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.17.0[${PYTHON_USEDEP}]
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+ >=dev-python/pathspec-0.10.3[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.4.1[${PYTHON_USEDEP}]
+ >=dev-python/rich-12.0.0[${PYTHON_USEDEP}]
+ >=dev-python/ruamel-yaml-0.18.5[${PYTHON_USEDEP}]
+ >=dev-python/wcmatch-8.3.2[${PYTHON_USEDEP}]
+ >=dev-util/yamllint-1.30.0[${PYTHON_USEDEP}]
+ dev-vcs/git"
+BDEPEND="
+ >=dev-python/setuptools-scm-7.0.5[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mypy[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ >=dev-python/pytest-plus-0.6[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-2.5.0[${PYTHON_USEDEP}]
+ )"
+
+# test_call_from_outside_venv doesn't play nicely with the sandbox
+# irrespective of whether Internet access is allowed or not
+EPYTEST_DESELECT=(
+ test/test_main.py::test_call_from_outside_venv
+)
+
+distutils_enable_tests pytest
+
+# Test suite fails to start without this
+python_test() {
+ epytest test
+}